From 50a596f7dec079904365c4685771e26f55e9f645 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Fri, 3 Dec 2010 03:27:30 +0000
Subject: twisted: initial include for deluge

---
 abs/extra/community/twisted/PKGBUILD        | 29 +++++++++++++++++++++++++++++
 abs/extra/community/twisted/twisted.install | 11 +++++++++++
 2 files changed, 40 insertions(+)
 create mode 100644 abs/extra/community/twisted/PKGBUILD
 create mode 100644 abs/extra/community/twisted/twisted.install

diff --git a/abs/extra/community/twisted/PKGBUILD b/abs/extra/community/twisted/PKGBUILD
new file mode 100644
index 0000000..e008e92
--- /dev/null
+++ b/abs/extra/community/twisted/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 94591 2010-10-08 12:55:33Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor:  Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=twisted
+pkgver=10.1.0
+pkgrel=1
+pkgdesc="Asynchronous networking framework written in Python."
+arch=('i686' 'x86_64')
+url="http://twistedmatrix.com/"
+license=('MIT')
+depends=('python2' 'pycrypto' 'zope-interface')
+optdepends=('pyopenssl'
+            'python-soappy:for twisted.web.soap')
+install=twisted.install
+source=(http://tmrc.mit.edu/mirror/twisted/Twisted/${pkgver%.*}/Twisted-${pkgver}.tar.bz2)
+md5sums=('04cca97506e830074cffc1965297da3f')
+build() {
+  cd "${srcdir}/Twisted-${pkgver}"
+
+  python2 setup.py install --prefix=/usr --root=$pkgdir --optimize=1
+  install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+  sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+      -i ${pkgdir}/usr/lib/python2.7/site-packages/twisted/trial/test/scripttest.py
+  sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+      -i ${pkgdir}/usr/lib/python2.7/site-packages/twisted/mail/test/pop3testserver.py
+}
diff --git a/abs/extra/community/twisted/twisted.install b/abs/extra/community/twisted/twisted.install
new file mode 100644
index 0000000..8e93ffd
--- /dev/null
+++ b/abs/extra/community/twisted/twisted.install
@@ -0,0 +1,11 @@
+post_install() {
+  python2 -c 'from twisted.plugin import IPlugin, getPlugins; list(getPlugins(IPlugin))' >/dev/null 2>&1 || return 1
+}
+
+post_upgrade() {
+  post_install
+}
+
+post_remove() {
+  find /usr/lib/python2.7/site-packages/twisted/plugins -name dropin.cache | xargs -r rm -f
+}
-- 
cgit v0.12