From fdb5bfb2a43c93c8e7636b0bf6738360ab89a20a Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Wed, 8 Jul 2009 00:06:54 -0700
Subject: Made ATI Remote Wonder more responsive.

---
 abs/core-testing/system-templates/PKGBUILD         |  2 +-
 .../templates/remotes/ATI_Remote_Wonder/lircrc     | 44 ++++++++++++++++++++++
 2 files changed, 45 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/system-templates/PKGBUILD b/abs/core-testing/system-templates/PKGBUILD
index b1c407c..60637bc 100755
--- a/abs/core-testing/system-templates/PKGBUILD
+++ b/abs/core-testing/system-templates/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=system-templates
 pkgver=1.0
-pkgrel=25
+pkgrel=26
 conflicts=( )
 pkgdesc="Templates used for system configuration"
 depends=()
diff --git a/abs/core-testing/system-templates/templates/remotes/ATI_Remote_Wonder/lircrc b/abs/core-testing/system-templates/templates/remotes/ATI_Remote_Wonder/lircrc
index a2f1ebb..01519a8 100644
--- a/abs/core-testing/system-templates/templates/remotes/ATI_Remote_Wonder/lircrc
+++ b/abs/core-testing/system-templates/templates/remotes/ATI_Remote_Wonder/lircrc
@@ -10,6 +10,7 @@ begin
     prog = mythtv
     button = tv
     config = ! 
+    repeat = 5
 end
 
 begin
@@ -17,6 +18,7 @@ begin
     prog = mythtv
     button = dvd
     config = @
+    repeat = 5
 end
 
 begin
@@ -24,6 +26,7 @@ begin
 #Jumppoint for MythWeater created in Mythweb
     button = web
     config = #
+    repeat = 5
 end
 
 begin
@@ -31,6 +34,7 @@ begin
 #Jumppoint for MythVideo created in Mythweb
     button = media_library
     config = $
+    repeat = 5
 end
 
 begin
@@ -38,6 +42,7 @@ begin
 #Jumppoint for MythWeater created in Mythweb
     button = HAND
     config = %
+    repeat = 5
 end
 
 begin
@@ -114,30 +119,35 @@ begin
     prog = mythtv
     button = mouse-up
     config = Up
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = mouse-down
     config = Down
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = mouse-left
     config = Left
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = mouse-right
     config = Right
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = mouse-button-right
     config = Esc
+    repeat = 5
 end
 
 begin
@@ -145,12 +155,14 @@ begin
 # Enter button
     button = mouse-button-left
     config = Return
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = power
     config = Esc
+    repeat = 5
 end
 
 begin
@@ -158,48 +170,56 @@ begin
 # Enter button
     button = ok
     config = Return
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = cursor-up
     config = Up
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = cursor-down
     config = Down
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = cursor-left
     config = Left
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = cursor-right
     config = Right
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = D
     config = Esc
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = chan-up
 config = Up
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = chan-down
 config = Down
+    repeat = 5
 end
 
 begin
@@ -219,6 +239,7 @@ begin
     prog = mythtv
     button = mute
     config = F9  
+    repeat = 5
 end
 
 begin
@@ -226,12 +247,14 @@ begin
     prog = mythtv
     button = mute
     config = |  
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = dvd-root_menu
     config = M  
+    repeat = 5
 end
 
 begin
@@ -239,6 +262,7 @@ begin
 # Enter button
     button = launch_setup
     config = Return
+    repeat = 5
 end
 
 
@@ -246,18 +270,21 @@ begin
     prog = mythtv
     button = a 
     config = S  
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = b
     config = I   
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = c
     config = T   
+    repeat = 5
 end
 
 begin
@@ -265,6 +292,7 @@ prog = mythtv
 # Change focus for PiP (to change channel in the other window)
 button = max_window
 config = B
+    repeat = 5
 end
 
 begin
@@ -272,12 +300,14 @@ prog = mythtv
 # Toggle PiP on/off
 button = tv_on_demand
 config = V
+    repeat = 5
 end
 
 begin
     prog = mythtv
     button = rewind
     config = Left  
+    repeat = 5
 end
 
 
@@ -285,30 +315,35 @@ begin
     prog = mythtv
     button = fastforward
     config = Right  
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = record
 config = R
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = stop
 config = Esc
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = play
 config = P
+    repeat = 5
 end
 
 begin
 prog = mythtv
 button = pause
 config = P
+    repeat = 5
 end
 
 begin
@@ -316,6 +351,7 @@ prog = mythtv
 button = e
 # Use for backwards commercial skip
 config = Q
+    repeat = 5
 end
 
 begin
@@ -323,6 +359,7 @@ prog = mythtv
 button = f
 # Use for forward commercial skip
 config = Z
+    repeat = 5
 end
 
 #Mplayer
@@ -331,42 +368,49 @@ begin
 prog = mplayer
 button = play
 config = pause
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = pause
 config = pause
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = stop
 config = quit
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = power
 config = quit
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = d
 config = quit
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = mouse-button-right
 config = quit
+    repeat = 5
 end
 
 begin
 prog = mplayer
 button = mute
 config = mute
+    repeat = 5
 end
 
 begin
-- 
cgit v0.12