From b4b0e51c3d581e4d271d58e445fdfeeb728c04bc Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 6 Aug 2011 23:53:15 -0500
Subject: js: Roll back to v1.7.0 for perl-javascript dep of shepherd. refs
 #383

---
 abs/extra/community/js/PKGBUILD                    | 60 ++++++++++------------
 abs/extra/community/js/js185-destdir.patch         | 15 ------
 .../community/js/spidermonkey-1.7-threadsafe.patch | 16 ++++++
 abs/extra/community/js/spidermonkey-Makefile.patch | 22 ++++++++
 4 files changed, 64 insertions(+), 49 deletions(-)
 delete mode 100644 abs/extra/community/js/js185-destdir.patch
 create mode 100644 abs/extra/community/js/spidermonkey-1.7-threadsafe.patch
 create mode 100644 abs/extra/community/js/spidermonkey-Makefile.patch

diff --git a/abs/extra/community/js/PKGBUILD b/abs/extra/community/js/PKGBUILD
index 35db2db..d55295c 100644
--- a/abs/extra/community/js/PKGBUILD
+++ b/abs/extra/community/js/PKGBUILD
@@ -1,39 +1,31 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
 pkgname=js
-pkgver=1.8.5
-pkgrel=3
-pkgdesc="JavaScript interpreter and libraries"
-arch=(i686 x86_64)
-url="https://developer.mozilla.org/En/SpiderMonkey/1.8.5"
-license=('GPL2')
-depends=('nspr' 'gcc-libs')
-makedepends=('python2' 'zip')
+pkgver=1.7.0
+pkgrel=1
+epoch=1
+pkgdesc="Mozilla's C implementation of JavaScript."
+arch=("i686" "x86_64")
+url="http://www.mozilla.org/js/spidermonkey/"
+license=('MPL' 'GPL' 'LGPL')
+depends=('nspr')
+options=('!makeflags')
 replaces=('spidermonkey')
 conflicts=('spidermonkey')
-source=(http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
-        js185-destdir.patch)
-md5sums=('a4574365938222adca0a6bd33329cb32'
-         '364834a8391888642c53d78c3a949d94')
-build() {
-  cd "$srcdir/$pkgname-$pkgver/js/src"
-
-  patch -Np0 -i $srcdir/js185-destdir.patch
-
-  ./configure --prefix=/usr --with-system-nspr \
-     --enable-threadsafe
-
-  make
-}
+source=("http://ftp.mozilla.org/pub/mozilla.org/js/js-$pkgver.tar.gz" \
+	"spidermonkey-1.7-threadsafe.patch" "spidermonkey-Makefile.patch")
+md5sums=('5571134c3863686b623ebe4e6b1f6fe6'
+	'b2ef9be017b6aa1857354b5223975a4f'
+	'161d4c0f2c604d15cba29dab60b1f7a7')
 
-package() {
-  cd "$srcdir/$pkgname-$pkgver/js/src"
-  make DESTDIR="$pkgdir" install
-
-  install -m 0755 shell/js ${pkgdir}/usr/bin
-
-  #cleanup
-  rm -f "${pkgdir}/usr/lib/libmozjs185-1.0.a"
+build() {
+  cd "$srcdir/js/src"
+  patch -p0 < "$srcdir/spidermonkey-Makefile.patch" || return 1
+  sed -i 's|include|include/js|' rules.mk || return 1
+  # fix for the lib location
+  [ "$CARCH" = "x86_64" ] && (sed -i -e "s:lib64:lib:g" config.mk || return 1)
+  # patch Makefile for threadsafe support with native nspr
+  patch -p2 -i "$srcdir/spidermonkey-1.7-threadsafe.patch" || return 1
+  # FS#16673
+  export CFLAGS="${CFLAGS} -DJS_C_STRINGS_ARE_UTF8"
+  # build - threadsafe
+  make -f Makefile.ref BUILD_OPT=1 JS_THREADSAFE=1 DIST="$pkgdir/usr" all export || return 1
 }
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/community/js/js185-destdir.patch b/abs/extra/community/js/js185-destdir.patch
deleted file mode 100644
index 87b7b53..0000000
--- a/abs/extra/community/js/js185-destdir.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-#https://bugzilla.mozilla.org/show_bug.cgi?id=628723
-
---- Makefile.in.old	2011-04-10 04:21:19.918608008 -0700
-+++ Makefile.in	2011-04-10 04:21:58.088607992 -0700
-@@ -888,8 +888,8 @@
- ifeq (,$(HOST_BIN_SUFFIX))
- 	mv -f $(SHLIB_ANY_VER) $(SHLIB_EXACT_VER)
- 	@[ ! -h $(SHLIB_ABI_VER) ] || rm -f $(SHLIB_ABI_VER)
--	ln -s $(SHLIB_EXACT_VER) $(SHLIB_ABI_VER)
--	ln -s $(SHLIB_ABI_VER) $(SHLIB_ANY_VER)
-+	ln -s $(notdir $(SHLIB_EXACT_VER)) $(SHLIB_ABI_VER)
-+	ln -s $(notdir $(SHLIB_ABI_VER)) $(SHLIB_ANY_VER)
- endif
- endif
- ifneq (,$(IMPORT_LIBRARY))
diff --git a/abs/extra/community/js/spidermonkey-1.7-threadsafe.patch b/abs/extra/community/js/spidermonkey-1.7-threadsafe.patch
new file mode 100644
index 0000000..da6c78d
--- /dev/null
+++ b/abs/extra/community/js/spidermonkey-1.7-threadsafe.patch
@@ -0,0 +1,16 @@
+--- js/src/Makefile.ref.orig	2008-05-28 19:51:32.000000000 -0400
++++ js/src/Makefile.ref	2008-05-28 19:52:17.000000000 -0400
+@@ -63,11 +63,11 @@
+ 
+ ifdef JS_THREADSAFE
+ DEFINES += -DJS_THREADSAFE
+-INCLUDES += -I$(DIST)/include/nspr
++INCLUDES += -I/usr/include/nspr
+ ifdef USE_MSVC
+ OTHER_LIBS += $(DIST)/lib/libnspr$(NSPR_LIBSUFFIX).lib
+ else
+-OTHER_LIBS += -L$(DIST)/lib -lnspr$(NSPR_LIBSUFFIX)
++OTHER_LIBS += -L/usr/$(LIBDIR)/nspr -lnspr${NSPR_LIBSUFFIX}
+ endif
+ endif
+ 
diff --git a/abs/extra/community/js/spidermonkey-Makefile.patch b/abs/extra/community/js/spidermonkey-Makefile.patch
new file mode 100644
index 0000000..abf1f31
--- /dev/null
+++ b/abs/extra/community/js/spidermonkey-Makefile.patch
@@ -0,0 +1,22 @@
+*** Makefile.ref.orig	2009-02-16 09:56:29.000000000 -0600
+--- Makefile.ref	2009-02-16 09:58:59.000000000 -0600
+***************
+*** 169,184 ****
+--- 169,185 ----
+  	jstypes.h	\
+  	jsprvtd.h	\
+  	jspubtd.h	\
+  	jsregexp.h	\
+  	jsscan.h	\
+  	jsscope.h	\
+  	jsscript.h	\
+  	jsstr.h		\
++ 	jsutil.h        \
+  	jsxdrapi.h	\
+  	jsxml.h		\
+  	$(NULL)
+  
+  API_HFILES =		\
+  	jsapi.h		\
+  	jsdbgapi.h	\
+  	$(NULL)
-- 
cgit v0.12