From cefb9fd29fa48a5e9b3c12a665702bb620e1b174 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sun, 17 Jul 2011 13:41:47 -0700
Subject: module-init-tools:bump to latest

---
 abs/core/module-init-tools/PKGBUILD                |  31 ++-
 abs/core/module-init-tools/docfix.patch            |  90 +++++++
 .../fix-modprobe-ignore-path.patch                 |  14 --
 abs/core/module-init-tools/makefile.patch          |  22 --
 .../module-init-tools-3.16-1.src.tar.gz            | Bin 0 -> 1426 bytes
 .../module-init-tools/module-init-tools.install    |   6 -
 abs/core/module-init-tools/modutils-gcc4.patch     | 280 ---------------------
 7 files changed, 105 insertions(+), 338 deletions(-)
 create mode 100644 abs/core/module-init-tools/docfix.patch
 delete mode 100644 abs/core/module-init-tools/fix-modprobe-ignore-path.patch
 delete mode 100644 abs/core/module-init-tools/makefile.patch
 create mode 100644 abs/core/module-init-tools/module-init-tools-3.16-1.src.tar.gz
 delete mode 100644 abs/core/module-init-tools/module-init-tools.install
 delete mode 100644 abs/core/module-init-tools/modutils-gcc4.patch

diff --git a/abs/core/module-init-tools/PKGBUILD b/abs/core/module-init-tools/PKGBUILD
index 10ff2b0..e65f419 100644
--- a/abs/core/module-init-tools/PKGBUILD
+++ b/abs/core/module-init-tools/PKGBUILD
@@ -1,29 +1,31 @@
-# $Id: PKGBUILD 85722 2010-07-18 10:36:50Z allan $
+# $Id: PKGBUILD 128937 2011-06-25 14:35:00Z dreisner $
 # Maintainer: Aaron Griffin <aaron@archlinux.org>
 # Contributor: judd <jvinet@zeroflux.org>
 
 pkgname=module-init-tools
-pkgver=3.12
-pkgrel=3
+pkgver=3.16
+pkgrel=1
 pkgdesc="utilities needed by Linux systems for managing loadable kernel modules"
 arch=('i686' 'x86_64')
 url="http://kerneltools.org"
 license=('GPL')
 depends=('glibc')
-install=module-init-tools.install
+makedepends=('docbook2x')
 backup=('etc/modprobe.d/modprobe.conf')
 source=(http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-$pkgver.tar.bz2
-        modprobe.conf)
-md5sums=('8b2257ce9abef74c4a44d825d23140f3'
-         '316f1bda4c21af02b30252eb014a0a55')
+        modprobe.conf
+        docfix.patch)
+md5sums=('bc44832c6e41707b8447e2847d2019f5'
+         '316f1bda4c21af02b30252eb014a0a55'
+         '4320d19902ded43bed55c804b065cdc7')
 
 build() {
   cd $srcdir/$pkgname-$pkgver
-  
-  # do not regenerate man pages
-  touch *.{5,8}
-  
-  ./configure --prefix=/usr --exec-prefix=/
+
+  # fix headers in SGML manpage sources and an XML typo
+  patch -Np0 < "$srcdir/docfix.patch"
+
+  ./configure --prefix=/usr --exec-prefix=/ --enable-zlib
   make
 }
 
@@ -31,10 +33,7 @@ package() {
   cd $srcdir/$pkgname-$pkgver
 
   make DESTDIR=$pkgdir install
- 
+
   # Install our custom (read: empty) modprobe.conf
   install -Dm644 $srcdir/modprobe.conf $pkgdir/etc/modprobe.d/modprobe.conf
-  
-  # fix man page (FS#17559)
-  sed -i "s#mod#man5/mod#" $pkgdir/usr/share/man/man5/modprobe.d.5
 }
diff --git a/abs/core/module-init-tools/docfix.patch b/abs/core/module-init-tools/docfix.patch
new file mode 100644
index 0000000..0151ca3
--- /dev/null
+++ b/abs/core/module-init-tools/docfix.patch
@@ -0,0 +1,90 @@
+--- doc/depmod.conf.sgml.orig	2011-06-25 10:07:15.897805024 -0400
++++ doc/depmod.conf.sgml	2011-06-25 10:07:48.810805020 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/depmod.sgml.orig	2011-06-25 10:07:15.898805024 -0400
++++ doc/depmod.sgml	2011-06-25 10:07:56.636805021 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+@@ -52,7 +52,7 @@
+       <arg><option>-n</option></arg>
+       <arg><option>-v</option></arg>
+       <arg><option>-P <replaceable>prefix</replaceable></option></arg>
+-      <arg><option>-w</option><arg>
++      <arg><option>-w</option></arg>
+       <arg><option><replaceable>version</replaceable></option></arg>
+       <arg rep='repeat'><option><replaceable>filename</replaceable></option></arg>
+     </cmdsynopsis>
+--- doc/insmod.sgml.orig	2011-06-25 10:07:15.899805024 -0400
++++ doc/insmod.sgml	2011-06-25 10:07:59.228805019 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/lsmod.sgml.orig	2011-06-25 10:07:15.899805024 -0400
++++ doc/lsmod.sgml	2011-06-25 10:08:04.804805020 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/modinfo.sgml.orig	2011-06-25 10:07:15.900805024 -0400
++++ doc/modinfo.sgml	2011-06-25 10:08:07.630805019 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/modprobe.conf.sgml.orig	2011-06-25 10:07:15.901805024 -0400
++++ doc/modprobe.conf.sgml	2011-06-25 10:08:10.173805018 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/modprobe.sgml.orig	2011-06-25 10:07:15.902805024 -0400
++++ doc/modprobe.sgml	2011-06-25 10:08:13.623805019 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/modules.dep.sgml.orig	2011-06-25 10:07:15.903805024 -0400
++++ doc/modules.dep.sgml	2011-06-25 10:08:19.323805019 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
+--- doc/rmmod.sgml.orig	2011-06-25 10:07:15.904805024 -0400
++++ doc/rmmod.sgml	2011-06-25 10:08:27.691805017 -0400
+@@ -1,4 +1,5 @@
+-<!doctype refentry PUBLIC "-//OASIS//DTD DocBook V4.1//EN" [
++<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook V4.1.2//EN"
++  "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+   <!ENTITY debian  "<productname>Debian GNU/Linux</productname>">
+   <!ENTITY docbook "<productname>DocBook</productname>">
+   <!ENTITY sgml    "<abbrev>SGML</abbrev>">
diff --git a/abs/core/module-init-tools/fix-modprobe-ignore-path.patch b/abs/core/module-init-tools/fix-modprobe-ignore-path.patch
deleted file mode 100644
index c562b3f..0000000
--- a/abs/core/module-init-tools/fix-modprobe-ignore-path.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- modprobe.c~	2005-12-02 00:42:09.000000000 +0100
-+++ modprobe.c	2008-03-12 09:39:14.000000000 +0100
-@@ -1236,9 +1236,8 @@
- 
- 	/* Try defaults. */
- 	for (i = 0; i < ARRAY_SIZE(default_configs); i++) {
--		if (read_config(default_configs[i], name, dump_only, removing,
--				options, commands, aliases, blacklist))
--			return;
-+		read_config(default_configs[i], name, dump_only, removing,
-+				options, commands, aliases, blacklist);
- 	}
- }
- 
diff --git a/abs/core/module-init-tools/makefile.patch b/abs/core/module-init-tools/makefile.patch
deleted file mode 100644
index 458b062..0000000
--- a/abs/core/module-init-tools/makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur module-init-tools-3.1-orig/Makefile.in module-init-tools-3.1/Makefile.in
---- module-init-tools-3.1-orig/Makefile.in	2004-11-14 16:59:48.000000000 -0800
-+++ module-init-tools-3.1/Makefile.in	2004-11-19 11:09:36.000000000 -0800
-@@ -704,18 +704,8 @@
- 
- # docbook2man writes file itself, doesn't do stdout.
- %.8: doc/%.sgml
--	if [ "$(DOCBOOKTOMAN)" = "docbook2man" ]; then                     \
--	    $(DOCBOOKTOMAN) $< > /dev/null 2>&1;                       \
--	else                                                               \
--	    $(DOCBOOKTOMAN) $< 2>&1 > $@ | sed 's/^[^:]*://';              \
--	fi
- 
- %.5: doc/%.sgml
--	if [ "$(DOCBOOKTOMAN)" = "docbook2man" ]; then                     \
--	    $(DOCBOOKTOMAN) $< > /dev/null 2>&1;                       \
--	else                                                               \
--	    $(DOCBOOKTOMAN) $< 2>&1 > $@ | sed 's/^[^:]*://';              \
--	fi
- 
- # docbook2man creates extra crap files which need cleaning.
- distclean: killbuildmanpages
diff --git a/abs/core/module-init-tools/module-init-tools-3.16-1.src.tar.gz b/abs/core/module-init-tools/module-init-tools-3.16-1.src.tar.gz
new file mode 100644
index 0000000..b75ae8b
Binary files /dev/null and b/abs/core/module-init-tools/module-init-tools-3.16-1.src.tar.gz differ
diff --git a/abs/core/module-init-tools/module-init-tools.install b/abs/core/module-init-tools/module-init-tools.install
deleted file mode 100644
index 169060f..0000000
--- a/abs/core/module-init-tools/module-init-tools.install
+++ /dev/null
@@ -1,6 +0,0 @@
-pre_upgrade() {
-   if [ -f /etc/modprobe.conf ]
-     then
-       mv /etc/modprobe.conf /etc/modprobe.d/modprobe.conf
-   fi
-}
diff --git a/abs/core/module-init-tools/modutils-gcc4.patch b/abs/core/module-init-tools/modutils-gcc4.patch
deleted file mode 100644
index 3f90a9b..0000000
--- a/abs/core/module-init-tools/modutils-gcc4.patch
+++ /dev/null
@@ -1,280 +0,0 @@
-Fix building with newer gcc versions.
-
-Most changes taken from Debian.
-
---- obj/obj_ia64.c
-+++ obj/obj_ia64.c
-@@ -127,6 +127,7 @@
- 	return (*(bundle + 1) >> 23) & 0x1ffffffffff;
- 
-     default:
-+	;
-     }
-     return (-1);
- }
---- depmod/depmod.c
-+++ depmod/depmod.c
-@@ -1133,7 +1133,7 @@
- 
- 		for (ksym = ksyms; so_far < nksyms; ++so_far, ksym++) {
- 			if (strncmp((char *)ksym->name, "GPLONLY_", 8) == 0)
--				((char *)ksym->name) += 8;
-+				ksym->name = ((char *)ksym->name) + 8;
- 			assert(n_syms < MAX_MAP_SYM);
- 			symtab[n_syms++] = addsym((char *)ksym->name, mod, SYM_DEFINED, 0);
- 		}
-@@ -1265,7 +1265,7 @@
- 				 * error.  Use the error() routine but do not count
- 				 * any errors.  Remove in 2.5.
- 				 */
--				int save_errors = errors;
-+				int save_errors = error_count;
- 				if (!quiet && nberr == 0)
- 					error("*** Unresolved symbols in %s",
- 					      ptmod->name);
-@@ -1274,7 +1274,7 @@
- 				nberr++;
- 				if (flag_unresolved_error)
- 					ret = 1;
--				errors = save_errors;
-+				error_count = save_errors;
- 			}
- 		}
- 		verbose("%s\n", ptmod->name + skipchars);
-@@ -1675,6 +1675,6 @@
- #else
- int main(int argc, char **argv)
- {
--	return depmod_main(argc, argv) || errors;
-+	return depmod_main(argc, argv) || error_count;
- }
- #endif	/* defined(COMMON_3264) && defined(ONLY_32) */
---- genksyms/genksyms.c
-+++ genksyms/genksyms.c
-@@ -45,7 +45,7 @@
- int flag_debug, flag_dump_defs, flag_warnings;
- int checksum_version = 1, kernel_version = version(2,0,0);
- 
--static int errors;
-+static int num_errors;
- static int nsyms;
- 
- static struct symbol *expansion_trail;
-@@ -458,7 +458,7 @@
-       va_end(args);
-       putc('\n', stderr);
- 
--      errors++;
-+      num_errors++;
-     }
- }
- 
-@@ -476,7 +476,7 @@
-       va_end(args);
-       putc('\n', stderr);
- 
--      errors++;
-+      num_errors++;
-     }
- }
- 
-@@ -597,5 +597,5 @@
- 	      nsyms, HASH_BUCKETS, (double)nsyms / (double)HASH_BUCKETS);
-     }
- 
--  return errors != 0;
-+  return num_errors != 0;
- }
---- include/util.h
-+++ include/util.h
-@@ -39,8 +39,8 @@
- extern int xftw(const char *directory, xftw_func_t);
- 
- /* Error logging */
--extern int log;
--extern int errors;
-+extern int logging;
-+extern int error_count;
- extern const char *error_file;
- 
- extern int flag_verbose;
---- insmod/insmod.c
-+++ insmod/insmod.c
-@@ -275,7 +275,7 @@
- 		if (strncmp((char *)s->name, "GPLONLY_", 8) == 0) {
- 			gplonly_seen = 1;
- 			if (gpl)
--				((char *)s->name) += 8;
-+				s->name = ((char *)s->name) + 8;
- 			else
- 				continue;
- 		}
-@@ -1679,7 +1679,7 @@
- 	error_file = "insmod";
- 
- 	/* To handle repeated calls from combined modprobe */
--	errors = optind = 0;
-+	error_count = optind = 0;
- 
- 	/* Process the command line.  */
- 	while ((o = getopt_long(argc, argv, "fhkLmnpqrsSvVxXyYNe:o:O:P:R:",
-@@ -2064,7 +2064,7 @@
- 		goto out;
- 	/**** No symbols or sections to be changed after kallsyms above ***/
- 
--	if (errors)
-+	if (error_count)
- 		goto out;
- 
- 	/* If we were just checking, we made it.  */
-@@ -2123,10 +2123,10 @@
- 		test_read.m.read_start = m_addr + sizeof(struct module);
- 		test_read.m.read_end = test_read.m.read_start + sizeof(test_read.data);
- 		if (sys_init_module(m_name, (struct module *) &test_read)) {
--			int old_errors = errors;
-+			int old_errors = error_count;
- 			error("has persistent data but the kernel is too old to support it."
- 				"  Expect errors during rmmod as well");
--			errors = old_errors;
-+			error_count = old_errors;
- 		}
- 	}
- 
-@@ -2152,7 +2152,7 @@
- #else
- 	init_module(m_name, f, m_size, blob_name, noload, flag_load_map);
- #endif
--	if (errors) {
-+	if (error_count) {
- 		if (!noload)
- 			delete_module(m_name);
- 		goto out;
---- insmod/kallsyms.c
-+++ insmod/kallsyms.c
-@@ -80,7 +80,7 @@
-     error_file = "kallsyms";
- 
-     /* To handle repeated calls from combined modprobe */
--    errors = optind = 0;
-+    error_count = optind = 0;
- 
-     /* Process the command line.  */
-     while ((c = getopt_long(argc, argv, "Vh",
---- insmod/modprobe.c
-+++ insmod/modprobe.c
-@@ -1023,7 +1023,7 @@
- 		if (quiet)
- 			my_argv[my_argc++] = "-q";
- 
--		if (log)
-+		if (logging)
- 			my_argv[my_argc++] = "-s";
- 
- 		if (insmod_opt) {
---- insmod/rmmod.c
-+++ insmod/rmmod.c
-@@ -261,9 +261,9 @@
- 	read_parm.m.read_start = mp->sym->value;
- 	read_parm.m.read_end = read_parm.m.read_start + datasize;
- 	if (sys_init_module(module, (struct module *) &read_parm)) {
--		int old_errors = errors;
-+		int old_errors = error_count;
- 		error("has persistent data but the kernel is too old to support it.");
--		errors = old_errors;
-+		error_count = old_errors;
- 		return(0);
- 	}
- 
---- util/logger.c
-+++ util/logger.c
-@@ -31,10 +31,10 @@
- 
- /*======================================================================*/
- 
--int log;
-+int logging;
- static int silent;
- 
--int errors;
-+int error_count;
- const char *error_file;
- const char *program_name;
- 
-@@ -75,7 +75,7 @@
- 
- 	if (silent)
- 		;
--	else if (log) {
-+	else if (logging) {
- 		char buf[2*PATH_MAX];
- 		int n;
- 
-@@ -100,7 +100,7 @@
- 		putc('\n', stderr);
- 	}
- 
--	errors++;
-+	error_count++;
- }
- 
- void lprintf(const char *fmt,...)
-@@ -108,7 +108,7 @@
- 	va_list args;
- 
- 	if (silent);
--	else if (log) {
-+	else if (logging) {
- 		char buf[2*PATH_MAX];
- 		va_start(args, fmt);
- 		vsnprintf(buf, sizeof(buf), fmt, args);
-@@ -132,5 +132,5 @@
- #ifdef STOREMSG
- 	atexit(dumpmsg);
- #endif
--	log = 1;
-+	logging = 1;
- }
---- obj/obj_kallsyms.c
-+++ obj/obj_kallsyms.c
-@@ -200,8 +200,8 @@
- 
-     /* Initial contents, header + one entry per input section.  No strings. */
-     osec->header.sh_size = sizeof(*a_hdr) + loaded*sizeof(*a_sec);
--    a_hdr = (struct kallsyms_header *) osec->contents =
--    	xmalloc(osec->header.sh_size);
-+    osec->contents = xmalloc(osec->header.sh_size);
-+    a_hdr = (struct kallsyms_header *) osec->contents;
-     memset(osec->contents, 0, osec->header.sh_size);
-     a_hdr->size = sizeof(*a_hdr);
-     a_hdr->sections = loaded;
-@@ -275,8 +275,8 @@
- 	a_hdr->symbol_off +
- 	a_hdr->symbols*a_hdr->symbol_size +
- 	strings_size - strings_left;
--    a_hdr = (struct kallsyms_header *) osec->contents =
--	xrealloc(a_hdr, a_hdr->total_size);
-+    osec->contents = xrealloc(a_hdr, a_hdr->total_size);
-+    a_hdr = (struct kallsyms_header *) osec->contents;
-     p = (char *)a_hdr + a_hdr->symbol_off;
-     memcpy(p, symbols, a_hdr->symbols*a_hdr->symbol_size);
-     free(symbols);
---- obj/obj_ppc.c
-+++ obj/obj_ppc.c
-@@ -25,6 +25,7 @@
- #include <obj.h>
- #include <util.h>
- #include <assert.h>
-+#include <stdlib.h>
- 
- 
- /*======================================================================*/
-@@ -255,7 +256,8 @@
-   archdata_sec->header.sh_size = 0;
-   sec = obj_find_section(f, "__ftr_fixup");
-   if (sec) {
--    ad = (struct archdata *) (archdata_sec->contents) = xmalloc(sizeof(*ad));
-+    archdata_sec->contents = xmalloc(sizeof(*ad));
-+    ad = (struct archdata *) (archdata_sec->contents);
-     memset(ad, 0, sizeof(*ad));
-     archdata_sec->header.sh_size = sizeof(*ad);
-     ad->__start___ftr_fixup = sec->header.sh_addr;
-- 
cgit v0.12