From 965b69db0623e1b510715bfa8ba081d857437e21 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Wed, 6 Jul 2011 01:08:41 -0700
Subject: fluidsynth:bumped to latest.

---
 abs/extra/community/fluidsynth/PKGBUILD | 52 +++++++++++++++++++++++----------
 1 file changed, 36 insertions(+), 16 deletions(-)

diff --git a/abs/extra/community/fluidsynth/PKGBUILD b/abs/extra/community/fluidsynth/PKGBUILD
index f3606cb..944222e 100644
--- a/abs/extra/community/fluidsynth/PKGBUILD
+++ b/abs/extra/community/fluidsynth/PKGBUILD
@@ -1,25 +1,45 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: damir <damir@archlinux.org>
+# $Id: PKGBUILD 94804 2010-10-11 11:48:58Z schiv $
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
 
 pkgname=fluidsynth
-pkgver=1.0.8
-origver=1.0.8
+pkgver=1.1.3
 pkgrel=1
-pkgdesc="FluidSynth is a real-time software synthesizer based on the SoundFont 2 specifications."
-arch=("i686" "x86_64")
+pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
+arch=(i686 x86_64)
 url="http://www.fluidsynth.org/"
-depends=('jack-audio-connection-kit' 'ladspa')
-options=('!libtool')
+depends=('glib2' 'jack' 'dbus-core')
+makedepends=('cmake' 'ladspa' 'doxygen')
+optdepends=('bash: init script')
 license=('LGPL')
-source=("http://savannah.nongnu.org/download/fluid/$pkgname-$pkgver.tar.gz")
-md5sums=('e2abfd2e69fd8b28d965df968d7d44ee')
-
+backup=('etc/conf.d/fluidsynth')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+        fluidsynth.conf
+        fluidsynthd)
+md5sums=('0d3e3cc770b4da413010dfb7dfdce9c8'
+         '16c5f4d4cbdddc6c5fcbd4fd4cc142f1'
+         'b296dbfb524c2164f552f68bd9abe2ec')
 
 build() {
-  cd $startdir/src/$pkgname-$origver
-  ./configure --prefix=/usr \
-              --enable-ladspa
-  make || return 1
-  make prefix=$startdir/pkg/usr install
+  cd "$srcdir/$pkgname-$pkgver"
+
+  cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+          -DCMAKE_BUILD_TYPE=Release \
+          -Denable-ladspa=ON \
+          -DLIB_SUFFIX=""
+  make
+}
+
+package() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  make DESTDIR="$pkgdir/" install
+
+  install -Dm644 "$srcdir/fluidsynth.conf" \
+    "$pkgdir/etc/conf.d/fluidsynth"
+
+  install -Dm755 "$srcdir/fluidsynthd" \
+    "$pkgdir/etc/rc.d/fluidsynth"
 }
 
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12