From 5ef6c56b85ae9603212a65a2bf3c5153de7cdc94 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 2 Dec 2010 03:48:23 +0000
Subject: fceu: upgrade

---
 abs/extra/fceu/ChangeLog     |  21 +++++++++++++++++++
 abs/extra/fceu/PKGBUILD      |  47 ++++++++++++++++++++++++++-----------------
 abs/extra/fceu/fceux.desktop |  10 +++++++++
 abs/extra/fceu/fceux.png     | Bin 0 -> 583 bytes
 4 files changed, 60 insertions(+), 18 deletions(-)
 create mode 100644 abs/extra/fceu/ChangeLog
 mode change 100755 => 100644 abs/extra/fceu/PKGBUILD
 create mode 100644 abs/extra/fceu/fceux.desktop
 create mode 100644 abs/extra/fceu/fceux.png

diff --git a/abs/extra/fceu/ChangeLog b/abs/extra/fceu/ChangeLog
new file mode 100644
index 0000000..93ba8b3
--- /dev/null
+++ b/abs/extra/fceu/ChangeLog
@@ -0,0 +1,21 @@
+2009-11-06  Eric Belanger  <eric@archlinux.org>
+
+	* fceux 2.1.2-1
+	* Upstream update
+
+2009-08-05  Eric Belanger  <eric@archlinux.org>
+
+	* fceux 2.1.1-1
+	* gfceux 2.1.1-1
+	* Upstream update
+	* Implemented split packages
+
+2009-04-06  Eric Belanger  <eric@archlinux.org>
+
+	* fceux 2.1.0a-1
+	* Upstream update
+
+2009-03-06  Eric Belanger  <eric@archlinux.org>
+
+	* fceux 2.0.3-1
+	* Added to [community] repo to replace fceu
diff --git a/abs/extra/fceu/PKGBUILD b/abs/extra/fceu/PKGBUILD
old mode 100755
new mode 100644
index cdae29a..532a8fd
--- a/abs/extra/fceu/PKGBUILD
+++ b/abs/extra/fceu/PKGBUILD
@@ -1,24 +1,35 @@
-# Maintainer: Eric Belanger <belanger@astro.umontreal.ca>
+# $Id: PKGBUILD 31918 2010-11-07 20:45:58Z lcarlier $
+# Maintainer: Eric Belanger <eric@archlinux.org>
 # Contributor: Jo Christian Bergsk�s <jcberg@gmail.com>
 
-pkgname=fceu
-pkgver=0.98.15
-pkgrel=1
-pkgdesc="FCE Ultra is a fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support."
+pkgname=fceux
+pkgver=2.1.4a
+pkgrel=4
 arch=('i686' 'x86_64')
-url="http://fceultra.sourceforge.net"
-license="GPL"
-options=('docs')
-depends=('sdl' 'zlib')
-source=(ftp://ftp.knoppmyth.net/R6/sources/$pkgname-$pkgver-src.tar.bz2)
-md5sums=('bfe9aa7f91c19fa17bb6e5424dc5901b')
+url="http://fceux.com/web/home.html"
+pkgdesc="A fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
+license=('GPL')
+depends=('sdl' 'lua' 'gtk2')
+makedepends=('scons' 'mesa')
+optdepends=('xchm: for viewing the help manual')
+provides=('fceu' 'gfceux')
+replaces=('fceu' 'gfceux')
+source=(http://downloads.sourceforge.net/fceultra/$pkgname-${pkgver}.src.tar.bz2 \
+        fceux.desktop fceux.png)
+md5sums=('a1252a888cdc8b2c42ae031211f2fad6'
+         '30baf915c936926fa50f59d8276f6575'
+         '3fe753731ac46b5fee528b1f73abd3e3')
 
 build() {
-  cd $startdir/src/fceu
-  ./configure --prefix=/usr --with-opengl --build=i686-linux-gnu
-  make || return 1
-  make DESTDIR=$startdir/pkg install
-  install -D -m644 $startdir/src/fceu/Documentation/fceu-sdl.6 $startdir/pkg/usr/man/man6/fceu.6
-  install -d $startdir/pkg/usr/share/doc/fceu-doc
-  cp -r $startdir/src/fceu/Documentation/* $startdir/pkg/usr/share/doc/fceu-doc
+  cd "${srcdir}/fceu$pkgver"
+  scons
+
+  sed -i "s|/usr/local|${pkgdir}/usr|" SConstruct
+  scons install
+
+  install -D -m644 bin/$pkgname.chm "${pkgdir}/usr/share/doc/$pkgname/$pkgname.chm"
+  install -D -m644 "$srcdir"/fceux.desktop "${pkgdir}"/usr/share/applications/fceux.desktop
+  install -D -m644 "$srcdir"/fceux.png "$pkgdir"/usr/share/pixmaps/fceux.png
 }
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/fceu/fceux.desktop b/abs/extra/fceu/fceux.desktop
new file mode 100644
index 0000000..c166755
--- /dev/null
+++ b/abs/extra/fceu/fceux.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Fceux
+GenericName=NES/Famicom emulator
+Exec=fceux
+Icon=/usr/share/pixmaps/fceux.png
+Type=Application
+Categories=Game;Emulator;
+Encoding=UTF-8
+
+
diff --git a/abs/extra/fceu/fceux.png b/abs/extra/fceu/fceux.png
new file mode 100644
index 0000000..1cf27b1
Binary files /dev/null and b/abs/extra/fceu/fceux.png differ
-- 
cgit v0.12