From 8014e8344b6f1a789a938fccc3b356a525ce8207 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 11 Nov 2010 19:51:34 +0000
Subject: unzip: archsync, no functional change

---
 abs/core/unzip/PKGBUILD | 50 ++++++++++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 21 deletions(-)

diff --git a/abs/core/unzip/PKGBUILD b/abs/core/unzip/PKGBUILD
index 730beb9..77608dd 100644
--- a/abs/core/unzip/PKGBUILD
+++ b/abs/core/unzip/PKGBUILD
@@ -1,32 +1,40 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Dan McGee <dan@archlinux.org>
+# $Id: PKGBUILD 70615 2010-02-27 15:46:11Z thayer $
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Robson Peixoto
 
 pkgname=unzip
-pkgver=6.00
-_pkgver=60
-pkgrel=1
+pkgver=6.0
+pkgrel=5
 pkgdesc="Unpacks .zip archives such as those made by PKZIP"
 arch=('i686' 'x86_64')
 url="http://www.info-zip.org/"
 license=('custom')
-depends=('glibc')
-source=(http://downloads.sourceforge.net/infozip/${pkgname}${_pkgver}.tar.gz)
+depends=('bzip2' 'bash')
+source=('http://downloads.sourceforge.net/infozip/unzip60.tar.gz')
+md5sums=('62b490407489521db863b523a7f86375')
 
 build() {
-  cd $startdir/src/${pkgname}${_pkgver}
+  cd ${srcdir}/${pkgname}${pkgver/./}
+
+  # set CFLAGS -- from Debian
+  export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -DACORN_FTYPE_NFS \
+  -DWILD_STOP_AT_DIR -DLARGE_FILE_SUPPORT -DUNICODE_SUPPORT \
+  -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DNO_LCHMOD -DDATE_FORMAT=DF_YMD \
+  -DUSE_BZIP2 -DNATIVE"
+
+  # make -- from Debian
+  make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr LF2="" \
+  D_USE_BZ2=-DUSE_BZIP2 L_BZ2=-lbz2 unzips || return 1
 
-  export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64"
-  if [ "${CARCH}" = "i686" ]; then
-    make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr linux || return 1
-  else
-    make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr linux_noasm || return 1
-  fi
-  make -f unix/Makefile prefix=$startdir/pkg/usr install
+  # install -- from Debian
+  make -f unix/Makefile prefix=${pkgdir}/usr INSTALL_PROGRAM="install" install || return 1
 
-  install -Dm644 LICENSE $startdir/pkg/usr/share/licenses/unzip/LICENSE
+  # install the license file
+  install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/unzip/LICENSE || return 1
+
+  # fix manpage location
+  mkdir -p ${pkgdir}/usr/share || return 1
+  mv ${pkgdir}/usr/man ${pkgdir}/usr/share/ || return 1
 }
-md5sums=('62b490407489521db863b523a7f86375'
-         '2de357c2ba84576f38b17aed87915c87'
-         'a4797a1f6e45385f5e021f9f6f2ec0fa'
-         '83c7e79de9618bf7d081dd639dd3dde1')
-md5sums=('62b490407489521db863b523a7f86375')
+
-- 
cgit v0.12