From b86d19a012d9d6b1c4258b79cb67da59e5fdb5f1 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 4 Jul 2011 20:13:27 -0700
Subject: mplayer:Bumped to latest.

---
 abs/core/mplayer/PKGBUILD        |  70 ++++++++++++++-------------------------
 abs/core/mplayer/mplayer.desktop |  21 ++++++++++++
 abs/core/mplayer/mplayer.png     | Bin 0 -> 1982 bytes
 3 files changed, 45 insertions(+), 46 deletions(-)
 create mode 100644 abs/core/mplayer/mplayer.desktop
 create mode 100644 abs/core/mplayer/mplayer.png

diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index 568a217..945a798 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -1,43 +1,30 @@
+# $Id: PKGBUILD 97113 2010-10-26 14:11:03Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+
 pkgname=mplayer
-pkgver=32736
-pkgrel=1
-pkgdesc="Famous multimedia player, dev. version, without its GUI"
+pkgver=32492
+pkgrel=2
+pkgdesc="A movie player for linux"
 arch=('i686' 'x86_64')
-url="http://www.mplayerhq.hu/"
-license=('GPL')
-depends=('libxxf86dga' 'libxv' 'libmad' 'giflib' 'cdparanoia' 'gtk2'
-         'sdl' 'lame' 'libtheora' 'xvidcore' 'zlib' 'libmng' 'libxss'
-         'libgl' 'smbclient' 'aalib' 'x264>=20101109' 'faac' 'lirc-utils' 
-	 'ttf-dejavu' 'libmng' 'libxfont' 'libjpeg' 'rtmpdump' 'ladspa'
-         'mpg123' 'libbluray-git' 'libcdio' 'libdca' 'a52dec')
+depends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss'
+         'libgl' 'smbclient' 'aalib' 'jack' 'libcaca' 'x264' 'faac' 'lirc-utils' 'ttf-dejavu' 'libxvmc' 'enca' 'libvdpau>=0.4'
+         'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx')
 license=('GPL')
-makedepends=('libcaca' 'unzip' 'live-media' 'libdca' 'subversion' 'libvdpau')
-
-conflicts=('mplayer-nogui-svn')
-provides=('mplayer')
-#source=(http://knoppmyth.net/repo/source/mplayer-export-snapshot.tar.bz2  http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2)
-source=(http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2)
-
-_svnmod="mplayer"
-_svntrunk=svn://svn.mplayerhq.hu/mplayer/trunk/
+url="http://www.mplayerhq.hu/"
+makedepends=('unzip' 'mesa' 'live-media>=2010.01.13' 'yasm')
+backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz mplayer.desktop mplayer.png)
+md5sums=('01beb068608d3977fbb84b0b28935cee'
+         '647b9f4ab5284a7fef3f84f992214e77'
+         'd00874ccc644b7f43d6ef1c942fcef28')
 
 build() {
-  cd ${srcdir}
-   if [ -d "${_svnmod}/.svn" ]; then
-     cd "${_svnmod}"
-     svn up -r ${pkgver}
-   else
-     svn co "${_svntrunk}" --config-dir . -r ${pkgver} "${_svnmod}"
-  fi
-  msg "SVN checkout done or server timeout"
-  
-  cp -r "${_svnmod}" "${_svnmod}-build"
-  cd "${_svnmod}-build"
-
-  msg "Building the package..."
-#  CFLAGS="$CFLAGS -fomit-frame-pointer"
   # Custom CFLAGS break the mplayer build
   unset CFLAGS LDFLAGS
+
+  cd ${srcdir}/${pkgname}
+
   ./configure --prefix=/usr \
       --enable-runtime-cpudetection \
       --disable-gui \
@@ -56,22 +43,13 @@ build() {
 
   [ "$CARCH" = "i686" ] &&  sed 's|-march=i486|-march=i686|g' -i config.mak
 
-  make || return 1
-}
-
-package() {
-  cd "${srcdir}/${_svnmod}-build"
+  make
   make -j1 DESTDIR=${pkgdir} install
   install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
   install -dm755 ${pkgdir}/usr/share/mplayer/
   ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
   rm -rf ${pkgdir}/usr/share/mplayer/font
-  mkdir -p ${pkgdir}/usr/share/mplayer/skins/default
-  mv ${srcdir}/Blue ${pkgdir}/usr/share/mplayer/skins/default
-  mkdir -p ${pkgdir}/usr/share/doc/mplayer
-  cp -r ${srcdir}/${_svnmod}-build/DOCS/tech/* ${pkgdir}/usr/share/doc/mplayer/
-
-  msg "Cleaning build files..."
-  rm -rf "${srcdir}/${_svnmod}-build"
+  #desktop file  FS#14770
+  install -Dm644 ${srcdir}/mplayer.desktop ${pkgdir}/usr/share/applications/mplayer.desktop
+  install -Dm644 ${srcdir}/mplayer.png ${pkgdir}/usr/share/pixmaps/mplayer.png
 }
-md5sums=('e4e2020d11b681aac898103b3ba723c4')
diff --git a/abs/core/mplayer/mplayer.desktop b/abs/core/mplayer/mplayer.desktop
new file mode 100644
index 0000000..e3229d0
--- /dev/null
+++ b/abs/core/mplayer/mplayer.desktop
@@ -0,0 +1,21 @@
+[Desktop Entry]
+Type=Application
+Name=MPlayer Media Player
+Name[ca]=Reproductor multimèdia MPlayer
+Name[pl]=MPlayer odtwarzacz multimedialny 
+GenericName=Multimedia player
+Comment=Play movies and songs
+Comment[ca]=Reproduïu vídeos i cançons
+Comment[de]=Filme und Musik abspielen
+Comment[es]=Reproduzca vídeos y canciones
+Comment[fr]=Lecteur multimédia
+Comment[it]=Lettore multimediale
+Comment[zh]=多媒体播放器
+Comment[pl]=Odtwarzaj filmy i muzykę
+Icon=mplayer
+TryExec=mplayer
+Exec=mplayer -really-quiet %F
+Terminal=false
+NoDisplay=true
+Categories=GTK;AudioVideo;Audio;Video;Player;TV;
+MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
diff --git a/abs/core/mplayer/mplayer.png b/abs/core/mplayer/mplayer.png
new file mode 100644
index 0000000..7997693
Binary files /dev/null and b/abs/core/mplayer/mplayer.png differ
-- 
cgit v0.12