From cbf49910602f00689c5d3e393019474e68c3ceab Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 2 Jan 2015 21:57:28 +0000
Subject: mkinitcpio: update to 18

---
 ...le-filter-to-be-aware-of-hyphens-in-the-M.patch | 29 ----------------
 ...und-conditional-leading-to-spurious-error.patch | 39 ++++++++++++++++++++++
 ...-shutdown-don-t-alert-udev-on-disable-VGs.patch | 28 ----------------
 abs/core/mkinitcpio/PKGBUILD                       | 30 +++++++++++------
 abs/core/mkinitcpio/__changelog                    |  3 +-
 abs/core/mkinitcpio/mkinitcpio.install             |  7 ++++
 abs/core/mkinitcpio/mkinitcpio.patch               | 14 ++++----
 7 files changed, 73 insertions(+), 77 deletions(-)
 delete mode 100644 abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
 create mode 100644 abs/core/mkinitcpio/0001-avoid-compound-conditional-leading-to-spurious-error.patch
 delete mode 100644 abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch

diff --git a/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch b/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
deleted file mode 100644
index 042a0b9..0000000
--- a/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7cf7ac4eb2c29a2b1aa748dae7658da5fbbc3a18 Mon Sep 17 00:00:00 2001
-From: Brian Parsons <brian@pmex.com>
-Date: Mon, 11 Jun 2012 17:30:10 -0400
-Subject: [PATCH 1/2] Update module filter to be aware of hyphens in the
- MODULES array
-
-[dave: fix whitespace and re-add needed quoting]
-
-Signed-off-by: Dave Reisner <dreisner@archlinux.org>
----
- functions |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/functions b/functions
-index 4a62d8e..e9fb81a 100644
---- a/functions
-+++ b/functions
-@@ -590,7 +590,7 @@ write_image_config() {
-         . "$CONFIG"
- 
-         # sanitize of any extra whitespace
--        read -ra modules <<< "$MODULES"
-+        read -ra modules <<<"${MODULES//-/_}"
-         for mod in "${modules[@]}"; do
-             in_array "${mod%\?}" "${ADDED_MODULES[@]}" || continue
-             add+=("${mod%\?}")
--- 
-1.7.10.4
-
diff --git a/abs/core/mkinitcpio/0001-avoid-compound-conditional-leading-to-spurious-error.patch b/abs/core/mkinitcpio/0001-avoid-compound-conditional-leading-to-spurious-error.patch
new file mode 100644
index 0000000..c1371fd
--- /dev/null
+++ b/abs/core/mkinitcpio/0001-avoid-compound-conditional-leading-to-spurious-error.patch
@@ -0,0 +1,39 @@
+From ea4c4154205372154457c794513ae46b61ea4e4c Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Mon, 4 Aug 2014 08:31:37 -0400
+Subject: [mkinitcpio] [PATCH] avoid compound conditional leading to spurious
+ "errors"
+
+As seen:
+
+https://bbs.archlinux.org/viewtopic.php?id=185204
+https://bbs.archlinux.org/viewtopic.php?id=185265
+---
+ functions | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/functions b/functions
+index 20bbffe..362d07b 100644
+--- a/functions
++++ b/functions
+@@ -423,11 +423,15 @@ add_full_dir() {
+ 
+         for f in "$1"/*; do
+             if [[ -L $f ]]; then
+-                [[ $f = $filter ]] && add_symlink "$f" "$(readlink "$f")"
++                if [[ $f = $filter ]]; then
++                    add_symlink "$f" "$(readlink "$f")"
++                fi
+             elif [[ -d $f ]]; then
+                 add_full_dir "$f"
+             elif [[ -f $f ]]; then
+-                [[ $f = $filter ]] && add_file "$f"
++                if [[ $f = $filter ]]; then
++                    add_file "$f"
++                fi
+             fi
+         done
+     fi
+-- 
+2.1.0
+
diff --git a/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch b/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
deleted file mode 100644
index 7a1aba9..0000000
--- a/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From c257b0d7b4dd1c3f9b63c6a27b68a27bc246acea Mon Sep 17 00:00:00 2001
-From: Dave Reisner <dreisner@archlinux.org>
-Date: Tue, 12 Jun 2012 19:18:18 -0400
-Subject: [PATCH 2/2] shutdown: don't alert udev on disable VGs
-
-Fixes FS#30271.
-
-Signed-off-by: Dave Reisner <dreisner@archlinux.org>
----
- shutdown |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/shutdown b/shutdown
-index ce7de23..fd88105 100644
---- a/shutdown
-+++ b/shutdown
-@@ -25,7 +25,7 @@ stop_device() {
-             read devname <"$1/dm/name"
-             lvm lvdisplay -c "/dev/mapper/$devname" | {
-                 IFS=: read _ vgname _
--                lvm vgchange -an "$vgname"
-+                lvm vgchange --noudevsync -an "$vgname"
-             }
-             ;;
-         raid*)
--- 
-1.7.10.4
-
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index e4415be..ad19b84 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -1,30 +1,38 @@
-# $Id: PKGBUILD 171244 2012-11-16 22:09:31Z dreisner $
+# $Id$
 # Maintainer: Dave Reisner <dreisner@archlinux.org>
 # Maintainer: Thomas Bächler <thomas@archlinux.org>
 
 pkgname=mkinitcpio
-pkgver=0.11.2
-pkgrel=1
+pkgver=18
+pkgrel=2
 pkgdesc="Modular initramfs image creation utility"
 arch=('any')
-url="http://www.archlinux.org/"
+url="https://projects.archlinux.org/mkinitcpio.git/"
 license=('GPL')
-depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.21' 'libarchive' 'coreutils'
-         'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd-tools')
+depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.23' 'libarchive'
+         'coreutils' 'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'gzip' 'systemd')
 optdepends=('xz: Use lzma or xz compression for the initramfs image'
             'bzip2: Use bzip2 compression for the initramfs image'
             'lzop: Use lzo compression for the initramfs image'
+            'lz4: Use lz4 compression for the initramfs image'
             'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
 backup=('etc/mkinitcpio.conf')
-source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig} "mkinitcpio.patch")
+source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig}
+        '0001-avoid-compound-conditional-leading-to-spurious-error.patch'
+        'mkinitcpio.patch')
 install=mkinitcpio.install
 
+prepare() {
+  patch -d "$pkgname-$pkgver" -Np1 <0001-avoid-compound-conditional-leading-to-spurious-error.patch
+}
+
 package() {
   make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
   cd $pkgdir/etc
   patch -Np0 < $srcdir/mkinitcpio.patch || exit 1
-}
 
-md5sums=('cc437770a2f1a6ae63e14ac3c86defcf'
-         '5521e600fafa99522deb4f112f2e57cb'
-         'fa758c290731ab535c8d6995f0ff5ef0')
+}
+md5sums=('46b83483ac1444aa05a8d09e3bbc87b5'
+         'SKIP'
+         'd8c693935bd8f793cc410b78b3bfaf56'
+         '031fd7d3013c26175ae7421781893feb')
diff --git a/abs/core/mkinitcpio/__changelog b/abs/core/mkinitcpio/__changelog
index a2eacb9..609b54f 100644
--- a/abs/core/mkinitcpio/__changelog
+++ b/abs/core/mkinitcpio/__changelog
@@ -1,2 +1 @@
-modified mkinitcpio.patch to move fsck earlier in the hook
-this is needed so that drives other then /  can mount during boot
+mkinitcpio.patch: update for new hooks
diff --git a/abs/core/mkinitcpio/mkinitcpio.install b/abs/core/mkinitcpio/mkinitcpio.install
index d8bbfdb..8571ee7 100644
--- a/abs/core/mkinitcpio/mkinitcpio.install
+++ b/abs/core/mkinitcpio/mkinitcpio.install
@@ -5,4 +5,11 @@ post_upgrade() {
     printf '==> If your /usr is on a separate partition, you must add the "usr" hook\n'
     printf '    to /etc/mkinitcpio.conf and regenerate your images before rebooting\n'
   fi
+
+  if [ "$(vercmp 0.12.0 "$2")" -eq 1 ]; then
+    printf '==> The "block" hook has replaced several hooks:\n'
+    printf '       fw, sata, pata, scsi, virtio, mmc, usb\n'
+    printf '    Replace any and all of these in /etc/mkinitcpio.conf with a single\n'
+    printf '    instance of the "block" hook\n'
+  fi
 }
diff --git a/abs/core/mkinitcpio/mkinitcpio.patch b/abs/core/mkinitcpio/mkinitcpio.patch
index ffc21fc..7bd711a 100644
--- a/abs/core/mkinitcpio/mkinitcpio.patch
+++ b/abs/core/mkinitcpio/mkinitcpio.patch
@@ -1,20 +1,20 @@
---- mkinitcpio.conf.orig	2012-08-22 23:26:28.952203845 +0000
-+++ mkinitcpio.conf	2012-08-22 23:25:44.408871852 +0000
+--- mkinitcpio.conf.orig	2015-01-02 21:13:27.682427426 +0000
++++ mkinitcpio.conf	2015-01-02 21:15:11.195818945 +0000
 @@ -4,7 +4,7 @@
  # run.  Advanced users may wish to specify all system modules
  # in this array.  For instance:
  #     MODULES="piix ide_disk reiserfs"
 -MODULES=""
 +MODULES="nfs reiserfs xfs jfs ext4"
-
+ 
  # BINARIES
  # This setting includes any additional binaries a given user may
-@@ -56,7 +56,7 @@
+@@ -49,7 +49,7 @@
  #
  ##   NOTE: If you have /usr on a separate partition, you MUST include the
  #    usr, fsck and shutdown hooks.
--HOOKS="base udev autodetect pata scsi sata filesystems usbinput fsck"
-+HOOKS="base udev fsck autodetect pata scsi sata filesystems usb usbinput resume  v86d plymouth"
-
+-HOOKS="base udev autodetect modconf block filesystems keyboard fsck"
++HOOKS="base udev autodetect modconf block filesystems keyboard fsck v86d plymouth"
+ 
  # COMPRESSION
  # Use this to compress the initramfs image. By default, gzip compression
-- 
cgit v0.12