From 58247c4d69c5aa4ddfe9e29ee6bbcbaacf6fa825 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Jul 2011 00:11:13 -0500
Subject: glibc: Bump to latest

---
 abs/core/glibc/PKGBUILD                            | 100 ++++++++++++----
 abs/core/glibc/__changelog                         |   2 -
 .../glibc-2.12.1-static-shared-getpagesize.patch   |  11 ++
 ....12.2-ignore-origin-of-privileged-program.patch |  26 ++++
 abs/core/glibc/glibc-2.13-futex.patch              |  31 +++++
 .../glibc/glibc-2.14-fix-resolver-crash-typo.patch |  22 ++++
 abs/core/glibc/glibc-2.14-libdl-crash.patch        | 132 +++++++++++++++++++++
 .../glibc/glibc-2.14-reexport-rpc-interface.patch  |  26 ++++
 .../glibc-2.14-reinstall-nis-rpc-headers.patch     |  28 +++++
 abs/core/glibc/glibc-2.14-revert-4462fad3.patch    |  37 ++++++
 abs/core/glibc/glibc.install                       |   5 +-
 11 files changed, 390 insertions(+), 30 deletions(-)
 delete mode 100644 abs/core/glibc/__changelog
 create mode 100644 abs/core/glibc/glibc-2.12.1-static-shared-getpagesize.patch
 create mode 100644 abs/core/glibc/glibc-2.12.2-ignore-origin-of-privileged-program.patch
 create mode 100644 abs/core/glibc/glibc-2.13-futex.patch
 create mode 100644 abs/core/glibc/glibc-2.14-fix-resolver-crash-typo.patch
 create mode 100644 abs/core/glibc/glibc-2.14-libdl-crash.patch
 create mode 100644 abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
 create mode 100644 abs/core/glibc/glibc-2.14-reinstall-nis-rpc-headers.patch
 create mode 100644 abs/core/glibc/glibc-2.14-revert-4462fad3.patch

diff --git a/abs/core/glibc/PKGBUILD b/abs/core/glibc/PKGBUILD
index af54ae4..1c9d578 100644
--- a/abs/core/glibc/PKGBUILD
+++ b/abs/core/glibc/PKGBUILD
@@ -1,22 +1,20 @@
-# $Id: PKGBUILD 87193 2010-08-11 00:55:29Z allan $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id$
 # Maintainer: Allan McRae <allan@archlinux.org>
 
 # toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
 # NOTE: valgrind requires rebuilt with each new glibc version
 
 pkgname=glibc
-pkgver=2.12.1
-pkgrel=2
-_glibcdate=20100811
+pkgver=2.14
+pkgrel=4
+_glibcdate=20110617
 pkgdesc="GNU C Library"
 arch=('i686' 'x86_64')
 url="http://www.gnu.org/software/libc"
 license=('GPL' 'LGPL')
 groups=('base')
-depends=('linux-api-headers>=2.6.34' 'tzdata')
+depends=('linux-api-headers>=2.6.39' 'tzdata')
 makedepends=('gcc>=4.4')
-replaces=('glibc-xen')
 backup=(etc/locale.gen
         etc/nscd.conf)
 options=('!strip')
@@ -25,21 +23,37 @@ source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.t
         glibc-2.10-dont-build-timezone.patch
         glibc-2.10-bz4781.patch
         glibc-__i686.patch
+        glibc-2.12.1-static-shared-getpagesize.patch
+        glibc-2.12.2-ignore-origin-of-privileged-program.patch
+        glibc-2.13-futex.patch
+        glibc-2.14-libdl-crash.patch
+        #glibc-2.14-fix-resolver-crash-typo.patch
+        glibc-2.14-revert-4462fad3.patch
+        glibc-2.14-reexport-rpc-interface.patch
+        glibc-2.14-reinstall-nis-rpc-headers.patch
         nscd
         locale.gen.txt
-        locale-gen)    
-md5sums=('3f0d64de5a9fc5614d8acc0f1d5846ed'
+        locale-gen)
+md5sums=('e441d745609d93c907b72548ba646dad'
          '4dadb9203b69a3210d53514bb46f41c3'
          '0c5540efc51c0b93996c51b57a8540ae'
          '40cd342e21f71f5e49e32622b25acc52'
+         'a3ac6f318d680347bb6e2805d42b73b2'
+         'b042647ea7d6f22ad319e12e796bd13e'
+         '7d0154b7e17ea218c9fa953599d24cc4'
+         'cea62cc6b903d222c5f26e05a3c0e0e6'
+         '46e56492cccb1c9172ed3a235cf43c6c'
+         'c5de2a946215d647c8af5432ec4b0da0'
+         '55febbb72139ac7b65757df085024b83'
          'b587ee3a70c9b3713099295609afde49'
          '07ac979b6ab5eeb778d55f041529d623'
          '476e9113489f93b348b21e144b6a8fcf')
 
+
 mksource() {
   git clone git://sourceware.org/git/glibc.git
   pushd glibc
-  git checkout -b glibc-2.12-arch origin/release/2.12/master
+  git checkout -b glibc-2.14-arch origin/release/2.14/master
   popd
   tar -cvJf glibc-${pkgver}_${_glibcdate}.tar.xz glibc/*
 }
@@ -57,9 +71,37 @@ build() {
   # http://sourceware.org/ml/libc-alpha/2009-07/msg00072.html
   patch -Np1 -i ${srcdir}/glibc-__i686.patch
 
+  # http://sourceware.org/bugzilla/show_bug.cgi?id=11929
+  # using Fedora "fix" as patch in that bug report causes breakages...
+  patch -Np1 -i ${srcdir}/glibc-2.12.1-static-shared-getpagesize.patch
+
+  # http://www.exploit-db.com/exploits/15274/
+  # http://sourceware.org/git/?p=glibc.git;a=patch;h=d14e6b09 (only fedora branch...)
+  patch -Np1 -i ${srcdir}/glibc-2.12.2-ignore-origin-of-privileged-program.patch
+
+  # http://sourceware.org/bugzilla/show_bug.cgi?id=12403
+  patch -Np1 -i ${srcdir}/glibc-2.13-futex.patch
+
+  # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=675155e9 (only fedora branch...)
+  # http://sourceware.org/ml/libc-alpha/2011-06/msg00006.html
+  patch -Np1 -i ${srcdir}/glibc-2.14-libdl-crash.patch
+
+  # This fixes the main segfault but not the assert fail (FS#24615)
+  # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=57912a71 
+  #patch -Np1 -i ${srcdir}/glibc-2.14-fix-resolver-crash-typo.patch
+  # resort to reverting the bad commit completely for the moment
+  patch -Np1 -i ${srcdir}/glibc-2.14-revert-4462fad3.patch
+
+  # re-export RPC interface until libtirpc is ready as a replacement
+  # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=acee4873 (only fedora branch...)
+  patch -Np1 -i ${srcdir}/glibc-2.14-reexport-rpc-interface.patch
+  # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=bdd816a3 (only fedora branch...)
+  patch -Np1 -i ${srcdir}/glibc-2.14-reinstall-nis-rpc-headers.patch
+
   install -dm755 ${pkgdir}/etc
   touch ${pkgdir}/etc/ld.so.conf
 
+  cd ${srcdir}
   mkdir glibc-build
   cd glibc-build
 
@@ -70,24 +112,31 @@ build() {
 
   echo "slibdir=/lib" >> configparms
 
-  ../configure --prefix=/usr \
-      --enable-add-ons=nptl,libidn --without-cvs \
-      --enable-kernel=2.6.18 --disable-profile \
-      --with-headers=/usr/include --libexecdir=/usr/lib \
-      --enable-bind-now --with-tls --with-__thread \
-      --libdir=/usr/lib --without-gd --disable-multi-arch
+  ${srcdir}/glibc/configure --prefix=/usr \
+      --libdir=/usr/lib --libexecdir=/usr/lib \
+      --with-headers=/usr/include \
+      --enable-add-ons=nptl,libidn \
+      --enable-kernel=2.6.27 \
+      --with-tls --with-__thread \
+      --enable-bind-now --without-gd \
+      --without-cvs --disable-profile \
+      --disable-multi-arch
         
   make
 }
 
+check() {
+  cd ${srcdir}/glibc-build
+
+  # some errors are expected - manually check log files
+  make -k check || true
+}
+
 package() {
-  cd ${srcdir}/glibc/glibc-build
+  cd ${srcdir}/glibc-build
   make install_root=${pkgdir} install
 
-  # provided by kernel-headers
-  #rm ${pkgdir}/usr/include/scsi/scsi.h
-
-  rm ${pkgdir}/etc/ld.so.conf
+  rm -f ${pkgdir}/etc/ld.so.{cache,conf}
 
   install -dm755 ${pkgdir}/etc/rc.d
   install -dm755 ${pkgdir}/usr/sbin
@@ -95,6 +144,7 @@ package() {
   install -m644 ${srcdir}/glibc/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
   install -m755 ${srcdir}/nscd ${pkgdir}/etc/rc.d/nscd
   install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/sbin
+  install -m644 ${srcdir}/glibc/posix/gai.conf ${pkgdir}/etc/gai.conf
 
   sed -i -e 's/^\tserver-user/#\tserver-user/' ${pkgdir}/etc/nscd.conf
 
@@ -108,8 +158,8 @@ package() {
 
   if [[ ${CARCH} = "x86_64" ]]; then
     # fix for the linker
-    sed -i '/RTLDLIST/s%/ld-linux.so.2 /lib64%%' ${pkgdir}/usr/bin/ldd
-    #Comply with multilib binaries, they look for the linker in /lib64
+    sed -i '/RTLDLIST/s%lib64%lib%' ${pkgdir}/usr/bin/ldd
+    # Comply with multilib binaries, they look for the linker in /lib64
     mkdir ${pkgdir}/lib64
     cd ${pkgdir}/lib64
     ln -v -s ../lib/ld* .
@@ -124,7 +174,7 @@ package() {
                         usr/bin/{gencat,getconf,getent,iconv,locale} \
                         usr/bin/{localedef,pcprofiledump,rpcgen,sprof} \
                         usr/lib/getconf/* \
-                        usr/sbin/{iconvconfig,nscd,rpcinfo}
+                        usr/sbin/{iconvconfig,nscd}
   [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
 
   strip $STRIP_STATIC usr/lib/*.a \
@@ -134,5 +184,5 @@ package() {
                       lib/libnss_{compat,dns,files,hesiod,nis,nisplus}-${pkgver}.so \
                       lib/{libdl,libm,libnsl,libresolv,librt,libutil}-${pkgver}.so \
                       lib/{libmemusage,libpcprofile,libSegFault}.so \
-                      usr/lib/{pt_chown,gconv/*.so}
+                      usr/lib/{pt_chown,{audit,gconv}/*.so}
 }
diff --git a/abs/core/glibc/__changelog b/abs/core/glibc/__changelog
deleted file mode 100644
index c611e3d..0000000
--- a/abs/core/glibc/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
- - comment out the removal of scsi.h as it does not make it into
-   kernel26-headers -mh
diff --git a/abs/core/glibc/glibc-2.12.1-static-shared-getpagesize.patch b/abs/core/glibc/glibc-2.12.1-static-shared-getpagesize.patch
new file mode 100644
index 0000000..e847542
--- /dev/null
+++ b/abs/core/glibc/glibc-2.12.1-static-shared-getpagesize.patch
@@ -0,0 +1,11 @@
+--- glibc-2.12-192-g7c08a05/sysdeps/unix/sysv/linux/getpagesize.c
++++ glibc-2.12.90-17/sysdeps/unix/sysv/linux/getpagesize.c
+@@ -28,7 +28,7 @@
+ int
+ __getpagesize ()
+ {
+-#ifdef __ASSUME_AT_PAGESIZE
++#if 0 && defined __ASSUME_AT_PAGESIZE
+   assert (GLRO(dl_pagesize) != 0);
+   return GLRO(dl_pagesize);
+ #else
diff --git a/abs/core/glibc/glibc-2.12.2-ignore-origin-of-privileged-program.patch b/abs/core/glibc/glibc-2.12.2-ignore-origin-of-privileged-program.patch
new file mode 100644
index 0000000..ce089b4
--- /dev/null
+++ b/abs/core/glibc/glibc-2.12.2-ignore-origin-of-privileged-program.patch
@@ -0,0 +1,26 @@
+From d14e6b09d60d52cc12f0396c3106b14e1bd0fe8f Mon Sep 17 00:00:00 2001
+From: Andreas Schwab <schwab@redhat.com>
+Date: Thu, 9 Dec 2010 15:00:59 +0100
+Subject: [PATCH 1/1] Ignore origin of privileged program
+
+---
+ ChangeLog       |    5 +++++
+ elf/dl-object.c |    3 +++
+ 2 files changed, 8 insertions(+), 0 deletions(-)
+
+diff --git a/elf/dl-object.c b/elf/dl-object.c
+index 22a1635..7674d49 100644
+--- a/elf/dl-object.c
++++ b/elf/dl-object.c
+@@ -214,6 +214,9 @@ _dl_new_object (char *realname, const char *libname, int type,
+     out:
+       new->l_origin = origin;
+     }
++  else if (INTUSE(__libc_enable_secure) && type == lt_executable)
++    /* The origin of a privileged program cannot be trusted.  */
++    new->l_origin = (char *) -1;
+ 
+   return new;
+ }
+-- 
+1.7.2
diff --git a/abs/core/glibc/glibc-2.13-futex.patch b/abs/core/glibc/glibc-2.13-futex.patch
new file mode 100644
index 0000000..9b9c3ac
--- /dev/null
+++ b/abs/core/glibc/glibc-2.13-futex.patch
@@ -0,0 +1,31 @@
+--- a/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_rwlock_timedrdlock.S	
++++ a/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_rwlock_timedrdlock.S	
+@@ -210,7 +210,7 @@ pthread_rwlock_timedrdlock:
+ 	cfi_restore(%r12)
+ 	retq
+ 
+-#ifdef __ASSUME_PRIVATE_FUTEX
++#ifdef __ASSUME_FUTEX_CLOCK_REALTIME
+ 	cfi_adjust_cfa_offset(16)
+ 	cfi_rel_offset(%r12, 8)
+ 	cfi_rel_offset(%r13, 0)
+--- a/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_rwlock_timedwrlock.S	
++++ a/nptl/sysdeps/unix/sysv/linux/x86_64/pthread_rwlock_timedwrlock.S	
+@@ -192,7 +192,7 @@ pthread_rwlock_timedwrlock:
+ 
+ 7:	movq	%rdx, %rax
+ 
+-#ifndef __ASSUME_PRIVATE_FUTEX
++#ifndef __ASSUME_FUTEX_CLOCK_REALTIME
+ 	addq	$16, %rsp
+ 	cfi_adjust_cfa_offset(-16)
+ 	popq	%r14
+@@ -207,7 +207,7 @@ pthread_rwlock_timedwrlock:
+ 	cfi_restore(%r12)
+ 	retq
+ 
+-#ifdef __ASSUME_PRIVATE_FUTEX
++#ifdef __ASSUME_FUTEX_CLOCK_REALTIME
+ 	cfi_adjust_cfa_offset(16)
+ 	cfi_rel_offset(%r12, 8)
+ 	cfi_rel_offset(%r13, 0)
diff --git a/abs/core/glibc/glibc-2.14-fix-resolver-crash-typo.patch b/abs/core/glibc/glibc-2.14-fix-resolver-crash-typo.patch
new file mode 100644
index 0000000..b5d86c7
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-fix-resolver-crash-typo.patch
@@ -0,0 +1,22 @@
+diff --git a/resolv/res_send.c b/resolv/res_send.c
+index 97142b7..a001c1e 100644
+--- a/resolv/res_send.c
++++ b/resolv/res_send.c
+@@ -549,7 +549,7 @@ __libc_res_nsend(res_state statp, const u_char *buf, int buflen,
+ 				    ns, ansp, ansp2, nansp2, resplen2);
+ 			if (n < 0)
+ 				return (-1);
+-			if (n == 0 && (buf2 == NULL || resplen2 == 0))
++			if (n == 0 && (buf2 == NULL || *resplen2 == 0))
+ 				goto next_ns;
+ 		} else {
+ 			/* Use datagrams. */
+@@ -559,7 +559,7 @@ __libc_res_nsend(res_state statp, const u_char *buf, int buflen,
+ 				    ansp2, nansp2, resplen2);
+ 			if (n < 0)
+ 				return (-1);
+-			if (n == 0 && (buf2 == NULL || resplen2 == 0))
++			if (n == 0 && (buf2 == NULL || *resplen2 == 0))
+ 				goto next_ns;
+ 			if (v_circuit)
+ 			  // XXX Check whether both requests failed or
diff --git a/abs/core/glibc/glibc-2.14-libdl-crash.patch b/abs/core/glibc/glibc-2.14-libdl-crash.patch
new file mode 100644
index 0000000..ee29f8c
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-libdl-crash.patch
@@ -0,0 +1,132 @@
+diff --git a/elf/dl-close.c b/elf/dl-close.c
+index 73b2a2f..9bd91e3 100644
+--- a/elf/dl-close.c
++++ b/elf/dl-close.c
+@@ -1,5 +1,5 @@
+ /* Close a shared object opened by `_dl_open'.
+-   Copyright (C) 1996-2007, 2009, 2010, 2011 Free Software Foundation, Inc.
++   Copyright (C) 1996-2007, 2009, 2010 Free Software Foundation, Inc.
+    This file is part of the GNU C Library.
+ 
+    The GNU C Library is free software; you can redistribute it and/or
+@@ -119,17 +119,8 @@ _dl_close_worker (struct link_map *map)
+   if (map->l_direct_opencount > 0 || map->l_type != lt_loaded
+       || dl_close_state != not_pending)
+     {
+-      if (map->l_direct_opencount == 0)
+-	{
+-	  if (map->l_type == lt_loaded)
+-	    dl_close_state = rerun;
+-	  else if (map->l_type == lt_library)
+-	    {
+-	      struct link_map **oldp = map->l_initfini;
+-	      map->l_initfini = map->l_orig_initfini;
+-	      _dl_scope_free (oldp);
+-	    }
+-	}
++      if (map->l_direct_opencount == 0 && map->l_type == lt_loaded)
++	dl_close_state = rerun;
+ 
+       /* There are still references to this object.  Do nothing more.  */
+       if (__builtin_expect (GLRO(dl_debug_mask) & DL_DEBUG_FILES, 0))
+diff --git a/elf/dl-deps.c b/elf/dl-deps.c
+index 9e30594..3890d00 100644
+--- a/elf/dl-deps.c
++++ b/elf/dl-deps.c
+@@ -478,6 +478,7 @@ _dl_map_object_deps (struct link_map *map,
+ 		  nneeded * sizeof needed[0]);
+ 	  atomic_write_barrier ();
+ 	  l->l_initfini = l_initfini;
++	  l->l_free_initfini = 1;
+ 	}
+ 
+       /* If we have no auxiliary objects just go on to the next map.  */
+@@ -681,6 +682,7 @@ Filters not supported with LD_TRACE_PRELINKING"));
+   l_initfini[nlist] = NULL;
+   atomic_write_barrier ();
+   map->l_initfini = l_initfini;
++  map->l_free_initfini = 1;
+   if (l_reldeps != NULL)
+     {
+       atomic_write_barrier ();
+@@ -689,5 +691,5 @@ Filters not supported with LD_TRACE_PRELINKING"));
+       _dl_scope_free (old_l_reldeps);
+     }
+   if (old_l_initfini != NULL)
+-      map->l_orig_initfini = old_l_initfini;
++    _dl_scope_free (old_l_initfini);
+ }
+diff --git a/elf/dl-libc.c b/elf/dl-libc.c
+index 7be9483..a13fce3 100644
+--- a/elf/dl-libc.c
++++ b/elf/dl-libc.c
+@@ -265,13 +265,13 @@ libc_freeres_fn (free_mem)
+ 
+   for (Lmid_t ns = 0; ns < GL(dl_nns); ++ns)
+     {
+-      /* Remove all additional names added to the objects.  */
+       for (l = GL(dl_ns)[ns]._ns_loaded; l != NULL; l = l->l_next)
+ 	{
+ 	  struct libname_list *lnp = l->l_libname->next;
+ 
+ 	  l->l_libname->next = NULL;
+ 
++	  /* Remove all additional names added to the objects.  */
+ 	  while (lnp != NULL)
+ 	    {
+ 	      struct libname_list *old = lnp;
+@@ -279,6 +279,10 @@ libc_freeres_fn (free_mem)
+ 	      if (! old->dont_free)
+ 		free (old);
+ 	    }
++
++	  /* Free the initfini dependency list.  */
++	  if (l->l_free_initfini)
++	    free (l->l_initfini);
+ 	}
+ 
+       if (__builtin_expect (GL(dl_ns)[ns]._ns_global_scope_alloc, 0) != 0
+diff --git a/elf/rtld.c b/elf/rtld.c
+index 4a9109e..617e30e 100644
+--- a/elf/rtld.c
++++ b/elf/rtld.c
+@@ -2251,6 +2251,7 @@ ERROR: ld.so: object '%s' cannot be loaded as audit interface: %s; ignored.\n",
+ 	      lnp->dont_free = 1;
+ 	      lnp = lnp->next;
+ 	    }
++	  l->l_free_initfini = 0;
+ 
+ 	  if (l != &GL(dl_rtld_map))
+ 	    _dl_relocate_object (l, l->l_scope, GLRO(dl_lazy) ? RTLD_LAZY : 0,
+diff --git a/include/link.h b/include/link.h
+index e877104..051b99a 100644
+--- a/include/link.h
++++ b/include/link.h
+@@ -1,6 +1,6 @@
+ /* Data structure for communication from the run-time dynamic linker for
+    loaded ELF shared objects.
+-   Copyright (C) 1995-2006, 2007, 2009, 2010, 2011 Free Software Foundation, Inc.
++   Copyright (C) 1995-2006, 2007, 2009, 2010 Free Software Foundation, Inc.
+    This file is part of the GNU C Library.
+ 
+    The GNU C Library is free software; you can redistribute it and/or
+@@ -192,6 +192,9 @@ struct link_map
+ 						 during LD_TRACE_PRELINKING=1
+ 						 contains any DT_SYMBOLIC
+ 						 libraries.  */
++    unsigned int l_free_initfini:1; /* Nonzero if l_initfini can be
++				       freed, ie. not allocated with
++				       the dummy malloc in ld.so.  */
+ 
+     /* Collected information about own RPATH directories.  */
+     struct r_search_path_struct l_rpath_dirs;
+@@ -240,9 +243,6 @@ struct link_map
+ 
+     /* List of object in order of the init and fini calls.  */
+     struct link_map **l_initfini;
+-    /* The init and fini list generated at startup, saved when the
+-       object is also loaded dynamically.  */
+-    struct link_map **l_orig_initfini;
+ 
+     /* List of the dependencies introduced through symbol binding.  */
+     struct link_map_reldeps
diff --git a/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch b/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
new file mode 100644
index 0000000..e2beea8
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-reexport-rpc-interface.patch
@@ -0,0 +1,26 @@
+diff --git a/include/libc-symbols.h b/include/libc-symbols.h
+index 67e1ca2..5e7cca5 100644
+--- a/include/libc-symbols.h
++++ b/include/libc-symbols.h
+@@ -635,7 +635,7 @@ for linking")
+ # define libc_hidden_proto(name, attrs...) hidden_proto (name, ##attrs)
+ # define libc_hidden_def(name) hidden_def (name)
+ # define libc_hidden_weak(name) hidden_weak (name)
+-# define libc_hidden_nolink(name, version) hidden_nolink (name, libc, version)
++# define libc_hidden_nolink(name, version) hidden_def (name)
+ # define libc_hidden_ver(local, name) hidden_ver (local, name)
+ # define libc_hidden_data_def(name) hidden_data_def (name)
+ # define libc_hidden_data_weak(name) hidden_data_weak (name)
+diff --git a/sunrpc/Makefile b/sunrpc/Makefile
+index 5134ce9..40c73d1 100644
+--- a/sunrpc/Makefile
++++ b/sunrpc/Makefile
+@@ -53,7 +53,7 @@ headers-in-tirpc = $(addprefix rpc/,auth.h auth_unix.h clnt.h pmap_clnt.h \
+ 				    des_crypt.h)
+ headers-not-in-tirpc = $(addprefix rpc/,key_prot.h rpc_des.h) \
+ 		       $(rpcsvc:%=rpcsvc/%) rpcsvc/bootparam.h
+-headers = rpc/netdb.h
++headers = rpc/netdb.h $(headers-in-tirpc) $(headers-not-in-tirpc)
+ install-others = $(inst_sysconfdir)/rpc
+ generated = $(rpcsvc:%.x=rpcsvc/%.h) $(rpcsvc:%.x=x%.c) $(rpcsvc:%.x=x%.stmp) \
+ 	    $(rpcsvc:%.x=rpcsvc/%.stmp) rpcgen
diff --git a/abs/core/glibc/glibc-2.14-reinstall-nis-rpc-headers.patch b/abs/core/glibc/glibc-2.14-reinstall-nis-rpc-headers.patch
new file mode 100644
index 0000000..eb0fd82
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-reinstall-nis-rpc-headers.patch
@@ -0,0 +1,28 @@
+From bdd816a366c4e5bba5de7157d948e0c0737fb4fb Mon Sep 17 00:00:00 2001
+From: Andreas Schwab <schwab@redhat.com>
+Date: Tue, 17 May 2011 17:42:30 +0200
+Subject: [PATCH] Reinstall NIS RPC headers
+
+---
+ nis/Makefile |    4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/nis/Makefile b/nis/Makefile
+index b5c9609..d2934d9 100644
+--- a/nis/Makefile
++++ b/nis/Makefile
+@@ -23,9 +23,9 @@ subdir	:= nis
+ 
+ aux			:= nis_hash
+ 
++headers			:= $(wildcard rpcsvc/*.[hx])
+ distribute		:= nss-nis.h nss-nisplus.h nis_intern.h Banner \
+-			   nisplus-parser.h nis_xdr.h nss \
+-			   $(wildcard rpcsvc/*.[hx])
++			   nisplus-parser.h nis_xdr.h nss
+ 
+ # These are the databases available for the nis (and perhaps later nisplus)
+ # service.  This must be a superset of the services in nss.
+-- 
+1.7.5.4
+
diff --git a/abs/core/glibc/glibc-2.14-revert-4462fad3.patch b/abs/core/glibc/glibc-2.14-revert-4462fad3.patch
new file mode 100644
index 0000000..d71e374
--- /dev/null
+++ b/abs/core/glibc/glibc-2.14-revert-4462fad3.patch
@@ -0,0 +1,37 @@
+diff -Naur glibc-orig//resolv/res_send.c glibc/resolv/res_send.c
+--- glibc-orig//resolv/res_send.c	2011-06-10 18:59:03.041436996 +1000
++++ glibc/resolv/res_send.c	2011-06-10 19:08:09.379309323 +1000
+@@ -549,7 +549,7 @@
+ 				    ns, ansp, ansp2, nansp2, resplen2);
+ 			if (n < 0)
+ 				return (-1);
+-			if (n == 0 && (buf2 == NULL || resplen2 == 0))
++			if (n == 0)
+ 				goto next_ns;
+ 		} else {
+ 			/* Use datagrams. */
+@@ -559,7 +559,7 @@
+ 				    ansp2, nansp2, resplen2);
+ 			if (n < 0)
+ 				return (-1);
+-			if (n == 0 && (buf2 == NULL || resplen2 == 0))
++			if (n == 0)
+ 				goto next_ns;
+ 			if (v_circuit)
+ 			  // XXX Check whether both requests failed or
+@@ -1275,14 +1275,10 @@
+ 				(*thisresplenp > *thisanssizp)
+ 				? *thisanssizp : *thisresplenp);
+ 
+-			if (recvresp1 || (buf2 != NULL && recvresp2)) {
+-			  *resplen2 = 0;
++			if (recvresp1 || (buf2 != NULL && recvresp2))
+ 			  return resplen;
+-			}
+ 			if (buf2 != NULL)
+ 			  {
+-			    /* No data from the first reply.  */
+-			    resplen = 0;
+ 			    /* We are waiting for a possible second reply.  */
+ 			    if (hp->id == anhp->id)
+ 			      recvresp1 = 1;
diff --git a/abs/core/glibc/glibc.install b/abs/core/glibc/glibc.install
index 5e15c81..7f85ade 100644
--- a/abs/core/glibc/glibc.install
+++ b/abs/core/glibc/glibc.install
@@ -1,6 +1,5 @@
-infodir=/usr/share/info
-filelist=(libc.info libc.info-1 libc.info-2 libc.info-3 libc.info-4 libc.info-5 libc.info-6 libc.info-7 
-          libc.info-8 libc.info-9 libc.info-10 libc.info-11)
+infodir=usr/share/info
+filelist=(libc.info{,-1,-2,-3,-4,-5,-6,-7,-8,-9,-10,-11})
 
 post_upgrade() {
   sbin/ldconfig -r .
-- 
cgit v0.12