From fb4e8e768d27649266771a63c1536ee9eeb0e821 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 16 Feb 2009 22:41:01 -0800
Subject: Gotta keep them Athlon's cool.

---
 abs/extra-testing/community/athcool/PKGBUILD | 19 +++++++++++++++
 abs/extra-testing/community/athcool/athcool  | 35 ++++++++++++++++++++++++++++
 2 files changed, 54 insertions(+)
 create mode 100644 abs/extra-testing/community/athcool/PKGBUILD
 create mode 100644 abs/extra-testing/community/athcool/athcool

diff --git a/abs/extra-testing/community/athcool/PKGBUILD b/abs/extra-testing/community/athcool/PKGBUILD
new file mode 100644
index 0000000..2f38191
--- /dev/null
+++ b/abs/extra-testing/community/athcool/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=athcool
+pkgver=0.3.12
+pkgrel=1
+pkgdesc="Small utility allowing to enable powersaving mode on AMD Duron/Athlon/Athlon XP processors."
+url="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html"
+depends=(pciutils)
+license="GPL"
+arch=(i686)
+source=(http://members.jcom.home.ne.jp/jacobi/linux/files/$pkgname-$pkgver.tar.gz
+	athcool)
+md5sums=('f2e0f4fbd04f5e1f09aa60a3ecb24645'
+	 'bbf32484cec6431568ccf51c2516f9e7')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+  /bin/install -D -m0755 ../athcool $startdir/pkg/etc/rc.d/athcool
+}
diff --git a/abs/extra-testing/community/athcool/athcool b/abs/extra-testing/community/athcool/athcool
new file mode 100644
index 0000000..f49bd40
--- /dev/null
+++ b/abs/extra-testing/community/athcool/athcool
@@ -0,0 +1,35 @@
+#!/bin/bash
+ 
+. /etc/rc.conf
+. /etc/rc.d/functions
+ 
+ATHCOOL=/usr/sbin/athcool
+ 
+case "$1" in
+ start)
+  stat_busy "Enabling Athcool"
+  $ATHCOOL on > /dev/null
+  if [ $? -gt 0 ]; then
+  stat_fail
+  else
+  stat_done
+  fi
+  ;;
+ stop)
+  stat_busy "Disabling Athcool"
+  $ATHCOOL off > /dev/null
+  if [ $? -gt 0 ]; then
+  stat_fail
+  else
+  stat_done
+  fi
+  ;;
+ restart)
+  $0 stop
+  /bin/sleep 1
+  $0 start
+  ;;
+ *)
+  echo "Usage: $0 {start|stop|restart}"
+esac
+exit 0
-- 
cgit v0.12