From e91a04796733c19b1fafab5ec974c4aeb11eca3c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 11 Jan 2013 16:43:37 -0600
Subject: LinHES-system:  make E  and enhanced the default windowmanger.  As a
 side effect supplemental web also becomes the default.

refs #895
---
 abs/core/LinHES-system/LinHES-session       | 43 ++++++++++++++----------
 abs/core/LinHES-system/PKGBUILD             |  8 ++---
 abs/core/LinHES-system/msg_daemon.py        | 13 ++++----
 abs/core/LinHES-system/set_windowmanager.sh | 51 ++++++++++++++++-------------
 4 files changed, 66 insertions(+), 49 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index e181a1a..01768bd 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -3,6 +3,13 @@ MYTH_RUN_STATUS="1"
 . /etc/profile
 . /etc/systemconfig
 
+
+#set some defaults, then override from /etc/X11/WINDOWMANAGER
+configdir="/usr/share/wm_data"
+WM="e16 -P $configdir/e16_config_dir/"
+STARTUP_STYLE=enhanced
+
+
 if [ -e /etc/X11/WINDOWMANAGER ]
 then
     . /etc/X11/WINDOWMANAGER
@@ -129,7 +136,7 @@ function fluxbox_settings(){
     then
         echo "setting symlink fluxbox"
         configdir=/usr/share/fluxbox_settings
-        ln -s $configdir /root/.fluxbox
+        ln -s $configdir $HOME/.fluxbox
     fi
 
 }
@@ -238,7 +245,7 @@ function update_apple_trailers(){
 
 
 function first_configure(){
-    if [ x$STARTUP_STYLE = xenhanced ]
+    if [ ! x$STARTUP_STYLE = xlegacy ]
     then
         first_configure_mv
     else
@@ -351,7 +358,7 @@ function start_myth() {
     fi
 
     #continue on with starting mythtv
-    if [ x$STARTUP_STYLE = xenhanced ]
+    if [ ! x$STARTUP_STYLE = xlegacy ]
     then
         start_myth_mv
     else
@@ -398,7 +405,7 @@ function run_myth(){
                 killall -9 irexec
                 /usr/bin/irexec -d
 
-                if [ x$STARTUP_STYLE = xenhanced ]
+                if [ ! x$STARTUP_STYLE = xlegacy ]
                 then
 
                     run_wmctrl &
@@ -427,18 +434,19 @@ function set_background()
 
 }
 
-if [ x"$WM" = "xdefault" ]
-then
-#   fluxbox > /var/log/fluxbox.log 2>&1
-    WM=fluxbox
-fi
-
-
-if [ x"$WM" = "x" ]
-then
-#	fluxbox > /var/log/fluxbox.log 2>&1
-    WM=fluxbox
-fi
+# if [ x"$WM" = "xdefault" ]
+# then
+# #   fluxbox > /var/log/fluxbox.log 2>&1
+#     WM=fluxbox
+# fi
+#
+#
+# if [ x"$WM" = "x" ]
+# then
+# #	fluxbox > /var/log/fluxbox.log 2>&1
+#     WM=fluxbox
+# fi
+#
 
 if [ $WM = "fluxbox" ]
 then
@@ -446,6 +454,7 @@ then
 fi
 
 
+
 #if using mythvantage style, start the WM right away
 # this is done so that starting mythtv can loop.
 $WM &
@@ -467,7 +476,7 @@ start_myth
 
 # wait for the  windowmanger
 #This will make the session wait on the WM to exit.
-if [ x$STARTUP_STYLE != xenhanced ]
+if [  x$STARTUP_STYLE = xlegacy ]
 then
     wait $pid
 fi
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 0c1e604..e49578e 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=139
+pkgrel=140
 arch=('i686' 'x86_64')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -80,7 +80,7 @@ build() {
 
 
 }
-md5sums=('4587b20bce8d5a0396f97a7b9793a03a'
+md5sums=('d1f60851cb319921f3b7ad044d6f6332'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
@@ -91,7 +91,7 @@ md5sums=('4587b20bce8d5a0396f97a7b9793a03a'
          'dc0be354ce77ba2b89868fc29b942c43'
          '542e670e78d117657f93141e9689f54d'
          '41951459ea9d2b0567be521b67e6285a'
-         '659c0a55b0b375c48fcd751252dd2102'
+         'bb72ab230c7a71706285bd0f31a4fb1f'
          '692563448cca1d49f45e7d1c8abcaa0c'
          '962a3e9eaba2d1466251b7ab0956705d'
          '1758aed160de64abfafb28a3a8f3390e'
@@ -106,7 +106,7 @@ md5sums=('4587b20bce8d5a0396f97a7b9793a03a'
          '4a3cd8f9b33b2b86fdba47a8f1fa2859'
          '16f079dab35dde6efd55bf6cf4e2fb2f'
          '0e76cd8f320a852a162931450a1fb8b7'
-         '55b33e6a08eeea2a5280da0100f2c33c'
+         'a53de3c723a071eb2800a4f966f2d4dd'
          'ea315f41dcd6c978e546c95fc05546cf'
          'ac61cc460d9e97ba1f5ef69e92cdfbe5'
          'f3502bb7c665750da0ecdf6918f7c838'
diff --git a/abs/core/LinHES-system/msg_daemon.py b/abs/core/LinHES-system/msg_daemon.py
index 0e54824..8601075 100755
--- a/abs/core/LinHES-system/msg_daemon.py
+++ b/abs/core/LinHES-system/msg_daemon.py
@@ -243,20 +243,21 @@ class msg_queue_runner(threading.Thread):
       self.out_xosd = msg_xosd()
 
   def get_current_style(self):
-    style = "default"
+    style = "enhanced"
     if  os.path.exists('/etc/X11/WINDOWMANAGER'):
         command = ['bash', '-c', 'source /etc/X11/WINDOWMANAGER && echo $STARTUP_STYLE']
         proc = subprocess.Popen(command, stdout = subprocess.PIPE)
-
+        #default
         for line in proc.stdout:
             if line.strip() == "":
-                style = "default"
+                style = "enhanced"
             else:
                 style = line.strip()
             break
         proc.communicate()
     else:
-        style = "default"
+        #default
+        style = "enhanced"
     return style
 
 
@@ -265,7 +266,7 @@ class msg_queue_runner(threading.Thread):
       #print "Killing current display"
       if style == "enhanced":
         self.p.terminate()
-      elif style == "default":
+      elif style == "legacy":
         #self.p.terminate()
         self.out_xosd.kill()
 
@@ -284,7 +285,7 @@ class msg_queue_runner(threading.Thread):
                 self.p = multiprocessing.Process(target=self.out_msg.display, args=(msgtext,display_time))
                 self.p.start()
                 self.p.join()
-            elif style == "default":
+            elif style == "legacy":
                 #display_time = int(msgdict['timeout'])
                 self.out_xosd.display(msgtext,display_time)
 
diff --git a/abs/core/LinHES-system/set_windowmanager.sh b/abs/core/LinHES-system/set_windowmanager.sh
index b159fbf..4cb7a1c 100644
--- a/abs/core/LinHES-system/set_windowmanager.sh
+++ b/abs/core/LinHES-system/set_windowmanager.sh
@@ -20,13 +20,13 @@ function stylemsg(){
 function set_wm(){
     case ${windowmanager} in
 
-        default)
-            outmsg "default/fluxbox"
-            outline="default"
-            echo "" > /etc/X11/WINDOWMANAGER
+        fluxbox)
+            outmsg "fluxbox"
+            outline="fluxbox"
+            echo "fluxbox" > /etc/X11/WINDOWMANAGER
             ;;
 
-        enlightenment)
+        enlightenment|default)
             outmsg "enlightenment"
             outline="e16 -P $configdir/e16_config_dir/"
             ;;
@@ -48,24 +48,30 @@ function set_wm(){
 
     case ${style} in
 
-        enhanced)
+        legacy)
+               STYLE="$style"
+               stylemsg "Default"
+               HSTYLE=0
+            ;;
+
+        enhanced|*)
             STYLE="enhanced"
             HSTYLE="1"
             stylemsg enhanced
             myth_settings_wrapper.sh  -c load -t custom 1 HOSTSupplemental
             ;;
 
-        *)
-            if [ x$style != x ]
-            then
-               stylemsg "** Unknown style..using default"
-               STYLE=""
-            else
-               STYLE="$style"
-               stylemsg "Default"
-            fi
-            HSTYLE=0
-            ;;
+#         *)
+#             if [ x$style != x ]
+#             then
+#                stylemsg "** Unknown style..using default"
+#                STYLE=""
+#             else
+#                STYLE="$style"
+#                stylemsg "Default"
+#             fi
+#             HSTYLE=0
+#            ;;
     esac
 
 
@@ -95,10 +101,11 @@ then
     echo "      place_custom_startup_here"
     echo
     echo "Valid STARTUP_STYLE options are:"
-    echo "      default"
+    echo "      legacy"
     echo "      enhanced"
     echo
     echo "If STARTUP_STYLE is not given, then the default will be used."
+    echo "    default is currently set as enlightenment enhanced"
     echo
     echo "Example:    "
     echo "    set_windowmanager.sh  enlightenment enhanced"
@@ -112,10 +119,10 @@ fi
 
 set_wm
 
-if [ x$outline = "xdefault" ]
-then
-    exit 0
-fi
+# if [ x$outline = "xdefault" ]
+# then
+#     exit 0
+# fi
 
 WM_CHECK=`echo $outline|cut -d" " -f1 |tr -dc '[:alnum:]'`
 which $WM_CHECK 2>/dev/null
-- 
cgit v0.12