From 879fd1c6e6a0fc060866f810956b00be2d1792cf Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 23 Jan 2013 17:45:45 -0600
Subject: libnl1:  needed by ceton usb userspace program

refs #899
---
 abs/core/libnl1/PKGBUILD              | 28 ++++++++++++++++++++++++++++
 abs/core/libnl1/fix-compilation.patch | 10 ++++++++++
 2 files changed, 38 insertions(+)
 create mode 100644 abs/core/libnl1/PKGBUILD
 create mode 100644 abs/core/libnl1/fix-compilation.patch

diff --git a/abs/core/libnl1/PKGBUILD b/abs/core/libnl1/PKGBUILD
new file mode 100644
index 0000000..7d0c36f
--- /dev/null
+++ b/abs/core/libnl1/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=libnl1
+pkgver=1.1
+pkgrel=1
+pkgdesc="Library for applications dealing with netlink sockets (Legacy version)"
+arch=('i686' 'x86_64')
+url="http://www.infradead.org/~tgr/libnl/"
+license=('GPL')
+depends=('glibc')
+source=("http://www.infradead.org/~tgr/libnl/files/libnl-${pkgver}.tar.gz"
+        'fix-compilation.patch')
+md5sums=('ae970ccd9144e132b68664f98e7ceeb1'
+         'e1f5e82c8aa1b3ad025c7b588178de1e')
+
+build() {
+  cd ${srcdir}/libnl-${pkgver}
+  patch -Np1 -i ${srcdir}/fix-compilation.patch
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd ${srcdir}/libnl-${pkgver}
+  make DESTDIR=${pkgdir} install
+}
diff --git a/abs/core/libnl1/fix-compilation.patch b/abs/core/libnl1/fix-compilation.patch
new file mode 100644
index 0000000..891562a
--- /dev/null
+++ b/abs/core/libnl1/fix-compilation.patch
@@ -0,0 +1,10 @@
+--- libnl-1.1.orig/include/netlink-local.h	2008-01-14 16:48:45.000000000 +0100
++++ libnl-1.1/include/netlink-local.h	2009-06-26 11:15:33.186011844 +0200
+@@ -26,6 +26,7 @@
+ #include <sys/socket.h>
+ #include <inttypes.h>
+ #include <assert.h>
++#include <limits.h>
+ 
+ #include <arpa/inet.h>
+ #include <netdb.h>
-- 
cgit v0.12