From a9fa605b48550b04e845146db013f9585ad5beae Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 7 Jun 2020 02:23:29 +0000
Subject: jsoncpp: update to 1.9.3

---
 abs/core/mythtv/stable-30/git_src/git_hash     |  2 +-
 abs/core/mythtv/stable-30/mythplugins/PKGBUILD |  2 +-
 abs/core/mythtv/stable-30/mythtv/PKGBUILD      |  2 +-
 abs/extra/jsoncpp/PKGBUILD                     | 32 +++++++++++++-------------
 4 files changed, 19 insertions(+), 19 deletions(-)

diff --git a/abs/core/mythtv/stable-30/git_src/git_hash b/abs/core/mythtv/stable-30/git_src/git_hash
index 7bcf13c..f40e231 100644
--- a/abs/core/mythtv/stable-30/git_src/git_hash
+++ b/abs/core/mythtv/stable-30/git_src/git_hash
@@ -1 +1 @@
-ab250d6ccfe80fe8fb129e1375feb80a453a22a9
+c6b20b072e2ac3e9e158e9eaba478d99d43163ad
diff --git a/abs/core/mythtv/stable-30/mythplugins/PKGBUILD b/abs/core/mythtv/stable-30/mythplugins/PKGBUILD
index 578bde5..456471e 100644
--- a/abs/core/mythtv/stable-30/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-30/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=30.0
-pkgrel=11
+pkgrel=12
 arch=('x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
diff --git a/abs/core/mythtv/stable-30/mythtv/PKGBUILD b/abs/core/mythtv/stable-30/mythtv/PKGBUILD
index 4c4e55a..6385e5b 100644
--- a/abs/core/mythtv/stable-30/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-30/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=30.0
-pkgrel=11
+pkgrel=12
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('x86_64')
diff --git a/abs/extra/jsoncpp/PKGBUILD b/abs/extra/jsoncpp/PKGBUILD
index a8a1a36..58f4034 100644
--- a/abs/extra/jsoncpp/PKGBUILD
+++ b/abs/extra/jsoncpp/PKGBUILD
@@ -5,51 +5,51 @@
 
 pkgbase=jsoncpp
 pkgname=('jsoncpp' 'jsoncpp-doc')
-pkgver=1.8.4
-pkgrel=2
+pkgver=1.9.3
+pkgrel=1
 pkgdesc='C++ library for interacting with JSON'
 url='https://github.com/open-source-parsers/jsoncpp'
 arch=('x86_64')
 license=('MIT' 'custom:Public_Domain')
 makedepends=('gcc-libs' 'doxygen' 'graphviz' 'python' 'meson')
-checkdepends=('python2')
 options=('staticlibs')
-source=(${pkgbase}-${pkgver}.tar.gz::https://github.com/open-source-parsers/${pkgbase}/archive/${pkgver}.tar.gz)
-sha256sums=('c49deac9e0933bcb7044f08516861a2d560988540b23de2ac1ad443b219afdb6')
-sha512sums=('f70361a3263dd8b9441374a9a409462be1426c0d6587c865171a80448ab73b3f69de2b4d70d2f0c541764e1e6cccc727dd53178347901f625ec6fb54fb94f4f1')
+source=(https://github.com/open-source-parsers/${pkgbase}/archive/${pkgver}/${pkgbase}-${pkgver}.tar.gz)
+sha512sums=('f1c035d54ed952d8d4e41acab5c3ecf6aa445f348f98aeac2e7c89555ec2f6421d727b3bc4c2f54176afce137c545b20d886562901953ec091f91890e91e8559')
+b2sums=('6f89762e899ffe127705a30c1fe86f458d62fa05b8dbde6c465c73b6855d3945f3d739ff0c26e1a6326a211c946277908684ace9363df72ba0f460f66b3e3fd8')
 
 prepare() {
   cd ${pkgbase}-${pkgver}
-  mkdir -p build
+  echo "${pkgver}" > version
 }
 
 build() {
   cd ${pkgbase}-${pkgver}
-  msg2 "Building docs..."
-  python doxybuild.py \
-    --doxygen="$(which doxygen)" \
-    --with-dot
-
-  msg2 "Building shared library..."
+  echo "Building shared library..."
   arch-meson --default-library shared build
   ninja -C build
 
-  msg2 "Building static library..."
+  echo "Building static library..."
   arch-meson --default-library static build-static
   ninja -C build-static
+
+  echo "Building docs..."
+  python doxybuild.py \
+    --doxygen="$(command -v doxygen)" \
+    --with-dot
 }
 
 check() {
   cd ${pkgbase}-${pkgver}
   ninja -C build test
   cd test
-  python2 runjsontests.py ../build/jsontestrunner
-  python2 rununittests.py ../build/jsoncpp_test
+  python runjsontests.py ../build/jsontestrunner
+  python rununittests.py ../build/jsoncpp_test
 }
 
 package_jsoncpp() {
   depends=('gcc-libs')
   optdepends=('jsoncpp-doc: documentation')
+  provides=('libjsoncpp.so')
 
   cd ${pkgbase}-${pkgver}
   DESTDIR="${pkgdir}" ninja -C build install
-- 
cgit v0.12