From e5964f928b92018a912288591d43d44b64a26c22 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 16 Apr 2014 17:34:30 +0000
Subject: ddclient: update to 3.8.2. refs #961

---
 abs/extra/ddclient/ChangeLog                 | 22 ------------
 abs/extra/ddclient/PKGBUILD                  | 53 +++++++++++++---------------
 abs/extra/ddclient/ddclient-foreground.patch | 47 ------------------------
 abs/extra/ddclient/ddclient.conf.d           |  2 --
 abs/extra/ddclient/ddclient.install          | 37 -------------------
 abs/extra/ddclient/ddclient.rc               | 37 -------------------
 abs/extra/ddclient/ddclient.service          | 11 ++++++
 7 files changed, 36 insertions(+), 173 deletions(-)
 delete mode 100644 abs/extra/ddclient/ChangeLog
 delete mode 100644 abs/extra/ddclient/ddclient-foreground.patch
 delete mode 100644 abs/extra/ddclient/ddclient.conf.d
 delete mode 100644 abs/extra/ddclient/ddclient.install
 delete mode 100644 abs/extra/ddclient/ddclient.rc
 create mode 100644 abs/extra/ddclient/ddclient.service

diff --git a/abs/extra/ddclient/ChangeLog b/abs/extra/ddclient/ChangeLog
deleted file mode 100644
index 4520b69..0000000
--- a/abs/extra/ddclient/ChangeLog
+++ /dev/null
@@ -1,22 +0,0 @@
-2008-08-07	Abhishek Dasgupta <abhidg@gmail.com>
-	
-	* ddclient 3.7.3-2
-	* added /etc/conf.d/ddclient for modifying
-	  daemon poll frequency. This overrides the
-	  setting specified in /etc/ddclient/ddclient.conf
-	  when ddclient is called as an rc script.
-
-2007-08-08  Alessio 'mOLOk' Bolognino <themolok@gmail.com>
-
-	* ddclient-3.7.3-1
-	* version bump
-	* GPL -> GPL2
-	* shortened pkgdesc
-
-2007-07-02  tardo <tardo@nagi-fanboi.net>
-
-	* Built for x86_64
-
-2007-06-29  Georg Grabler (STiAT) <ggrabler@gmail.com>
-	
-	* Version Bump to 3.7.2
diff --git a/abs/extra/ddclient/PKGBUILD b/abs/extra/ddclient/PKGBUILD
index 77be4a8..91f7baa 100644
--- a/abs/extra/ddclient/PKGBUILD
+++ b/abs/extra/ddclient/PKGBUILD
@@ -1,37 +1,34 @@
-# $Id: PKGBUILD 17388 2010-05-24 09:45:55Z spupykin $
-# Maintainer: Abhishek Dasgupta <abhidg@gmail.com>
+# $Id$
+# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
 # Contributor: David Rosenstrauch <darose@darose.net>
 
 pkgname=ddclient
-pkgver=3.8.0
-pkgrel=4
-pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services."
+pkgver=3.8.2
+pkgrel=1
+pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services"
 arch=('any')
-url="http://ddclient.sourceforge.net/"
+url="http://ddclient.sourceforge.net"
 license=('GPL2')
-depends=('perl' 'perl-io-socket-ssl')
-backup=('etc/ddclient/ddclient.conf' 'etc/conf.d/ddclient')
-install=ddclient.install
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d ddclient-foreground.patch)
+depends=('perl-io-socket-ssl' 'perl-digest-sha1' 'net-tools')
+backup=('etc/ddclient/ddclient.conf')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+        $pkgname.service)
+md5sums=('62cd5fe93ced2c794d5f441f9d908841'
+         '1bcd3e75309e658931532adef2a0608a')
 
-build() {
-  cd ${srcdir}/ddclient-${pkgver}
-  patch < ${srcdir}/ddclient-foreground.patch
+package() {
+  cd "$srcdir"/$pkgname-$pkgver
 
-  # core files
-  install -D -m755 ddclient ${pkgdir}/usr/sbin/ddclient
-  install -D -m755 ${srcdir}/ddclient.rc ${pkgdir}/etc/rc.d/ddclient
-  install -D -m600 sample-etc_ddclient.conf ${pkgdir}/etc/ddclient/ddclient.conf
-  install -D -m644 ${srcdir}/ddclient.conf.d ${pkgdir}/etc/conf.d/ddclient
-  install -d ${pkgdir}/var/cache/ddclient
+  install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+  install -Dm600 sample-etc_$pkgname.conf "$pkgdir"/etc/$pkgname/$pkgname.conf
+  install -d "$pkgdir"/var/cache/$pkgname
+  install -Dm644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
 
-  # additional instructions, sample configs
-  install -D -m644 README ${pkgdir}/etc/ddclient/samples/README
-  install -D -m644 sample-etc_cron.d_ddclient ${pkgdir}/etc/ddclient/samples/sample-etc_cron.d_ddclient
-  install -D -m644 sample-etc_dhcpc_dhcpcd-eth0.exe ${pkgdir}/etc/ddclient/samples/sample-etc_dhcpc_dhcpcd-eth0.exe
-  install -D -m644 sample-etc_ppp_ip-up.local ${pkgdir}/etc/ddclient/samples/sample-etc_ppp_ip-up.local
+  install -Dm644 README.cisco "$pkgdir"/usr/share/doc/$pkgname/README.cisco
+  install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+  install -Dm644 README.ssl "$pkgdir"/usr/share/doc/$pkgname/README.ssl
+  install -Dm644 sample-etc_cron.d_$pkgname "$pkgdir"/usr/share/doc/$pkgname/sample-etc_cron.d_$pkgname
+  install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+  install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
 }
-md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
-         '7035bf8132f3517a59167f61ee5e8b90'
-         'b8f39c82827776da948b76ef83544d33'
-         'd8ffc95f98f9afcb4a06a1e192220e35')
diff --git a/abs/extra/ddclient/ddclient-foreground.patch b/abs/extra/ddclient/ddclient-foreground.patch
deleted file mode 100644
index a814ede..0000000
--- a/abs/extra/ddclient/ddclient-foreground.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- ../ddclient-orig/ddclient	2009-10-19 22:45:15.000000000 +1030
-+++ ddclient	2009-10-19 22:50:11.000000000 +1030
-@@ -307,6 +307,7 @@
- my %variables = (
-     'global-defaults'    => {
- 	'daemon'              => setv(T_DELAY, 0, 0, 1, 0,                    interval('60s')),
-+	'foreground'          => setv(T_BOOL,  0, 0, 1, 0,                    undef),
- 	'file'                => setv(T_FILE,  0, 0, 1, "$etc$program.conf",  undef),
- 	'cache'               => setv(T_FILE,  0, 0, 1, "$cachedir$program.cache", undef),
- 	'pid'                 => setv(T_FILE,  0, 0, 1, "",                   undef),
-@@ -535,6 +536,7 @@
-     "usage: ${program} [options]",
-     "options are:",
-     [ "daemon",      "=s", "-daemon delay         : run as a daemon, specify delay as an interval." ],
-+    [ "foreground",  "!",  "-foreground           : do not fork" ],
-     [ "proxy",       "=s", "-proxy host           : use 'host' as the HTTP proxy" ],
-     [ "server",      "=s", "-server host          : update DNS information on 'host'" ],
-     [ "protocol",    "=s", "-protocol type        : update protocol used" ],
-@@ -623,7 +625,10 @@
- $SIG{'HUP'}    = sub { $caught_hup  = 1; };
- $SIG{'TERM'}   = sub { $caught_term = 1; };
- $SIG{'KILL'}   = sub { $caught_kill = 1; };
--if (opt('daemon') && !opt('force')) {
-+# don't fork() if foreground or force is on
-+if (opt('foreground') || opt('force')) {
-+    ;
-+} elsif (opt('daemon')) {
-     $SIG{'CHLD'}   = 'IGNORE';
-     my $pid = fork;
-     if ($pid < 0) {
-@@ -633,12 +638,15 @@
- 	exit 0;
-     }
-     $SIG{'CHLD'}   = 'DEFAULT';
--    $opt{'syslog'} = 1;
-     open(STDOUT, ">/dev/null");
-     open(STDERR, ">/dev/null");
-     open(STDIN,  "</dev/null");
-+}
- 
-+# write out the pid file if we're daemon'ized
-+if(opt('daemon')) {
-     write_pid();
-+    $opt{'syslog'} = 1;
- }
- 
- umask 077;
diff --git a/abs/extra/ddclient/ddclient.conf.d b/abs/extra/ddclient/ddclient.conf.d
deleted file mode 100644
index 8b754a3..0000000
--- a/abs/extra/ddclient/ddclient.conf.d
+++ /dev/null
@@ -1,2 +0,0 @@
-# Parameters passed to ddclient
-EXTRA_ARGS="-daemon 300"
diff --git a/abs/extra/ddclient/ddclient.install b/abs/extra/ddclient/ddclient.install
deleted file mode 100644
index 55b0e1b..0000000
--- a/abs/extra/ddclient/ddclient.install
+++ /dev/null
@@ -1,37 +0,0 @@
-# arg 1:  the new package version
-post_install() {
-cat << EOM
-
-If you want to use ddclient with dhcpcd, cron or pppd,
-see /etc/ddclient/samples for further instructions.
-
-If you have ddclient in the DAEMONS array of /etc/rc.conf:
-- Change /etc/conf.d/ddclient according to your needs.
-- This setting OVERRIDES any setting in
-  /etc/ddclient/ddclient.conf
-
-EOM
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  
-if [ -f /etc/ddclient/ddclient.cache ]; then
-	echo -n "Moving ddclient.cache from /etc/ddclient/ to /var/cache/ddclient/."
-	mv /etc/ddclient/ddclient.cache /var/cache/ddclient/
-	echo " (done)"
-fi
-
-if [ "$(vercmp $2 3.7.3-2)" -lt 0 ]; then
-cat << EOM
-
-If you have ddclient in the DAEMONS array of /etc/rc.conf:
-- Change /etc/conf.d/ddclient according to your needs.
-- This setting OVERRIDES any setting in
-  /etc/ddclient/ddclient.conf
-
-EOM
-fi
-
-}
diff --git a/abs/extra/ddclient/ddclient.rc b/abs/extra/ddclient/ddclient.rc
deleted file mode 100644
index a9093f7..0000000
--- a/abs/extra/ddclient/ddclient.rc
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-[ -f /etc/conf.d/ddclient ] && . /etc/conf.d/ddclient
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/ddclient`
-case "$1" in
-  start)
-    stat_busy "Starting ddclient"
-    [ -z "$PID" ] && /usr/sbin/ddclient ${EXTRA_ARGS}
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      add_daemon ddclient
-      stat_done
-    fi
-    ;;
-  stop)
-    stat_busy "Stopping ddclient"
-    [ -n "$PID" ] && kill -15 $PID >/dev/null
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      rm_daemon ddclient
-      stat_done
-    fi
-    ;;
-  restart)
-    $0 stop
-    sleep 1
-    $0 start
-    ;;
-  *)
-    echo "usage: $0 {start|stop|restart}"  
-esac
diff --git a/abs/extra/ddclient/ddclient.service b/abs/extra/ddclient/ddclient.service
new file mode 100644
index 0000000..4abadac
--- /dev/null
+++ b/abs/extra/ddclient/ddclient.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Dynamic DNS Update Client
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/var/run/ddclient.pid
+ExecStart=/usr/bin/ddclient
+
+[Install]
+WantedBy=multi-user.target
-- 
cgit v0.12