From d992bf484dfa07050c368c30a8c2dda70511c066 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 16 Feb 2014 17:57:48 -0600
Subject: parted: update binary path to /usr/bin refs #961

---
 abs/core/parted/PKGBUILD       |  8 ++++----
 abs/core/parted/linux.c.patch  | 25 -------------------------
 abs/core/parted/parted.install |  2 +-
 3 files changed, 5 insertions(+), 30 deletions(-)
 delete mode 100644 abs/core/parted/linux.c.patch

diff --git a/abs/core/parted/PKGBUILD b/abs/core/parted/PKGBUILD
index 7a94164..a0211ff 100644
--- a/abs/core/parted/PKGBUILD
+++ b/abs/core/parted/PKGBUILD
@@ -1,25 +1,24 @@
-# $Id: PKGBUILD 151858 2012-03-03 14:28:32Z giovanni $
+# $Id: PKGBUILD 199967 2013-11-20 11:26:39Z allan $
 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
 # Contributor: Aaron Griffin <aaron@archlinux.org>
 
 pkgname=parted
 pkgver=3.1
-pkgrel=1
+pkgrel=3
 pkgdesc="A program for creating, destroying, resizing, checking and copying partitions"
 arch=('i686' 'x86_64')
 license=('GPL3')
 url="http://www.gnu.org/software/parted/parted.html"
 depends=('device-mapper' 'e2fsprogs')
 makedepends=('pkg-config')
-options=('!libtool')
 install=parted.install
 source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz")
-md5sums=('5d89d64d94bcfefa9ce8f59f4b81bdcb')
 
 build() {
   cd "${srcdir}/${pkgname}-${pkgver}"
 
   ./configure --prefix=/usr \
+              --sbindir=/usr/bin \
               --disable-debug \
               --disable-rpath
   make
@@ -30,3 +29,4 @@ package() {
 
   make DESTDIR="${pkgdir}" install
 }
+md5sums=('5d89d64d94bcfefa9ce8f59f4b81bdcb')
diff --git a/abs/core/parted/linux.c.patch b/abs/core/parted/linux.c.patch
deleted file mode 100644
index c9feea1..0000000
--- a/abs/core/parted/linux.c.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/libparted/arch/linux.c	2011-05-27 14:52:37.000000000 +0200
-+++ b/libparted/arch/linux.c	2011-07-29 20:25:38.000000000 +0200
-@@ -601,17 +601,17 @@
-         static int kver = -1;
- 
-         struct utsname uts;
--        int major;
--        int minor;
--        int teeny;
-+        int major = 0;
-+        int minor = 0;
-+        int teeny = 0;
- 
-         if (kver != -1)
-                 return kver;
- 
-         if (uname (&uts))
-                 return kver = 0;
--        if (sscanf (uts.release, "%u.%u.%u", &major, &minor, &teeny) != 3)
--                return kver = 0;
-+        int n = sscanf (uts.release, "%u.%u.%u", &major, &minor, &teeny);
-+        assert (n == 2 || n == 3);
- 
-         return kver = KERNEL_VERSION (major, minor, teeny);
- }
diff --git a/abs/core/parted/parted.install b/abs/core/parted/parted.install
index 5e00699..752a687 100644
--- a/abs/core/parted/parted.install
+++ b/abs/core/parted/parted.install
@@ -8,7 +8,7 @@ post_install() {
 }
 
 post_upgrade() {
-  post_install $1
+  post_install
 }
 
 pre_remove() {
-- 
cgit v0.12