From 1110292b3a2245a2ae0dafa870ca49440aaef8ac Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 29 Nov 2008 15:41:50 -0600
Subject: missing hwd pkg

---
 abs/core-testing/ddcxinfo-arch/PKGBUILD | 21 +++++++++++++++++++++
 abs/core-testing/hwd/PKGBUILD           | 22 ++++++++++++++++++++++
 abs/core-testing/hwd/hwd.install        | 15 +++++++++++++++
 3 files changed, 58 insertions(+)
 create mode 100644 abs/core-testing/ddcxinfo-arch/PKGBUILD
 create mode 100644 abs/core-testing/hwd/PKGBUILD
 create mode 100644 abs/core-testing/hwd/hwd.install

diff --git a/abs/core-testing/ddcxinfo-arch/PKGBUILD b/abs/core-testing/ddcxinfo-arch/PKGBUILD
new file mode 100644
index 0000000..108a97e
--- /dev/null
+++ b/abs/core-testing/ddcxinfo-arch/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: damir <damir@archlinux.org>
+# TUR: Ben <ben@benmazer.net>
+# Contributor: Elia Yehuda <z4ziggy@user-contributions.org>
+
+pkgname=ddcxinfo-arch
+pkgver=0.8
+pkgrel=1
+pkgdesc="utility to probe non/ddc monitors - used by hwd"
+url="http://user-contributions.org/projects/ddcxinfo-arch/"
+depends=('glibc')
+arch=i686
+source=(http://user-contributions.org/projects/ddcxinfo-arch/source/$pkgname-$pkgver.tar.gz)
+
+md5sums=('ca734d958a54bef03a543479f7ab8b00')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  make ddcxinfo-arch || return 1
+  install -D -m755 ddcxinfo-arch $startdir/pkg/usr/sbin/ddcxinfo-arch
+}
diff --git a/abs/core-testing/hwd/PKGBUILD b/abs/core-testing/hwd/PKGBUILD
new file mode 100644
index 0000000..6073e2b
--- /dev/null
+++ b/abs/core-testing/hwd/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 3106 2008-06-19 18:56:52Z damir $
+# Maintainer: damir <damir@archlinux.org>
+# Contributor: Markku (rasat at Arch Linux Forums)
+
+pkgname=hwd
+pkgver=5.3.4
+pkgrel=1
+pkgdesc="Hardware detect for Arch Linux (devfs and udev)."
+url="http://user-contributions.org/projects/hwd/hwd.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('bash' 'pciutils' 'usbutils' 'ddcxinfo-arch' 'wget')
+install=hwd.install
+source=(http://user-contributions.org/projects/hwd/src/$pkgname-$pkgver.bin.tar.gz)
+
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  cp -R $startdir/src/$pkgname-$pkgver/{etc,usr} $startdir/pkg/ || return 1
+}
+
+md5sums=('002cfb6de516442203073084b6c1a7f9')
diff --git a/abs/core-testing/hwd/hwd.install b/abs/core-testing/hwd/hwd.install
new file mode 100644
index 0000000..e4c28cb
--- /dev/null
+++ b/abs/core-testing/hwd/hwd.install
@@ -0,0 +1,15 @@
+# arg 1:  the new package version
+post_install() {
+    echo "==> Run 'hwd -u' to update xorgtable, pci-, and usb.ids."
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+    echo "==> Run 'hwd -u' to update xorgtable, pci-, and usb.ids."
+}
+
+# arg 1:  the old package version
+pre_remove() {
+    rm -R /etc/hwd >/dev/null 2>&1
+}
-- 
cgit v0.12