From 91da949087b33b1e025923bf30e3101891fbca93 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Mon, 15 Aug 2011 16:41:04 -0700
Subject: ceton:Bumped to latest module.

---
 abs/core/ceton/PKGBUILD | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/abs/core/ceton/PKGBUILD b/abs/core/ceton/PKGBUILD
index 97eb417..dd69ebe 100644
--- a/abs/core/ceton/PKGBUILD
+++ b/abs/core/ceton/PKGBUILD
@@ -3,8 +3,8 @@
 
 pkgname=ceton
 _kernver=2.6.39-LinHES
-pkgver=1.2
-pkgrel=3
+pkgver=1.3
+pkgrel=2
 pkgdesc="Drivers for Ceton InfiniTV4"
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -12,17 +12,17 @@ url="http://linuxtv.org/"
 depends=('kernel26')
 makedepends=(kernel-headers)
 install=ceton.install
-source=('http://www.cetoncorp.com/firmware/ceton_infinitv_linux_driver_1_2.tar.gz')
+source=('http://www.cetoncorp.com/firmware/ceton_infinitv_linux_driver_1_3.tar.gz')
 
 build() {
   cd $startdir/src/ceton_infinitv_linux_driver
 #  patch -p1 < ../hdpvr.diff
   make
   make install
-  mkdir -p $startdir/pkg/lib/modules/$_kernver/kernel/drivers/media/video
-  cp ctn91xx.ko $startdir/pkg/lib/modules/$_kernver/kernel/drivers/media/video
+  mkdir -p $startdir/pkg/lib/modules/$_kernver/extra
+  cp ctn91xx.ko $startdir/pkg/lib/modules/$_kernver/extra
   mkdir -p $pkgdir/etc/udev/rules.d
   cp 98-ctn91xx.rules $pkgdir/etc/udev/rules.d/
 
 }
-md5sums=('7a014a32d88e0792231b439079c20acd')
+md5sums=('5021db6c04e2f0c2a8367d9c15827470')
-- 
cgit v0.12


From 44fd9d621c275da6426ace611de208fbd2216b0f Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 16 Aug 2011 13:23:53 -0700
Subject: mythtv:latest mythtv w/ patch for Ceton InfinTV 4 support!

---
 abs/core/mythtv/stable-0.24/mythtv/PKGBUILD | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
index 36945b3..ab70bcd 100755
--- a/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/mythtv/PKGBUILD
@@ -6,7 +6,7 @@
 
 pkgname=mythtv
 pkgver=0.24
-pkgrel=19
+pkgrel=21
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org/"
@@ -28,7 +28,8 @@ optdepends=('xmltv: to download tv listings')
 #replaces=('mythtv-contrib')
 #conflicts=('mythtv-contrib')
 source=(ftp://ftp.knoppmyth.net/R6/sources/mythtv-0.24-fixes.tar.bz2
-	'mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty')
+	'mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty'
+	'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_ver007.patch')
 _gitroot="https://github.com/MythTV/mythtv.git"
 _gitname="${pkgname}"
 build() {
@@ -46,6 +47,8 @@ build() {
                 echo "-----------------------------"
                 patch -Np0  -i ${startdir}/src/$i  || return 1
         done
+	echo Applying patch for Ceton InfinTV4
+	patch -p2 < ${startdir}/src//ceton_ver007.patch
         echo "--------------------------done applying patches-----------------------------------------------"
 
         sed -i -e "s/\`(svnversion \$\${SVNTREEDIR} 2>\/dev\/null) || echo Unknown\`/$pkgver/" version.pro
@@ -102,4 +105,5 @@ md5sums=('91488a6b1b05d14c5c5c601908b699e5'
          'd048fd37d5061c853b5712d5f187b25d'
          'f735805a80b0d1180dee01f9df1b7004'
          'f407d6af23e74a49540755420f84fa58'
-         '5469d9921b726db750b991c87d226158')
+         '5469d9921b726db750b991c87d226158'
+         'f4abf567356a1f99a0177ac914829bb8')
-- 
cgit v0.12


From 1b716c368383693f2ba72bb9fb36c25e40a1e00a Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 16 Aug 2011 13:24:30 -0700
Subject: ceton-scripts:Initial inclusion. Scripts by Ron Frazier to support
 Ceton InfinTV4 in MythTV.

---
 abs/core/ceton-scripts/PKGBUILD | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 abs/core/ceton-scripts/PKGBUILD

diff --git a/abs/core/ceton-scripts/PKGBUILD b/abs/core/ceton-scripts/PKGBUILD
new file mode 100644
index 0000000..5c7d76b
--- /dev/null
+++ b/abs/core/ceton-scripts/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=ceton-scripts
+pkgver=1
+pkgrel=1
+pkgdesc="Scripts by Ron Frazier for use with Ceton InfiniTV4 and MythTV 0.24"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://linuxtv.org/"
+source=('http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_qam_channelmap.tar.gz'
+	'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_channelmap.tar.gz')
+build() {
+  cd $startdir/src/
+  mkdir -p $startdir/pkg/usr/bin
+  install -m 755 *.pl $pkgdir/usr/bin
+}
+md5sums=('7ef75cb01332ab86d56c348353d59a0e'
+         'ab362902926c01a9b03498cc1aed4d14')
-- 
cgit v0.12


From d7b0ad9151942bf042e6761b6671fb72078e42e0 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Tue, 16 Aug 2011 15:50:24 -0700
Subject: ceton-scripts:Patched so mythtv is default mysql user.

---
 abs/core/ceton-scripts/PKGBUILD   | 11 ++++++++---
 abs/core/ceton-scripts/ccm.patch  | 13 +++++++++++++
 abs/core/ceton-scripts/cqcm.patch | 13 +++++++++++++
 3 files changed, 34 insertions(+), 3 deletions(-)
 create mode 100644 abs/core/ceton-scripts/ccm.patch
 create mode 100644 abs/core/ceton-scripts/cqcm.patch

diff --git a/abs/core/ceton-scripts/PKGBUILD b/abs/core/ceton-scripts/PKGBUILD
index 5c7d76b..8bab8c0 100644
--- a/abs/core/ceton-scripts/PKGBUILD
+++ b/abs/core/ceton-scripts/PKGBUILD
@@ -3,17 +3,22 @@
 
 pkgname=ceton-scripts
 pkgver=1
-pkgrel=1
+pkgrel=2
 pkgdesc="Scripts by Ron Frazier for use with Ceton InfiniTV4 and MythTV 0.24"
 arch=('i686' 'x86_64')
 license=('GPL2')
 url="http://linuxtv.org/"
 source=('http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_qam_channelmap.tar.gz'
-	'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_channelmap.tar.gz')
+	'http://www.ronfrazier.net/mythtv/0.24/downloads/ceton_channelmap.tar.gz'
+	'ccm.patch' 'cqcm.patch')
 build() {
   cd $startdir/src/
+  patch -p0 < ccm.patch
+  patch -p0 < cqcm.patch
   mkdir -p $startdir/pkg/usr/bin
   install -m 755 *.pl $pkgdir/usr/bin
 }
 md5sums=('7ef75cb01332ab86d56c348353d59a0e'
-         'ab362902926c01a9b03498cc1aed4d14')
+         'ab362902926c01a9b03498cc1aed4d14'
+         'b57b7f04c1c177455b47efc958325ab9'
+         '40af5815f67fdf8070cf8aa041928a3b')
diff --git a/abs/core/ceton-scripts/ccm.patch b/abs/core/ceton-scripts/ccm.patch
new file mode 100644
index 0000000..53ec740
--- /dev/null
+++ b/abs/core/ceton-scripts/ccm.patch
@@ -0,0 +1,13 @@
+--- ceton_channelmap.pl.orig	2011-08-16 22:41:03.000000000 +0000
++++ ceton_channelmap.pl	2011-08-16 22:41:47.000000000 +0000
+@@ -8,8 +8,8 @@
+ 
+ my $mysql_host = 'localhost';
+ my $mysql_db = 'mythconverg';
+-my $mysql_user = 'root';
+-my $mysql_pw = 'PUT PASSWORD HERE';
++my $mysql_user = 'mythtv';
++my $mysql_pw = 'mythtv';
+ 
+ -e $wget_path or die "Error: wget does not appear to be in the location specified ($wget_path) . Please configure the \$wget_path variable in this script\n";
+ 
diff --git a/abs/core/ceton-scripts/cqcm.patch b/abs/core/ceton-scripts/cqcm.patch
new file mode 100644
index 0000000..479ed1f
--- /dev/null
+++ b/abs/core/ceton-scripts/cqcm.patch
@@ -0,0 +1,13 @@
+--- ceton_qam_channelmap.pl.orig	2011-08-16 22:41:13.000000000 +0000
++++ ceton_qam_channelmap.pl	2011-08-16 22:42:37.000000000 +0000
+@@ -11,8 +11,8 @@
+ 
+ my $mysql_host = 'localhost';
+ my $mysql_db = 'mythconverg';
+-my $mysql_user = 'root';
+-my $mysql_pw = 'PUT PASSWORD HERE';
++my $mysql_user = 'mythtv';
++my $mysql_pw = 'mythtv';
+ 
+ my $global_modulation = 'qam_256';
+ 
-- 
cgit v0.12