From 63dcfff5cc1e1699defc88edede6171db303969c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 May 2018 18:32:41 +0000
Subject: perl-sub-install: update to 0.928

---
 abs/core/perl_modules/perl-sub-install/PKGBUILD | 63 ++++++++++---------------
 1 file changed, 24 insertions(+), 39 deletions(-)

diff --git a/abs/core/perl_modules/perl-sub-install/PKGBUILD b/abs/core/perl_modules/perl-sub-install/PKGBUILD
index 08b4b65..9fbb71a 100644
--- a/abs/core/perl_modules/perl-sub-install/PKGBUILD
+++ b/abs/core/perl_modules/perl-sub-install/PKGBUILD
@@ -1,46 +1,31 @@
-# Maintainer: Justin Davis (juster) <jrcd83@gmail.com>
-# $Id: PKGBUILD 71649 2012-05-31 15:44:24Z juster $
+# $Id$
+# Maintainer: Jonathan Steel <jsteel@aur.archlinux.org>
+# Contributor: Justin Davis (juster) <jrcd83@gmail.com>
 
 pkgname=perl-sub-install
-pkgver=0.926
-pkgrel=1
-pkgdesc='install subroutines into packages easily'
-arch=(any)
-license=(PerlArtistic GPL)
-options=(!emptydirs)
-depends=(perl)
-url=https://metacpan.org/release/Sub-Install
-source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Sub-Install-$pkgver.tar.gz")
-md5sums=(89a7f82dd840bc2401f281b5f24732b9)
-sha512sums=(c536e1ace79ce8c6bd4a6e580cc2e181671b54f07cef231a84094c854779aee556de4b2ff0a95f0e6a8aca87f77a6e19d148071a48fe5c6e9c0ca15314f0c9cc)
-_dir="$srcdir/Sub-Install-$pkgver"
+pkgver=0.928
+pkgrel=3
+pkgdesc="Install subroutines into packages easily"
+arch=('any')
+url="https://metacpan.org/release/Sub-Install"
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Sub-Install-$pkgver.tar.gz)
+sha1sums=('868c6cb4c0232d9ac3f865f232359f82012be8d6')
 
-build()
-(
-  cd "$_dir"
-  export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
-  unset PERL5LIB PERL_MM_OPT
-  /usr/bin/perl Makefile.PL
+build() {
+  cd Sub-Install-$pkgver
+  perl Makefile.PL INSTALLDIRS=vendor
   make
-)
+}
 
-check()
-(
-  cd "$_dir"
-  export PERL_MM_USE_DEFAULT=1
-  unset PERL5LIB
+check() {
+  cd Sub-Install-$pkgver
   make test
-)
+}
 
-package()
-(
-  cd "$_dir"
-  make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
-  find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-)
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et:
+package() {
+  cd Sub-Install-$pkgver
+  make DESTDIR="$pkgdir" install
+}
-- 
cgit v0.12