From fd8ebb392cd04e7c59ae0dd696d93f0ef509b89c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 6 Aug 2011 00:21:15 -0500
Subject: linhes-config: fix hobbitlclient init.

---
 abs/core/LinHES-config/PKGBUILD   | 6 +++---
 abs/core/LinHES-config/timezip.py | 7 ++++---
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 2df19dd..ebc35f9 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.2
-pkgrel=23
+pkgrel=26
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -107,11 +107,11 @@ md5sums=('c737f8538aea20fcb5f3903957e80837'
          '985891a43f7c4c983eb2a362162f1a0f'
          'd7a8cd4a0060399ae22e69f74e04eb07'
          '7a45287a07145fde5aa664583d4f6fba'
-         '39ca949f82123a5e84902d761a6f9ca2'
+         'c20f73d4da5d7e15e1f3eb85c7dcb49a'
          '8ac1cfd2eca0f641737da0d0aca416a7'
          '9ae8d79f620c6d19973c55c32a921874'
          '95526b4d3dec6c9341088fb6511d831a'
-         'bf32873c56d04c45ff0682f4e345e517'
+         'ecf9e5df20683a769c4a8a8f2d65de85'
          'e459ed069317bccb20351f037a9df3d2'
          '83be9a3bc72179909773479c74d13b38'
          '6aff504ed5e860adc1b7317cd0780900'
diff --git a/abs/core/LinHES-config/timezip.py b/abs/core/LinHES-config/timezip.py
index ca20921..4e494be 100755
--- a/abs/core/LinHES-config/timezip.py
+++ b/abs/core/LinHES-config/timezip.py
@@ -106,9 +106,10 @@ def selectvars():
         result = cursor.fetchone()
         try:
             hobbitclient=result[0]
-        except TypeError:
+        except:
+            hobbitclient="1"
+    else:
             hobbitclient="1"
-
 
 
 def insertvars():
@@ -184,7 +185,7 @@ def insertvars():
 #hobbitclient
     cursor.execute("select *  from settings where value='HostServiceHobbitclient' and hostname=(%s)",(thishostname))
     result = cursor.fetchone()
-    if ( tz != ""):
+    if ( hobbitclient != ""):
          if (result == None):
             cursor.execute("INSERT INTO  settings (value,data,hostname) VALUES ('HostServiceHobbitclient',(%s),(%s))",(hobbitclient,thishostname))
             print "inserting hobbitcleint"
-- 
cgit v0.12