From b49362d14f8daa5a85c215a0db9a3a9d5072df25 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 12 Feb 2009 11:19:26 -0600
Subject: Connect the new software config items int /etc/systemconfig to
 systemconfig.sh.

---
 abs/core-testing/LinHES-config/PKGBUILD        |  2 +-
 abs/core-testing/LinHES-config/systemconfig.sh | 92 +++++++++++++++++---------
 2 files changed, 60 insertions(+), 34 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 8ca54da..2ddac13 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=251
+pkgrel=253
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index 8c21242..4fdbea0 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -391,45 +391,71 @@ function setupplugins (){
 pkglistinstall=""
 pkglistremove=""
 #default enabled
-for i in mythcontrols mythgallery mythmovietime mythmusic mythsmolt mythvideo mythappletrailers mythstream mythvodka
+for i in mythcontrols mythgallery mythmovietime mythmusic mythsmolt mythvideo
 do
-eval pkgvalue=\$${i}
-
-if [ x$pkgvalue = x ]
- then
-     pkglistinstall="$pkglistinstall $i$postfix"
-     else
-     if [ x$pkgvalue = x1 ]
-     then
-         pkglistinstall="$pkglistinstall $i$postfix"
-     else
-         pkglistremove="$pkglistremove $i$postfix"
-     fi
- fi
-
-
-
+    eval pkgvalue=\$${i}
+    if [ x$pkgvalue = x ]
+    then
+        pkglistinstall="$pkglistinstall $i$postfix"
+    else
+        if [ x$pkgvalue = x1 ]
+        then
+            pkglistinstall="$pkglistinstall $i$postfix"
+        else
+            pkglistremove="$pkglistremove $i$postfix"
+        fi
+    fi
 done
 
+#default disabled
+for i in mythphone mytharchive mythbrowser mythnews mythgame mythflix mythweather mythappletrailers mythstream mythvodka
+do
+    eval pkgvalue=\$${i}
+    if [ x$pkgvalue = x ]
+    then
+        pkglistremove="$pkglistremove $i$postfix"
+    else
+        if [ x$pkgvalue = x1 ]
+        then
+            pkglistinstall="$pkglistinstall $i$postfix"
+        else
+            pkglistremove="$pkglistremove $i$postfix"
+        fi
+    fi
+done
+#everything else
+for i in  miro xe romdb xine dvdcss
+do
+    case $i in
+        xine)
+                if [ x$pkgvalue = x1 ]
+                then
+                    pkglistinstall="$pkglistinstall xine-ui"
+                else
+                    pkglistremove="$pkglistremove xine-ui"
+                fi
+            ;;
+        dvdcss)
+                if [ x$pkgvalue = x1 ]
+                then
+                    pkglistinstall="$pkglistinstall libdvdcss"
+                else
+                    pkglistremove="$pkglistremove libdvdcss"
+                fi
+            ;;
+        *)
+            if [ x$pkgvalue = x1 ]
+            then
+                pkglistinstall="$pkglistinstall $i"
+            else
+                pkglistremove="$pkglistremove $i"
+            fi
+        ;;
+esac
 
+done
 
-#default disabled
- for i in mythphone mytharchive mythbrowser mythnews mythgame mythflix mythweather
- do
-eval pkgvalue=\$${i}
 
-if [ x$pkgvalue = x ]
- then
-     pkglistremove="$pkglistremove $i$postfix"
-     else
-     if [ x$pkgvalue = x1 ]
-     then
-         pkglistinstall="$pkglistinstall $i$postfix"
-     else
-         pkglistremove="$pkglistremove $i$postfix"
-     fi
- fi
- done
 install="$pkglistinstall $install"
 remove="$pkglistremove $remove"
 
-- 
cgit v0.12