From 4e350c428b99f783930fc9aa53761bc2df173b2c Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 16:01:22 -0700
Subject: initscripts:Bumped/Updated for LinHES 7.

---
 abs/core-testing/initscripts/PKGBUILD            | 32 ++++++++++++++++--------
 abs/core-testing/initscripts/initscripts.install | 28 ++++-----------------
 abs/core-testing/initscripts/rc.shutdown.patch   | 28 ++++++++-------------
 abs/core-testing/initscripts/rc.sysinit.patch    | 18 ++++---------
 4 files changed, 41 insertions(+), 65 deletions(-)

diff --git a/abs/core-testing/initscripts/PKGBUILD b/abs/core-testing/initscripts/PKGBUILD
index 7f886e0..df2897e 100644
--- a/abs/core-testing/initscripts/PKGBUILD
+++ b/abs/core-testing/initscripts/PKGBUILD
@@ -1,23 +1,33 @@
-# $Id: PKGBUILD 25007 2009-01-22 17:10:39Z aaron $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
+# $Id: PKGBUILD 85250 2010-07-11 09:54:57Z thomas $
+# Maintainer: Thomas Bächler <thomas@archlinux.org>
 # Maintainer: Aaron Griffin <aaron@archlinux.org>
 
 pkgname=initscripts
-pkgver=2009.01
-pkgrel=9
+pkgver=2010.07
+pkgrel=1
 pkgdesc="System initialization/bootup scripts"
 arch=('i686' 'x86_64')
 url="http://www.archlinux.org"
 license=('GPL')
 groups=('base')
 backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown)
-depends=('glibc' 'bash' 'awk' 'grep' 'coreutils' 'sed' 'udev>=118' 'net-tools' 'ncurses' 'kbd' 'findutils')
-source=(ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.gz rc.sysinit.patch rc.shutdown.patch)
-md5sums=('b947f3efd5d4681459fe8073d610f1b5')
+depends=('glibc' 'bash' 'awk' 'grep' 'coreutils' 'sed' 'udev>=139-1'
+         'net-tools' 'ncurses' 'kbd' 'findutils' 'sysvinit')
+optdepends=('bridge-utils: Network bridging support'
+            'dhcpcd: DHCP network configuration'
+            'wireless_tools: Wireless networking')
+install=initscripts.install
+source=(ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}-${pkgrel}.tar.xz rc.sysinit.patch rc.shutdown.patch)
 
 build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}/
-   patch -p0 < $startdir/src/rc.sysinit.patch  || exit 1
-   patch -p0 < $startdir/src/rc.shutdown.patch || exit 1
-  DESTDIR=$startdir/pkg ./install.sh
+  cd ${srcdir}/${pkgname}-${pkgver}-${pkgrel}/
+  patch -p0 < ${srcdir}/rc.sysinit.patch || exit 1
+  patch -p0 < ${srcdir}/rc.shutdown.patch || exit 1
+  DESTDIR=${pkgdir} ./install.sh
 }
+sha256sums=('16b89a9108deacb7d2afd965e59e31aa4b313fc4d1a660fb3cc1fa5c28cfc053'
+            '3a8a82edd680263c4ffa7289fdb6dac69d4611905d093ee3457c00e008e95a1a'
+            'caeb8d9e56783d01001875ffa12d207bc78e06d0fbe3883ce1b68efdfa6ce195')
+sha256sums=('16b89a9108deacb7d2afd965e59e31aa4b313fc4d1a660fb3cc1fa5c28cfc053'
+            '3a8a82edd680263c4ffa7289fdb6dac69d4611905d093ee3457c00e008e95a1a'
+            'fd5248ccfc927ca0d8722cec61c041083b4bf79126176d18d51d5e21378ec5fa')
diff --git a/abs/core-testing/initscripts/initscripts.install b/abs/core-testing/initscripts/initscripts.install
index 9fffa9b..360101c 100644
--- a/abs/core-testing/initscripts/initscripts.install
+++ b/abs/core-testing/initscripts/initscripts.install
@@ -1,25 +1,7 @@
 post_upgrade() {
-  cat << "EOF"
------------------------------------------------------------
-IMPORTANT NOTICE FOR ENCRYPTION USERS
-
-The "password" column in /etc/crypttab has now
-two special keywords:
-- ASK  ask for a passphrase on boot
-- SWAP use a random key and create swapspace
-       This is particularly dangerous, as the
-       volume in question will be overwritten
-       If you use SWAP as your passphrase (which
-       is insecure anyway), be sure to remove it
-       from /etc/crypttab to avoid dataloss!
-
-See /etc/crypttab(.pacnew) for more information.
------------------------------------------------------------
-Attention netcfg users: netcfg is no longer included as
-part of the initscripts package.
-Be aware that rc.conf's NET_PROFILES has changed to
-NETWORKS, and that netcfg must be installed separately.
-For more info, see the netcfg man page.
------------------------------------------------------------
-EOF
+  if [ "$(vercmp $2 2009.07)" -lt 0 ]; then
+    echo "==> Adjusting /etc/inittab for transition to /dev/tty standard."
+    echo "==> Original file saved as /etc/inittab.pacsave"
+    sed -i'.pacsave' 's#vc/\([0-9]\)#tty\1#' /etc/inittab
+  fi
 }
diff --git a/abs/core-testing/initscripts/rc.shutdown.patch b/abs/core-testing/initscripts/rc.shutdown.patch
index 7456b54..329164d 100644
--- a/abs/core-testing/initscripts/rc.shutdown.patch
+++ b/abs/core-testing/initscripts/rc.shutdown.patch
@@ -1,23 +1,15 @@
---- rc.shutdown.orig	2009-02-06 15:32:04.000000000 +0000
-+++ rc.shutdown	2009-02-06 15:45:05.000000000 +0000
-@@ -22,6 +22,12 @@
- 	/etc/rc.local.shutdown
+--- rc.shutdown.orig	2010-08-08 23:50:24.000000000 +0000
++++ rc.shutdown	2010-08-08 23:51:37.000000000 +0000
+@@ -32,6 +32,12 @@
+ 		fi
+ 	done
  fi
- 
 +#unmount network filesystems for runit
-+#if [ -e /var/service/netfs ]
++#if [ -e /var/services/netfs ]
 +#then
-+    /etc/rc.d/netfs stop
++   /etc/rc.d/netfs stop
 +#fi
 +
- if [ "$PREVLEVEL" = "3" -o "$PREVLEVEL" = "5" ]; then
- 	# Shutdown daemons
- 	let i=${#DAEMONS[@]}
-@@ -39,6 +45,7 @@
- 	fi
- fi
- 
-+
- # Terminate all processes
- stat_busy "Sending SIGTERM To Processes"
- /sbin/killall5 -15 &> /dev/null
+ # Shutdown daemons in reverse order
+ let i=${#DAEMONS[@]}-1
+ while [ $i -ge 0 ]; do
diff --git a/abs/core-testing/initscripts/rc.sysinit.patch b/abs/core-testing/initscripts/rc.sysinit.patch
index 6556069..b0253d0 100644
--- a/abs/core-testing/initscripts/rc.sysinit.patch
+++ b/abs/core-testing/initscripts/rc.sysinit.patch
@@ -1,5 +1,5 @@
---- /tmp/rc.sysinit.orig	2009-04-02 16:40:47.000000000 +0000
-+++ rc.sysinit	2009-04-02 16:44:20.000000000 +0000
+--- rc.sysinit.orig	2010-08-08 23:42:36.000000000 +0000
++++ rc.sysinit	2010-08-08 23:44:28.000000000 +0000
 @@ -7,10 +7,9 @@
  . /etc/rc.d/functions
  
@@ -7,18 +7,10 @@
 -printhl "Arch Linux\n"
 -printhl "${C_H2}http://www.archlinux.org"
 -printhl "Copyright 2002-2007 Judd Vinet"
--printhl "Copyright 2007-2009 Aaron Griffin"
-+printhl "LinHES"
-+printhl "The Linux Home Entertainment System"
+-printhl "Copyright 2007-2010 Aaron Griffin"
++printhl "LinHES\n"
++printhl "The Linux Home Entertainment System\n"
 +printhl "${C_H2}http://www.linhes.org"
  printhl "Distributed under the GNU General Public License (GPL)"
  printsep
  
-@@ -85,6 +84,7 @@
- if ! [ "$load_modules" = "off" ]; then
- 	if [ -f /proc/modules ]; then
- 		stat_busy "Loading Modules"
-+		/usr/LH/bin/load-modules-mythvantage.sh
- 		for mod in "${MODULES[@]}"; do
- 			if [ "$mod" = "${mod#!}" ]; then
- 				/sbin/modprobe $mod
-- 
cgit v0.12