From 0d8e27875735262157fde2ec8b9093a52708ebb8 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 11 Apr 2009 21:53:28 -0500
Subject: LinHES-config:  The padded helmet is now optional. Having to change
 sshd config every new install finally annoyed me enough to do something about
 it. By default the helmet is on ensuring the safety of linhes users
 everywhere.

---
 abs/core-testing/LinHES-config/PKGBUILD         |  2 +-
 abs/core-testing/LinHES-config/install_proxy.sh | 10 +++++-----
 abs/core-testing/LinHES-config/systemconfig.sh  | 10 +++++++++-
 3 files changed, 15 insertions(+), 7 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 71a9e2a..3f5bc58 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=388
+pkgrel=394
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates )
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index c73b860..d39f712 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -239,7 +239,7 @@ full_install () {
             mount -t sysfs none $mountpoint/sys
             chroot "$mountpoint"   "$MV_ROOT/bin/install_db_chroot.sh" 2>&1 |tee /tmp/chrootdb.out
             #chroot "$mountpoint"   "$MV_ROOT/bin/install_db_chroot.sh"
-            chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
+            chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,user,this_is_install
             echo "stopping mysql in chroot"
             chroot "$mountpoint" /etc/rc.d/mysqld stop
             kill_dhcp_chroot
@@ -264,14 +264,14 @@ full_install () {
                 chmod 777 $mountpoint/tmp/.dbsysfailed
             else
             #Run second time
-            chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
+            chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,user,this_is_install
             chroot "$mountpoint" $MV_ROOT/bin/restore_default_settings.sh -c  ACCESSCONTROL
             umount -l "$mountpoint/dev"
             umount -l "$mountpoint/proc"
             umount -l "$mountpoint/sys"
             fi
     fi
-    chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh advanced
+    chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh advanced,user
     touch $mountpoint/home/mythtv/.configure && chmod 777 $mountpoint/home/mythtv/.configure
 
     echo "Done" > /tmp/.install_state
@@ -404,7 +404,7 @@ function upgrade () {
          mount --bind /dev "$mountpoint/dev"
          mount --bind /proc "$mountpoint/proc"
 
-        chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
+        chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,user,this_is_install
         #wrap this in a network check_network, no need to update the db if the import worked.
         #####  do I need to start mysql?
         /etc/rc.d/mysqld stop
@@ -457,7 +457,7 @@ function upgrade () {
         fi
         #
         #Run second time
-        chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
+        chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,user,this_is_install
         chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh advanced,this_is_install
         echo "stopping mysql in chroot"
         chroot "$mountpoint" /etc/rc.d/mysqld stop
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index d4894ba..6f8ceb8 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -1173,7 +1173,15 @@ case $i in
 
     this_is_install) MV_NEW_INSTALL="true"
         ;;
-
+    user)
+            if [ x$rootSSH = "x1" ]
+            then
+                sed -i "s/^.*PermitRootLogin.*$/PermitRootLogin yes/" $BASE/etc/ssh/sshd_config
+            else
+                sed -i "s/^.*PermitRootLogin.*$/PermitRootLogin no/" $BASE/etc/ssh/sshd_config
+            fi
+            sv hup sshd
+        ;;
     esac
 done
 
-- 
cgit v0.12