From 684a7deefc1909d5cea43dd69310acc2565def02 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 4 Apr 2009 23:49:01 -0500
Subject: perl-pathtools: Added perl-javascript: Added. Needed for Shepherd.
 REF FS#282

---
 .../perl_modules/perl-javascript/PKGBUILD          | 22 ++++++++++++++++++++++
 .../perl_modules/perl-pathtools/PKGBUILD           | 22 ++++++++++++++++++++++
 .../perl_modules/perl-pathtools/license.txt        |  6 ++++++
 3 files changed, 50 insertions(+)
 create mode 100644 abs/core-testing/perl_modules/perl-javascript/PKGBUILD
 create mode 100644 abs/core-testing/perl_modules/perl-pathtools/PKGBUILD
 create mode 100644 abs/core-testing/perl_modules/perl-pathtools/license.txt

diff --git a/abs/core-testing/perl_modules/perl-javascript/PKGBUILD b/abs/core-testing/perl_modules/perl-javascript/PKGBUILD
new file mode 100644
index 0000000..8ce00cb
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-javascript/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=perl-javascript
+_realname=JavaScript
+pkgver=1.12
+pkgrel=1
+pkgdesc="get name of current working directory"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~KWILLIAMS/Path-Class"
+
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' spidermonkey)
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/C/CL/CLAESJAC/JavaScript-$pkgver.tar.gz)
+#source=(http://search.cpan.org/CPAN/authors/id/T/TB/TBUSCH/JavaScript-SpiderMonkey-0.19.tar.gz)
+build() {
+  cd  $startdir/src/$_realname-$pkgver
+  JS_INC=/usr/include/js   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1 
+  make || return 1
+  make install DESTDIR=$startdir/pkg || return 1
+  find $startdir/pkg -name '.packlist' -delete
+  find $startdir/pkg -name '*.pod' -delete
+}
+
diff --git a/abs/core-testing/perl_modules/perl-pathtools/PKGBUILD b/abs/core-testing/perl_modules/perl-pathtools/PKGBUILD
new file mode 100644
index 0000000..11e69ab
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-pathtools/PKGBUILD
@@ -0,0 +1,22 @@
+
+pkgname=perl-pathtools
+pkgver=3.29
+pkgrel=1
+pkgdesc="get name of current working directory"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~KWILLIAMS/Path-Class"
+
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/PathTools-$pkgver.tar.gz)
+
+build() {
+  cd  $startdir/src/PathTools-$pkgver
+  PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1 
+  make || return 1
+  make install DESTDIR=$startdir/pkg || return 1
+  find $startdir/pkg -name '.packlist' -delete
+  find $startdir/pkg -name '*.pod' -delete
+}
+
diff --git a/abs/core-testing/perl_modules/perl-pathtools/license.txt b/abs/core-testing/perl_modules/perl-pathtools/license.txt
new file mode 100644
index 0000000..508353d
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-pathtools/license.txt
@@ -0,0 +1,6 @@
+"THE BEER-WARE LICENSE" (Revision 42):
+<phk@login.dknet.dk>  wrote this  file.  As  long as  you  retain this
+notice you can  do whatever you want with this stuff.  If we meet some
+day, and you  think this stuff is worth  it, you can buy me  a beer in
+return.  Poul-Henning Kamp
+
-- 
cgit v0.12