From 68f0ad93db42767b17f0c9187354b3f0533e896c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 1 Aug 2009 20:05:47 -0500
Subject: linhes-config: add dhcp-request to systemconfig.py

---
 abs/core-testing/LinHES-config/PKGBUILD        |  2 +-
 abs/core-testing/LinHES-config/systemconfig.py | 12 ++++++++++--
 2 files changed, 11 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 75439cc..fdfadf1 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=65
+pkgrel=68
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo python-pexpect python-netifaces LinHES-timezone python-iplib)
diff --git a/abs/core-testing/LinHES-config/systemconfig.py b/abs/core-testing/LinHES-config/systemconfig.py
index 4418003..b2f8529 100755
--- a/abs/core-testing/LinHES-config/systemconfig.py
+++ b/abs/core-testing/LinHES-config/systemconfig.py
@@ -50,9 +50,9 @@ def main(argv):
     global systemconfig
     systemconfig["MVROOT"]=MVROOT
     restartlcd = False
-    cmdmodule={"misc":False , "sleep":False , "hostype":False , "hostypec":False , "advanced":False , "audio":False , "network":False , "advancedX":False , "webuser":False , "restartfe":False , "reloadfe":False , "ddns":False , "screensaver":False , "ir":False , "this_is_install":False , "user":False, "software":False, "plugins":False, "smolt":False, "all":False}
+    cmdmodule={"misc":False , "sleep":False , "hostype":False , "hostypec":False , "advanced":False , "audio":False , "network":False , "advancedX":False , "webuser":False , "restartfe":False , "reloadfe":False , "ddns":False , "screensaver":False , "ir":False , "this_is_install":False , "user":False, "software":False, "plugins":False, "smolt":False, "all":False, "dhcp_request":False }
     try:
-        opts,  args = getopt.getopt(argv,  'c:hm:',  ["help","modules" ] )
+        opts,  args = getopt.getopt(argv,  'c:hm:d:',  ["help","modules" ] )
     except getopt.GetoptError, why:
         print why
         usage()
@@ -65,6 +65,9 @@ def main(argv):
         elif opt in ("-m"):
             for i in arg.split(","):
                 cmdmodule[i]=True
+        elif opt in ("-d"):
+            dhcp_dev = arg
+
 
     if cmdmodule["this_is_install"] or cmdmodule["hostypec"]:
         systemconfig["hostypec"] = True
@@ -185,6 +188,11 @@ def main(argv):
             mv_common.runcmd(cmd)
         logging.info("__End of ssh user\n")
 
+    if cmdmodule["dhcp_request"]:
+        cmd = '''dhcpcd -t4 -h' ' -Td %s > /tmp/mvnetwork.dhcpinfo ''' %dhcp_dev
+        mv_common.runcmd(cmd)
+
+
 if __name__ == "__main__":
 
     config_file = "mv_config"
-- 
cgit v0.12


From cf2291ab38dfcdd43efafdcd369d54ffb176c640 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 2 Aug 2009 14:29:34 -0700
Subject: hdhomerun:bumped to latest.

---
 abs/core-testing/hdhomerun/PKGBUILD                     |  15 ++++++++-------
 .../hdhomerun/hdhomerun_firmware_20070716.bin           | Bin 90112 -> 0 bytes
 2 files changed, 8 insertions(+), 7 deletions(-)
 delete mode 100644 abs/core-testing/hdhomerun/hdhomerun_firmware_20070716.bin

diff --git a/abs/core-testing/hdhomerun/PKGBUILD b/abs/core-testing/hdhomerun/PKGBUILD
index 8c569d2..0a327b9 100755
--- a/abs/core-testing/hdhomerun/PKGBUILD
+++ b/abs/core-testing/hdhomerun/PKGBUILD
@@ -1,21 +1,22 @@
 pkgname=hdhomerun	
-pkgver=20070726
+pkgver=20090415
 pkgrel=1
 pkgdesc="utils and firmware needed for the hdhomerun"
 arch=(i686 x86_64)
 url="http://www.silicondust.com"
-firmware=hdhomerun_firmware_20070716.bin
-source=("http://download.silicondust.com/hdhomerun/libhdhomerun_20070726.tgz http://download.silicondust.com/hdhomerun/$firmware")
+firmware=hdhomerun_atsc_firmware_20090415.bin
+firmware2=hdhomerun_dvbt_firmware_20090415.bin
+firmware3=hdhomerun_tech_atsc_firmware_20090415.bin
+url=http://download.silicondust.com/hdhomerun
+source=("$url/libhdhomerun_20090415.tgz" "$url/$firmware" "$url/$firmware2" "$url/$firmware3" )
 
 
 build() {
   cd $startdir/src || return 1
-	tar -xvf libhdhomerun_20070726.tgz
 	cd libhdhomerun
 	make || return 1
 	install -D -m755 hdhomerun_config $startdir/pkg/usr/bin/hdhomerun_config
 	cd ..
-	install -D -m755 $firmware $startdir/pkg/lib/firmware/$firmware
-        
-	
+	mkdir -p $startdir/pkg/lib/firmware
+	cp $startdir/src/*.bin $startdir/pkg/lib/firmware/
 }
diff --git a/abs/core-testing/hdhomerun/hdhomerun_firmware_20070716.bin b/abs/core-testing/hdhomerun/hdhomerun_firmware_20070716.bin
deleted file mode 100644
index 6ad51af..0000000
Binary files a/abs/core-testing/hdhomerun/hdhomerun_firmware_20070716.bin and /dev/null differ
-- 
cgit v0.12


From 7224eedb7ce6cc6c4a520cc887c2c5b1eac16191 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 2 Aug 2009 14:33:02 -0700
Subject: local-website:latest

---
 abs/core-testing/local-website/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index c596881..564b238 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=local-website
 pkgver=2
-pkgrel=9
+pkgrel=10
 pkgdesc="Contents of http://localhost"
 arch=(i686 x86_64)
 license=('GPL')
-- 
cgit v0.12