From 117e8d1604d451e12e5f5c32f5a8424d3dd74ca7 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 3 May 2009 13:33:13 -0700
Subject: Initial inclusion of bluetooth support into LinHES.

---
 abs/extra-testing/bluez-firmware/PKGBUILD |  23 +++++++
 abs/extra-testing/bluez-hcidump/PKGBUILD  |  22 +++++++
 abs/extra-testing/bluez/PKGBUILD          |  53 +++++++++++++++
 abs/extra-testing/bluez/bluetooth.conf.d  |  33 ++++++++++
 abs/extra-testing/bluez/rc.bluetooth      | 106 ++++++++++++++++++++++++++++++
 5 files changed, 237 insertions(+)
 create mode 100644 abs/extra-testing/bluez-firmware/PKGBUILD
 create mode 100644 abs/extra-testing/bluez-hcidump/PKGBUILD
 create mode 100644 abs/extra-testing/bluez/PKGBUILD
 create mode 100644 abs/extra-testing/bluez/bluetooth.conf.d
 create mode 100644 abs/extra-testing/bluez/rc.bluetooth

diff --git a/abs/extra-testing/bluez-firmware/PKGBUILD b/abs/extra-testing/bluez-firmware/PKGBUILD
new file mode 100644
index 0000000..64466c1
--- /dev/null
+++ b/abs/extra-testing/bluez-firmware/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Stefano Zamprogno <stefano.zamprogno@gmail.com>
+
+pkgname=bluez-firmware
+pkgver=1.2
+pkgrel=4
+pkgdesc="Firmware for Broadcom BCM203x Blutonium devices"
+url="http://www.bluez.org/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=()
+source=("http://bluez.sf.net/download/$pkgname-$pkgver.tar.gz")
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  ./configure --libdir=/lib || return 1
+  make || return 1
+  make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums=('1cc3cefad872e937e05de5a0a2b390dd')
diff --git a/abs/extra-testing/bluez-hcidump/PKGBUILD b/abs/extra-testing/bluez-hcidump/PKGBUILD
new file mode 100644
index 0000000..25e0fdf
--- /dev/null
+++ b/abs/extra-testing/bluez-hcidump/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Geoffroy carrier <geoffroy@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Joerie de Gram <j.de.gram@gmail.com>
+
+pkgname=bluez-hcidump
+pkgver=1.42
+pkgrel=1
+pkgdesc="Bluetooth HCI package analyzer"
+url="http://www.bluez.org/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('bluez>=4.18')
+source=(http://bluez.sf.net/download/$pkgname-$pkgver.tar.gz)
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+  ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+  make || return 1
+  make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums=('5704737aaf72104eeaf77335218a1827')
diff --git a/abs/extra-testing/bluez/PKGBUILD b/abs/extra-testing/bluez/PKGBUILD
new file mode 100644
index 0000000..9e8f13b
--- /dev/null
+++ b/abs/extra-testing/bluez/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
+pkgname=bluez
+pkgver=4.30
+pkgrel=1
+pkgdesc="Libraries and tools for the Bluetooth protocol stack"
+url="http://www.bluez.org/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('dbus-core' 'glib2')
+makedepends=('gstreamer0.10-base' 'alsa-lib' 'libusb')
+optdepends=('gstreamer0.10-base' 'alsa-lib' 'libusb')
+conflicts=('bluez-libs' 'bluez-utils')
+provides=('bluez-libs' 'bluez-utils')
+replaces=('bluez-libs' 'bluez-utils')
+backup=(etc/bluetooth/{main,rfcomm,audio,network,input}.conf
+        etc/conf.d/bluetooth)
+source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+        'bluetooth.conf.d'
+        'rc.bluetooth')
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+  ./configure --prefix=/usr \
+        --sysconfdir=/etc \
+        --localstatedir=/var \
+        --libexecdir=/lib \
+        --mandir=/usr/share/man \
+        --enable-gstreamer \
+        --enable-alsa \
+        --enable-usb \
+        --enable-netlink \
+        --enable-tools \
+        --enable-bccmd \
+        --enable-hid2hci \
+        --enable-dfutool \
+        --enable-hidd \
+        --enable-pand \
+        --enable-dund \
+        --enable-cups \
+        --enable-manpages \
+        --enable-configfiles \
+        --enable-pcmciarules || return 1
+  make || return 1
+  make DESTDIR="$pkgdir" install || return 1
+
+  install -D -m644 "$srcdir/$pkgname-$pkgver/network/network.conf" "$pkgdir/etc/bluetooth/" || return 1
+  install -D -m644 "$srcdir/$pkgname-$pkgver/input/input.conf"     "$pkgdir/etc/bluetooth/" || return 1
+  install -D -m644 "$srcdir/$pkgname-$pkgver/audio/audio.conf"     "$pkgdir/etc/bluetooth/" || return 1
+  install -D -m755 "$srcdir/rc.bluetooth"                          "$pkgdir/etc/rc.d/bluetooth" || return 1
+  install -D -m644 "$srcdir/bluetooth.conf.d"                      "$pkgdir/etc/conf.d/bluetooth" || return 1
+}
+md5sums=('5c37fb99c03f40269b9245eec3e7b7f4'
+         'd12be5b494525bb1ba6eac5c3983dd3e'
+         '03d4f2463b1b580e8d2ada3767140685')
diff --git a/abs/extra-testing/bluez/bluetooth.conf.d b/abs/extra-testing/bluez/bluetooth.conf.d
new file mode 100644
index 0000000..8f25ef4
--- /dev/null
+++ b/abs/extra-testing/bluez/bluetooth.conf.d
@@ -0,0 +1,33 @@
+# Bluetooth configuraton file
+
+# Bluetooth services (allowed values are "true" and "false")
+
+# Run the bluetoothd daemon (default: true)
+#DAEMON_ENABLE="false"
+
+# Run hid2hci (default: false)
+#HID2HCI_ENABLE="true"
+
+# Run the sdp daemon (default: false)
+# If this is disabled, hcid's internal sdp daemon will be used
+#SDPD_ENABLE="true"
+
+# Run the bluetooth HID daemon (default: false)
+#HIDD_ENABLE="true"
+
+# Activate rfcomm ports (default: false)
+#RFCOMM_ENABLE="true"
+
+# Run bluetooth dial-up networking daemon (default: false)
+#DUND_ENABLE="true"
+
+# Run bluetooth PAN daemon (default: false)
+#PAND_ENABLE="true"
+
+# rfcomm configuration file (default: /etc/bluetooth/rfcomm.conf)
+#RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Options for hidd, dund and pand (default: none)
+#HIDD_OPTIONS=""
+#DUND_OPTIONS=""
+#PAND_OPTIONS=""
diff --git a/abs/extra-testing/bluez/rc.bluetooth b/abs/extra-testing/bluez/rc.bluetooth
new file mode 100644
index 0000000..38b6216
--- /dev/null
+++ b/abs/extra-testing/bluez/rc.bluetooth
@@ -0,0 +1,106 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+DAEMON_NAME="bluetoothd"
+HID2HCI_NAME="hid2hci"
+HIDD_NAME="hidd"
+RFCOMM_NAME="rfcomm"
+PAND_NAME="pand"
+DUND_NAME="dund"
+
+DAEMON_EXEC="/usr/sbin/bluetoothd"
+HID2HCI_EXEC="/usr/sbin/hid2hci"
+HIDD_EXEC="/usr/bin/hidd"
+RFCOMM_EXEC="/usr/bin/rfcomm"
+PAND_EXEC="/usr/bin/pand"
+DUND_EXEC="/usr/bin/dund"
+
+DAEMON_ENABLE="true"
+HID2HCI_ENABLE="false"
+HIDD_ENABLE="false"
+RFCOMM_ENABLE="false"
+DUND_ENABLE="false"
+PAND_ENABLE="false"
+
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+HIDD_OPTIONS=""
+DUND_OPTIONS=""
+PAND_OPTIONS=""
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+case "$1" in
+  start)
+    stat_busy "Starting bluetooth subsystem:"
+    if [ "$DAEMON_ENABLE" = "true" -a -x "$DAEMON_EXEC" ] ; then
+      stat_append " $DAEMON_NAME"
+      $DAEMON_EXEC
+    fi
+    if [ "$HID2HCI_ENABLE" = "true" -a -x "$HID2HCI_EXEC" ] ; then
+      stat_append " $HID2HCI_NAME"
+      $HID2HCI_EXEC --tohci > /dev/null 2>&1 || true
+    fi
+    if [ "$SDPD_ENABLE" = "true" -a -x "$SDPD_EXEC" ] ; then
+      stat_append " $SDPD_NAME"
+      $SDPD_EXEC
+    fi
+    if [ "$HIDD_ENABLE" = "true" -a -x "$HIDD_EXEC" ]; then
+      stat_append " $HIDD_NAME"
+      $HIDD_EXEC $HIDD_OPTIONS --server
+    fi
+    if [ "$RFCOMM_ENABLE" = "true" -a -x "$RFCOMM_EXEC" -a -f "$RFCOMM_CONFIG" ]; then
+      stat_append " $RFCOMM_NAME"
+      $RFCOMM_EXEC -f $RFCOMM_CONFIG bind all
+    fi
+    if [ "$DUND_ENABLE" = "true" -a -x "$DUND_EXEC" -a -n "$DUND_OPTIONS" ]; then
+      stat_append " $DUND_NAME"
+      $DUND_EXEC $DUND_OPTIONS
+    fi
+    if [ "$PAND_ENABLE" = "true" -a -x "$PAND_EXEC" -a -n "$PAND_OPTIONS" ]; then
+      stat_append " $PAND_NAME"
+      $PAND_EXEC $PAND_OPTIONS
+    fi
+    add_daemon bluetooth
+    stat_done
+    ;;
+  stop)
+    stat_busy "Stopping bluetooth subsystem:"
+
+    stat_append " $PAND_NAME"
+    killall $PAND_NAME >/dev/null 2>&1
+
+    stat_append " $DUND_NAME"
+    killall $DUND_NAME >/dev/null 2>&1
+
+    if [ -x "$RFCOMM_EXEC" ]; then
+      stat_append " $RFCOMM_NAME"
+      $RFCOMM_EXEC release all >/dev/null 2>&1
+    fi
+
+    stat_append " $HIDD_NAME"
+    killall $HIDD_NAME >/dev/null 2>&1
+
+    stat_append " $SDPD_NAME"
+    killall $SDPD_NAME >/dev/null 2>&1
+
+    stat_append " $DAEMON_NAME"
+    killall $DAEMON_NAME >/dev/null 2>&1
+
+    rm_daemon bluetooth
+    stat_done
+    ;;
+  restart)
+    $0 stop
+    sleep 1
+    $0 start
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart}"  
+esac
+exit 0
-- 
cgit v0.12