From cff24d02505081b7297a257c38edcf286772e015 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 17 Jan 2009 11:47:26 -0600
Subject: correct exports.template to point to /myth instead of /data/media add
 nfslock to all machine types start netfs

---
 abs/core-testing/LinHES-config/PKGBUILD              |  2 +-
 abs/core-testing/LinHES-config/install_functions.sh  | 10 +++++++---
 abs/core-testing/LinHES-config/systemconfig.sh       | 20 ++++++++++----------
 .../LinHES-config/templates/exports.template         |  2 +-
 .../LinHES-config/templates/fstab.conf.template      |  2 +-
 5 files changed, 20 insertions(+), 16 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index c25ee7e..a3c00c1 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=191
+pkgrel=193
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/install_functions.sh b/abs/core-testing/LinHES-config/install_functions.sh
index fd84d6c..e9d2461 100755
--- a/abs/core-testing/LinHES-config/install_functions.sh
+++ b/abs/core-testing/LinHES-config/install_functions.sh
@@ -470,9 +470,13 @@ case $1 in
                     then
                         if [ -f /tmp/etc/fstab ]
                         then
-                            grep /dev/vg /tmp/etc/fstab >> /$mountpoint/etc/fstab
-                            grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs mkdir
-                            grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs chown -R mythtv:users
+                            grep -q /dev/vg /tmp/etc/fstab
+                            if [ $? = 0 ]
+                            then
+                                grep /dev/vg /tmp/etc/fstab >> /$mountpoint/etc/fstab
+                                grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs mkdir
+                                grep /dev/vg /tmp/etc/fstab | awk -v mount=$mountpoint ' { print "/" mount $2 }' |xargs chown -R mythtv:users
+                            fi
                         fi
                     fi
         ;;
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index 948137a..66ef9cd 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -673,7 +673,7 @@ then
 
 else
       ser_remove="$ser_remove"
-      ser_daemon_remove="nfsd nfslock  $ser_daemon_remove"
+      ser_daemon_remove="nfsd  $ser_daemon_remove"
 fi
 
 if [ x$Runncidd = x1 ]
@@ -856,7 +856,7 @@ function setupcnfs () {
             #if no central nfs found, then use the mbe.
             if [ $SystemType = "Frontend_only" ]
             then
-                setupfstab ${dbhost}:/data/media /data/media
+                setupfstab ${dbhost}:/myth /myth
             fi
 	fi
 
@@ -1130,12 +1130,12 @@ case $SystemType in
                         sudo sv restart avahi
             fi
 
-            install="mysql mythdb-initial  avahli portmap local-website $ser_install"
+            install="mysql mythdb-initial  avahli portmap nfslock local-website $ser_install"
 
 
             remove="none $ser_remove"
 
-            daemon_add="mysql  mythbackend  avahi portmap lighttpd $ser_daemon_add"
+            daemon_add="mysql  mythbackend  avahi portmap nfslock netfs lighttpd $ser_daemon_add"
             daemon_remove="none $ser_daemon_remove"
 
     ;;
@@ -1150,10 +1150,10 @@ case $SystemType in
                         sudo sv restart  avahi
             fi
 
-            install="mysql  mythdb-initial avahi portmap local-website myth2ipod mythtv-status $ser_install  "
+            install="mysql  mythdb-initial avahi portmap nfslock local-website myth2ipod mythtv-status $ser_install  "
             remove="$ser_remove"
 
-            daemon_add="mysql mythbackend  avahi   portmap lighttpd $ser_daemon_add"
+            daemon_add="mysql mythbackend  avahi   portmap nfslock netfs lighttpd $ser_daemon_add"
             daemon_remove="$ser_daemon_remove"
     ;;
     Slave_backend)
@@ -1170,10 +1170,10 @@ case $SystemType in
             fi
 
             #cp $TEMPLATES/mysql.service  ${BASE}/etc/avahi/services/mysql.service
-            install="mysql  avahi  local-website $ser_install  "
+            install="mysql  avahi  local-website portmap nfslock $ser_install  "
             remove=" $ser_remove"
 
-            daemon_add="mythbackend avahi portmap lighttpd $ser_daemon_add"
+            daemon_add="mythbackend avahi portmap nfslock netfs lighttpd $ser_daemon_add"
             daemon_remove="$ser_daemon_remove"
     ;;
     Frontend_only)
@@ -1186,10 +1186,10 @@ case $SystemType in
                         sudo sv restart  avahi
             fi
 
-        install="libmysqlclient mysql-clients portmap avahi local-website $ser_install"
+        install="libmysqlclient mysql-clients portmap nfslock avahi local-website $ser_install"
         remove="mysql mythweb$postfix $ser_remove"
 
-        daemon_add="avahi portmap lighttpd $ser_daemon_add "
+        daemon_add="avahi portmap nfslock netfs lighttpd $ser_daemon_add "
         daemon_remove="mysql   mythbackend  $ser_daemon_remove"
    ;;
 
diff --git a/abs/core-testing/LinHES-config/templates/exports.template b/abs/core-testing/LinHES-config/templates/exports.template
index b946287..b883932 100644
--- a/abs/core-testing/LinHES-config/templates/exports.template
+++ b/abs/core-testing/LinHES-config/templates/exports.template
@@ -3,6 +3,6 @@
 # See exports(5) for a description.
 
 # use exportfs -arv to reread
-/data/media    REPLACEME(rw,all_squash,anonuid=1000,anongid=1000)
+/myth    REPLACEME(rw,all_squash,anonuid=1000,anongid=1000)
 /data/var/cache    REPLACEME(rw,all_squash,anonuid=1000,anongid=1000)
 
diff --git a/abs/core-testing/LinHES-config/templates/fstab.conf.template b/abs/core-testing/LinHES-config/templates/fstab.conf.template
index d27bcd9..f8544cf 100755
--- a/abs/core-testing/LinHES-config/templates/fstab.conf.template
+++ b/abs/core-testing/LinHES-config/templates/fstab.conf.template
@@ -12,5 +12,5 @@ none                   /dev/shm      tmpfs     defaults            0      0
 /dev/sda1 / reiserfs defaults 0 1
 /dev/sda2 swap swap defaults 0 0
 /dev/sda3 /data reiserfs defaults 0 0
-192.168.1.6:/media  /data/media nfs
+192.168.1.6:/myth  /myth nfs
 
-- 
cgit v0.12