From 316d04462eeadfdec54e513357a7ff7a97597a1c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 18 Mar 2010 16:26:14 -0500
Subject: bash-completion: initial import closes 567

---
 abs/extra-testing/bash-completion/PKGBUILD        | 34 +++++++++++++++++++++++
 abs/extra-testing/bash-completion/cowsay.bashcomp | 34 +++++++++++++++++++++++
 2 files changed, 68 insertions(+)
 create mode 100644 abs/extra-testing/bash-completion/PKGBUILD
 create mode 100644 abs/extra-testing/bash-completion/cowsay.bashcomp

diff --git a/abs/extra-testing/bash-completion/PKGBUILD b/abs/extra-testing/bash-completion/PKGBUILD
new file mode 100644
index 0000000..a60a49a
--- /dev/null
+++ b/abs/extra-testing/bash-completion/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 67318 2010-02-06 09:38:55Z eric $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+pkgname=bash-completion
+pkgver=1.1
+pkgrel=3
+pkgdesc="Programmable completion for the bash shell"
+arch=(any)
+url="http://bash-completion.alioth.debian.org/"
+license=('GPL')
+depends=('bash')
+source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.gz cowsay.bashcomp)
+md5sums=('593d3edcf287b9e9d735049bd4d3f229' 'e9766bdc391caf825cb24e704422987e')
+sha1sums=('0e666ebda3d577571ab62bcecc16e1024922cd18' 'a8620aa1029d46bae92be8a6ea0eb62d737545ef')
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  # fixes for archlinux
+  sed -i 's#/sbin/lsmod#/bin/lsmod#' bash_completion || return 1
+
+  ./configure --prefix=/usr --sysconfdir=/etc
+  make || return 1
+  make DESTDIR="$pkgdir" install
+  install -D -m644 "$srcdir/cowsay.bashcomp" "$pkgdir/etc/bash_completion.d/cowsay"
+
+  # apache2ctl doesn't work, even when renamed to apachectl (and sed'd)
+  rm "$pkgdir/etc/bash_completion.d/apache2ctl"
+  # munin-node doesn't work, even i've updated munin to 1.4.0
+  rm "$pkgdir/etc/bash_completion.d/munin-node"
+}
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra-testing/bash-completion/cowsay.bashcomp b/abs/extra-testing/bash-completion/cowsay.bashcomp
new file mode 100644
index 0000000..77d8be9
--- /dev/null
+++ b/abs/extra-testing/bash-completion/cowsay.bashcomp
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/games-misc/cowsay/files/cowsay.bashcomp,v 1.1 2005/02/06 14:37:54 ka0ttic Exp $
+
+# bash command-line completion for cowsay
+# Author: Aaron Walker <ka0ttic@gentoo.org>
+# Modified by: Michal Bentkowski <mr.ecik at gmail.com>
+
+_cowsay() {
+    local cur prev opts x
+    COMPREPLY=()
+    cur="${COMP_WORDS[COMP_CWORD]}"
+    prev="${COMP_WORDS[COMP_CWORD-1]}"
+    opts="-e -f -h -l -n -T -W -b -d -g -p -s -t -w -y"
+
+    if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+        COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
+        return 0
+    fi
+
+    case "${prev}" in
+        -f)
+            COMPREPLY=( $( command ls /usr/share/cowsay| \
+                sed -ne 's/^\('$cur'.*\)\.cow$/\1/p') )
+            return 0
+            ;;
+        -[eTW])
+            COMPREPLY=()
+            ;;
+    esac
+}
+complete -o filenames -F _cowsay cowsay cowthink
+
+# vim: set ft=sh tw=80 sw=4 et :
-- 
cgit v0.12