From c3589abad837334030b962217d470780571060ce Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 31 Jan 2010 14:48:35 -0600
Subject: mythtv-stable: added new menu called LiveTV. This restores the Watch
 TV button to the top of the list. .22 requires menutheme_fallback.patch but
 hopefully .23 will not, as a patch was submitted to mythtv for inclusion.
 closes FS#608

Signed-off-by: James Meyer <james.meyer@operamail.com>
---
 .../mythtv/stable-0.22/mythtv/PKGBUILD             | 18 ++++--
 .../stable-0.22/mythtv/menu-xml/mainmenu.tv.patch  | 68 ++++++++++++++++++++++
 .../stable-0.22/mythtv/menu-xml/themeinfo.xml-tv   | 48 +++++++++++++++
 .../stable-0.22/mythtv/menutheme_fallback.patch    | 18 ++++++
 4 files changed, 148 insertions(+), 4 deletions(-)
 create mode 100644 abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/mainmenu.tv.patch
 create mode 100644 abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/themeinfo.xml-tv
 create mode 100644 abs/core-testing/mythtv/stable-0.22/mythtv/menutheme_fallback.patch

diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
index b671f8e..47cdedd 100755
--- a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.22
-pkgrel=22005
+pkgrel=23247
 pkgdesc="A personal video recorder for Linux"
 url="http://www.mythtv.org"
 license="GPL"
@@ -16,7 +16,7 @@ groups=('pvr')
 #MAKEFLAGS="-j6"
 install='mythtv.install'
 
-patchs=()
+patchs=('menutheme_fallback.patch')
 #patchs=('smolt_jump.patch')
 source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` 'mythbackend.lr' 'mythfrontend.lr' 'pretty')
 arch=('i686' 'x86_64')
@@ -50,7 +50,7 @@ build() {
 	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
 
 	# clean up from last build
-	make distclean
+#	make distclean
 
 	# configure
 	./configure --prefix=/usr --arch=${ARCH} \
@@ -63,7 +63,6 @@ build() {
 	. /etc/profile
 	make || return 1
 	make INSTALL_ROOT=$startdir/pkg install || return 1
-    
 	# install db schema, scripts and docs
 	install -m0644 database/mc.sql $startdir/pkg/usr/share/mythtv/ || return 1
 	install -D -m0755 ../mythbackend $startdir/pkg/etc/rc.d/mythbackend || return 1
@@ -81,6 +80,17 @@ build() {
 	patch -p0 < $startdir/menu-xml/library.xml.patch || return 1
 	patch -p0 < $startdir/menu-xml/util_menu.xml.patch || return 1
 
+	#create new for those that still want live-tv on top
+	mkdir -p $startdir/pkg/usr/share/mythtv/themes/LiveTV
+	cp $startdir/menu-xml/themeinfo.xml-tv $startdir/pkg/usr/share/mythtv/themes/LiveTV/themeinfo.xml
+	cp  $startdir/pkg/usr/share/mythtv/themes/defaultmenu/mainmenu.xml  $startdir/pkg/usr/share/mythtv/themes/LiveTV/
+	cd  $startdir/pkg/usr/share/mythtv/themes/LiveTV/
+	patch -p5 < $startdir/menu-xml/mainmenu.tv.patch || return 1
+	
+
+
+
+
 	# make log dir
 	mkdir -p $startdir/pkg/var/log/mythtv
 	chown 1000.1000 $startdir/pkg/var/log/mythtv
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/mainmenu.tv.patch b/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/mainmenu.tv.patch
new file mode 100644
index 0000000..930fc5b
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/mainmenu.tv.patch
@@ -0,0 +1,68 @@
+--- usr/share/mythtv/themes/defaultmenu/mainmenu.xml.orig	2010-01-07 04:56:58.000000000 +0000
++++ usr/share/mythtv/themes/defaultmenu/mainmenu.xml	2010-01-07 04:57:35.000000000 +0000
+@@ -2,6 +2,32 @@
+ <mythmenu name="MAIN">
+ 
+     <button>
++        <type>TV_WATCH_TV</type>
++        <text>Watch TV</text>
++        <text lang="IT">Guarda la TV</text>
++        <text lang="ES">Ver la TV</text>
++        <text lang="NL">TV Kijken</text>
++        <text lang="DE">Fernsehen</text>
++        <text lang="DA">Se TV</text>
++        <text lang="IS">Horfa á sjónvarp</text>
++        <text lang="PT">Ver Televisão</text>
++        <text lang="SV">Se på TV</text>
++        <text lang="JA">TV放送</text>
++        <text lang="FI">Katso Televisiota</text>
++        <text lang="ZH_TW">觀看電視</text>
++        <text lang="SL">Glej TV</text>
++        <text lang="ET">Vaata telerit</text>
++        <text lang="RU">Смотреть ТВ</text>
++        <text lang="AR">شاهد التلفاز</text>
++        <text lang="PL">Oglądanie TV</text>
++        <text lang="HE">צפיה בטלויזיה</text>
++        <text lang="HU">TV nézés</text>
++        <description>Watch live television</description>
++        <description lang="DE">Jetzt Fernsehen schauen</description>
++        <action>TV_WATCH_LIVE</action>
++    </button>
++
++    <button>
+         <type>MENU_MEDIA_LIBRARY</type>
+         <text>Media Library</text>
+         <text lang="IT">Multimedia</text>
+@@ -130,32 +156,6 @@
+     </button>
+ 
+     <button>
+-        <type>TV_WATCH_TV</type>
+-        <text>Watch TV</text>
+-        <text lang="IT">Guarda la TV</text>
+-        <text lang="ES">Ver la TV</text>
+-        <text lang="NL">TV Kijken</text>
+-        <text lang="DE">Fernsehen</text>
+-        <text lang="DA">Se TV</text>
+-        <text lang="IS">Horfa á sjónvarp</text>
+-        <text lang="PT">Ver Televisão</text>
+-        <text lang="SV">Se på TV</text>
+-        <text lang="JA">TV放送</text>
+-        <text lang="FI">Katso Televisiota</text>
+-        <text lang="ZH_TW">觀看電視</text>
+-        <text lang="SL">Glej TV</text>
+-        <text lang="ET">Vaata telerit</text>
+-        <text lang="RU">Смотреть ТВ</text>
+-        <text lang="AR">شاهد التلفاز</text>
+-        <text lang="PL">Oglądanie TV</text>
+-        <text lang="HE">צפיה בטלויזיה</text>
+-        <text lang="HU">TV nézés</text>
+-        <description>Watch live television</description>
+-        <description lang="DE">Jetzt Fernsehen schauen</description>
+-        <action>TV_WATCH_LIVE</action>
+-    </button>
+-
+-    <button>
+         <type>MENU_UTILITIES_SETUP</type>
+         <text>Service Menu</text>
+         <description>LinHES Service Menu</description>
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/themeinfo.xml-tv b/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/themeinfo.xml-tv
new file mode 100644
index 0000000..64a3207
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/menu-xml/themeinfo.xml-tv
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<themeinfo>
+    <!-- The Theme Name (Required) -->
+    <name>LiveTV</name>
+   
+    <!-- The Theme Types (Required) -->
+    <types>
+        <!-- Type. Legal Values are one or more of: UI, OSD and Menu -->
+        <type>Menu</type>
+    </types>
+   
+    <!-- Theme Author Details (Optional)-->
+    <author>
+        <!-- Your name -->
+        <name></name>
+       
+        <!-- Your Email Address -->
+        <email></email>
+    </author>
+   
+    <!-- The Versioning Info (Required) -->
+    <version>
+        <!-- Major version changes mean the theme is no longer
+             compatible with earlier versions of mythtv -->
+        <major>1</major>
+       
+        <!-- Minor version changes are backwards compatible -->
+        <minor>1</minor>
+    </version>
+   
+    <!-- Theme Details (Required) -->
+    <detail>
+        <!-- At least one thumbnail image named "preview" must be included
+             with the theme.
+             There is no limit to the number of thumbnails.
+             Each thumbnail must be given a different name -->
+        <thumbnail name="preview"></thumbnail>
+       
+        <!-- A description of the theme, including general colours and
+             style. The description should include any details that
+             may help to locate your theme in a search. -->
+        <description></description>
+       
+        <!-- Errata. A list of known faults, missing elements or unfinished
+             areas. e.g. "mythgallery not themed" -->
+        <errata>N/A</errata>
+    </detail>
+</themeinfo>
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/menutheme_fallback.patch b/abs/core-testing/mythtv/stable-0.22/mythtv/menutheme_fallback.patch
new file mode 100644
index 0000000..aa633ff
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/menutheme_fallback.patch
@@ -0,0 +1,18 @@
+Index: libs/libmythui/myththemedmenu.cpp
+===================================================================
+--- libs/libmythui/myththemedmenu.cpp	(revision 23401)
++++ libs/libmythui/myththemedmenu.cpp	(working copy)
+@@ -778,6 +778,13 @@
+     else
+         VERBOSE(VB_FILE+VB_EXTRA, "No menu file " + testdir);
+ 
++    testdir = GetShareDir() + "themes/defaultmenu/" + menuname;
++    file.setFileName(testdir);
++    if (file.exists())
++        return testdir;
++    else
++        VERBOSE(VB_FILE+VB_EXTRA, "No menu file " + testdir);
++
+     return QString();
+ }
+ 
-- 
cgit v0.12