From 099ccac45c11ee6f96198367e9bea7040c9358c8 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 22:57:46 -0700
Subject: tiacx:Bumped/Updated for LinHES 7.

---
 abs/core-testing/tiacx/PKGBUILD            | 25 ++++++---
 abs/core-testing/tiacx/acx.install         | 16 ++----
 abs/core-testing/tiacx/kernel-2.6.30.patch | 16 ++++++
 abs/core-testing/tiacx/kernel-2.6.31.patch | 88 ++++++++++++++++++++++++++++++
 abs/core-testing/tiacx/kernel-2.6.33.patch | 11 ++++
 5 files changed, 138 insertions(+), 18 deletions(-)
 create mode 100644 abs/core-testing/tiacx/kernel-2.6.30.patch
 create mode 100644 abs/core-testing/tiacx/kernel-2.6.31.patch
 create mode 100644 abs/core-testing/tiacx/kernel-2.6.33.patch

diff --git a/abs/core-testing/tiacx/PKGBUILD b/abs/core-testing/tiacx/PKGBUILD
index a55fb12..43b77db 100644
--- a/abs/core-testing/tiacx/PKGBUILD
+++ b/abs/core-testing/tiacx/PKGBUILD
@@ -1,26 +1,35 @@
-# $Id: PKGBUILD 22506 2008-12-26 22:54:41Z tpowa $
+# $Id: PKGBUILD 80410 2010-05-17 07:53:48Z tpowa $
 # Maintainer: James Rayner <iphitus@gmail.com>
 
 pkgname=tiacx
 pkgver=20080210
-pkgrel=10
+pkgrel=15
 pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock arch 2.6 kernel"
 arch=(i686 x86_64)
 url="http://acx100.sourceforge.net/"
 license=('MPL')
-depends=('wireless_tools' 'kernel26>=2.6.28' 'kernel26<2.6.29' 'tiacx-firmware')
+depends=('wireless_tools' 'kernel26>=2.6.34' 'kernel26<2.6.35' 'tiacx-firmware')
+makedepends=('kernel26-headers>=2.6.34' 'kernel26-headers<2.6.35')
 install=acx.install
 source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
-        kernel-2.6.27.patch)
-md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
-         '9895f72f8d0c84956b0f6c3b16df0fe8')
-
-_kernver=2.6.28-LinHES
+        kernel-2.6.27.patch
+        kernel-2.6.30.patch
+        kernel-2.6.31.patch
+        kernel-2.6.33.patch)
+_kernver=2.6.34-LinHES
 
 build() {
     cd $startdir/src/acx-$pkgver
     patch -Np1 -i ../kernel-2.6.27.patch || return 1
+    patch -Np0 -i ../kernel-2.6.30.patch || return 1
+    patch -Np1 -i ../kernel-2.6.31.patch || return 1
+    patch -Np0 -i ../kernel-2.6.33.patch || return 1
     make -C /lib/modules/${_kernver}/build M=`pwd` || return 1
     install -D acx.ko $startdir/pkg/lib/modules/${_kernver}/kernel/drivers/net/wireless/tiacx/acx.ko
     sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install
 }
+md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
+         '9895f72f8d0c84956b0f6c3b16df0fe8'
+         'e2900aee839ce711a7f7606b3e3de36e'
+         'dbcb276d77df7801cef58a85c18dfe94'
+         '9cd35ea33b8abdd2e4efec485b05477e')
diff --git a/abs/core-testing/tiacx/acx.install b/abs/core-testing/tiacx/acx.install
index 8d11348..b858f58 100644
--- a/abs/core-testing/tiacx/acx.install
+++ b/abs/core-testing/tiacx/acx.install
@@ -1,23 +1,19 @@
 # arg 1:  the new package version
 post_install() {
-  KERNEL_VERSION='2.6.28-LinHES'
-  depmod -v $KERNEL_VERSION > /dev/null 2>&1 
+  KERNEL_VERSION='2.6.34-LinHES'
+  depmod $KERNEL_VERSION > /dev/null 2>&1 
 }
 
 # arg 1:  the new package version
 # arg 2:  the old package version
 post_upgrade() {
-  KERNEL_VERSION='2.6.28-LinHES'
-  depmod -v $KERNEL_VERSION > /dev/null 2>&1	 
+  KERNEL_VERSION='2.6.34-LinHES'
+  depmod $KERNEL_VERSION > /dev/null 2>&1	 
   
 }
 
 # arg 1:  the old package version
 post_remove() {
-  KERNEL_VERSION='2.6.28-LinHES'
-  depmod -v $KERNEL_VERSION > /dev/null 2>&1	 
+  KERNEL_VERSION='2.6.34-LinHES'
+  depmod $KERNEL_VERSION > /dev/null 2>&1	 
 }
-
-op=$1
-shift
-$op $*
diff --git a/abs/core-testing/tiacx/kernel-2.6.30.patch b/abs/core-testing/tiacx/kernel-2.6.30.patch
new file mode 100644
index 0000000..b5d94a1
--- /dev/null
+++ b/abs/core-testing/tiacx/kernel-2.6.30.patch
@@ -0,0 +1,16 @@
+--- wlan_compat.h~	2009-06-12 09:17:30.000000000 +0200
++++ wlan_compat.h	2009-06-12 09:17:30.000000000 +0200
+@@ -217,13 +217,6 @@
+ /*=============================================================*/
+ #define WLAN_PACKED	__attribute__ ((packed))
+ 
+-/* Interrupt handler backwards compatibility stuff */
+-#ifndef IRQ_NONE
+-#define IRQ_NONE
+-#define IRQ_HANDLED
+-typedef void irqreturn_t;
+-#endif
+-
+ #ifndef ARPHRD_IEEE80211_PRISM
+ #define ARPHRD_IEEE80211_PRISM 802
+ #endif
diff --git a/abs/core-testing/tiacx/kernel-2.6.31.patch b/abs/core-testing/tiacx/kernel-2.6.31.patch
new file mode 100644
index 0000000..2a89e3c
--- /dev/null
+++ b/abs/core-testing/tiacx/kernel-2.6.31.patch
@@ -0,0 +1,88 @@
+--- acx-20080210/pci.c	2008-02-10 21:06:42.000000000 +0100
++++ acx-20080210/pci.c	2009-09-11 22:27:28.000000000 +0200
+@@ -1437,6 +1437,19 @@
+ 
+ static void dummy_netdev_init(struct net_device *ndev) {}
+ 
++static const struct net_device_ops acx_netdev_ops = {
++	.ndo_open = &acxpci_e_open,
++	.ndo_stop = &acxpci_e_close,
++	.ndo_start_xmit = &acx_i_start_xmit,
++	.ndo_get_stats = &acx_e_get_stats,
++#if IW_HANDLER_VERSION <= 5
++	.ndo_get_wireless_stats = &acx_e_get_wireless_stats,
++#endif
++	.ndo_set_multicast_list = &acxpci_i_set_multicast_list,
++	.ndo_tx_timeout = &acxpci_i_tx_timeout,
++	.ndo_change_mtu = &acx_e_change_mtu,
++};
++	
+ #ifdef CONFIG_PCI
+ static int __devinit acxpci_e_probe(struct pci_dev *pdev, const struct pci_device_id *id)
+ {
+@@ -1547,17 +1560,8 @@
+ 	}
+ 
+ 	ether_setup(ndev);
+-	ndev->open = &acxpci_e_open;
+-	ndev->stop = &acxpci_e_close;
+-	ndev->hard_start_xmit = &acx_i_start_xmit;
+-	ndev->get_stats = &acx_e_get_stats;
+-#if IW_HANDLER_VERSION <= 5
+-	ndev->get_wireless_stats = &acx_e_get_wireless_stats;
+-#endif
+-	ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+-	ndev->set_multicast_list = &acxpci_i_set_multicast_list;
+-	ndev->tx_timeout = &acxpci_i_tx_timeout;
+-	ndev->change_mtu = &acx_e_change_mtu;
++	ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
++	ndev->netdev_ops = &acx_netdev_ops;
+ 	ndev->watchdog_timeo = 4 * HZ;
+ 	ndev->irq = pdev->irq;
+ 	ndev->base_addr = pci_resource_start(pdev, 0);
+--- acx-20080210/usb.c	2008-02-10 21:06:42.000000000 +0100
++++ acx-20080210/usb.c	2009-09-11 22:38:42.000000000 +0200
+@@ -778,6 +778,21 @@
+ static void
+ dummy_netdev_init(struct net_device *ndev) {}
+ 
++static const struct net_device_ops acxusb_netdev_ops = {
++	.ndo_open = &acxusb_e_open,
++	.ndo_stop = &acxusb_e_close,
++	.ndo_start_xmit = (void *)&acx_i_start_xmit,
++	.ndo_get_stats = (void *)&acx_e_get_stats,
++#if IW_HANDLER_VERSION <= 5
++	.ndo_get_wireless_stats = (void *)&acx_e_get_wireless_stats,
++#endif
++	.ndo_set_multicast_list = (void *)&acxusb_i_set_rx_mode,
++#ifdef HAVE_TX_TIMEOUT
++	.ndo_tx_timeout = &acxusb_i_tx_timeout,
++#endif
++	.ndo_change_mtu = &acx_e_change_mtu,
++};
++
+ static int
+ acxusb_e_probe(struct usb_interface *intf, const struct usb_device_id *devID)
+ {
+@@ -845,20 +860,11 @@
+ 	/* Register the callbacks for the network device functions */
+ 
+ 	ether_setup(ndev);
+-	ndev->open = &acxusb_e_open;
+-	ndev->stop = &acxusb_e_close;
+-	ndev->hard_start_xmit = (void *)&acx_i_start_xmit;
+-	ndev->get_stats = (void *)&acx_e_get_stats;
+-#if IW_HANDLER_VERSION <= 5
+-	ndev->get_wireless_stats = (void *)&acx_e_get_wireless_stats;
+-#endif
+ 	ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+-	ndev->set_multicast_list = (void *)&acxusb_i_set_rx_mode;
++	ndev->netdev_ops = &acxusb_netdev_ops;
+ #ifdef HAVE_TX_TIMEOUT
+-	ndev->tx_timeout = &acxusb_i_tx_timeout;
+ 	ndev->watchdog_timeo = 4 * HZ;
+ #endif
+-	ndev->change_mtu = &acx_e_change_mtu;
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)) && defined(SET_MODULE_OWNER)
+ 	SET_MODULE_OWNER(ndev);
+ #endif
diff --git a/abs/core-testing/tiacx/kernel-2.6.33.patch b/abs/core-testing/tiacx/kernel-2.6.33.patch
new file mode 100644
index 0000000..f486009
--- /dev/null
+++ b/abs/core-testing/tiacx/kernel-2.6.33.patch
@@ -0,0 +1,11 @@
+--- pci.c~	2010-02-27 19:30:54.000000000 +0100
++++ pci.c	2010-02-27 19:30:54.000000000 +0100
+@@ -35,7 +35,7 @@
+ 
+ /* Linux 2.6.18+ uses <linux/utsrelease.h> */
+ #ifndef UTS_RELEASE
+-#include <linux/utsrelease.h>
++#include <generated/utsrelease.h>
+ #endif
+ 
+ #include <linux/compiler.h> /* required for Lx 2.6.8 ?? */
-- 
cgit v0.12