From a24e76ac094b2c26d12b867a12587d2c0409dc3f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 26 Feb 2009 23:53:09 -0800
Subject: Fixed install file.

---
 abs/core-testing/v4l-dvb/PKGBUILD        | 2 +-
 abs/core-testing/v4l-dvb/v4l-dvb.install | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/v4l-dvb/PKGBUILD b/abs/core-testing/v4l-dvb/PKGBUILD
index 2e3f46a..10f76a5 100644
--- a/abs/core-testing/v4l-dvb/PKGBUILD
+++ b/abs/core-testing/v4l-dvb/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=v4l-dvb
 _kernver=2.6.28-LinHES
 pkgver=1
-pkgrel=4
+pkgrel=5
 pkgdesc="V4L-DVB drivers from mercurial"
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/core-testing/v4l-dvb/v4l-dvb.install b/abs/core-testing/v4l-dvb/v4l-dvb.install
index 1c17557..7ae7ed0 100644
--- a/abs/core-testing/v4l-dvb/v4l-dvb.install
+++ b/abs/core-testing/v4l-dvb/v4l-dvb.install
@@ -1,20 +1,20 @@
 # arg 1:  the new package version
 post_install() {
-  KERNEL_VERSION='2.6.27-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1                
 }
 
 # arg 1:  the new package version
 # arg 2:  the old package version
 post_upgrade() {
-  KERNEL_VERSION='2.6.27-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
 
 }
 
 # arg 1:  the old package version
 post_remove() {
-  KERNEL_VERSION='2.6.27-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
 }
 
-- 
cgit v0.12


From 2144c0e196d48e5a091b66aeb8ab444ff119269e Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 27 Feb 2009 01:03:13 -0800
Subject: Added lirc_mod_mce.

---
 abs/core-testing/lirc/PKGBUILD           | 15 ++++++++++++---
 abs/core-testing/lirc/lirc_mod_mce.patch | 12 ++++++++++++
 2 files changed, 24 insertions(+), 3 deletions(-)
 create mode 100644 abs/core-testing/lirc/lirc_mod_mce.patch

diff --git a/abs/core-testing/lirc/PKGBUILD b/abs/core-testing/lirc/PKGBUILD
index ef2359b..f6fff65 100644
--- a/abs/core-testing/lirc/PKGBUILD
+++ b/abs/core-testing/lirc/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=lirc
 pkgver=0.8.5CVS
-pkgrel=1
+pkgrel=2
 _kernver=2.6.28-LinHES
 pkgdesc="Linux Infrared Remote Control kernel modules for stock arch kernel"
 arch=(i686 x86_64)
@@ -17,7 +17,9 @@ install=$pkgname.install
 source=(http://www.blushingpenguin.com/mark/lmilk/lirc-0.8.5-CVS-pvr150.tar.bz2 \
 	kernel-2.6.26.patch
 	kernel-2.6.27.patch
-	lirc_atiusb.patch)
+	lirc_atiusb.patch
+	http://superb-east.dl.sourceforge.net/sourceforge/mod-mce/lirc_mod_mce-0.2.0.tar.bz2
+	lirc_mod_mce.patch)
 
 build() {
 	# configure
@@ -50,7 +52,14 @@ build() {
 	# set the kernel we've built for inside the install script
 	sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
 		$startdir/lirc.install || return 1
+	cd $startdir/src/lirc_mod_mce
+	cp ../lirc-0.8.5-CVS-pvr150/drivers/lirc_dev/lirc_dev.h .
+	patch -p1 < ../lirc_mod_mce.patch
+	make KDIR=/usr/src/linux-2.6.28-LinHES/
+	cp lirc_mod_mce.ko $startdir/pkg/lib/modules/2.6.28-LinHES/kernel/drivers/misc/
 }
 md5sums=('8f3ba7eb57529992f3991d6981a3feb6'
          '1753acd774f50b638e6173d364de53fd'
-         '6f151eb4e81fc7776a06c9063e6ad9a5')
+         '6f151eb4e81fc7776a06c9063e6ad9a5'
+	 '563f992342df81317fe4ae2b1157cc5e'
+	 'a966b297a0768386f845348f736c6db3')
diff --git a/abs/core-testing/lirc/lirc_mod_mce.patch b/abs/core-testing/lirc/lirc_mod_mce.patch
new file mode 100644
index 0000000..0d07995
--- /dev/null
+++ b/abs/core-testing/lirc/lirc_mod_mce.patch
@@ -0,0 +1,12 @@
+diff -ruaN lirc_mod_mce.orig/lirc_mod_mce.c lirc_mod_mce/lirc_mod_mce.c
+--- lirc_mod_mce.orig/lirc_mod_mce.c	2008-04-26 08:42:47.000000000 +0000
++++ lirc_mod_mce/lirc_mod_mce.c	2009-02-27 08:50:31.000000000 +0000
+@@ -1298,7 +1298,7 @@
+     input_dev->name = ir->name;
+     input_dev->phys = ir->phys;
+     usb_to_input_id(dev, &input_dev->id);
+-    input_dev->cdev.dev = &dev->dev;
++    input_dev->dev.parent = &dev->dev;
+     input_dev->evbit[BIT_WORD(EV_KEY)] |= BIT_MASK(EV_KEY);
+     input_dev->evbit[BIT_WORD(EV_REL)] |= BIT_MASK(EV_REL);
+     input_dev->relbit[BIT_WORD(REL_X)] |= BIT_MASK(REL_X);
-- 
cgit v0.12


From 02a1e16db70661cb8fffc1a6f4452c0c360f51cf Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 27 Feb 2009 01:03:43 -0800
Subject: Updated to latest.  Removed replaces mythtv.

---
 abs/extra-testing/community/mythtv-vdpau/PKGBUILD | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/abs/extra-testing/community/mythtv-vdpau/PKGBUILD b/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
index 3a1b2f1..c447d10 100644
--- a/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
+++ b/abs/extra-testing/community/mythtv-vdpau/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv-vdpau
 pkgver=0.21
-pkgrel=1
+pkgrel=2
 pkgdesc="A Homebrew PVR project"
 arch=('i686' 'x86_64')
 depends=('bash' 'mysql-clients>=5.0' 'qt3' 'lame' 'lirc-utils' 'ffmpeg' \
@@ -9,13 +9,12 @@ backup=(etc/mythtv/mythbackend.conf etc/mythtv/mysql.txt usr/share/mythtv/is.xml
 source=(ftp://ftp.knoppmyth.net/R6/sources/mythtv-${pkgver}-fixes.tar.bz2 \
 	mythbackend myththemedmenu.cpp.patch myththemedmenu.h.patch  \
 	smolt_jump.patch pretty \
-	http://www.avenard.org/files/mythtv-vdpau/mythtv-fixes-glvdpau19990.patch.gz)
+	http://www.avenard.org/files/media/vdpau/mythtv-fixes-glvdpau20018.patch.gz)
 
 #md5sums=('e316ed18d7ac837cf8c4af54b1478793' '7ef6de58240e7aad389a0b13d91b1cf6'\
 #         'a0ecb7f476cb71c0c1ac90d349fc7695')
 conflicts=('mythtv')
-provides=('mythtv'${pkgver})
-replaces=('mythtv')
+provides=('mythtv'=${pkgver})
 license=('GPL2')
 makedepends=(libgl subversion nvidia-utils-beta)
 groups=('pvr')
@@ -24,7 +23,7 @@ install=mythtv.install
 
 build() {
 	cd $startdir/src/mythtv-${pkgver} || return 1
-	svn update -r 19990
+	svn update
 
 #apply patches 
 	 patch -p0 < ../myththemedmenu.cpp.patch
@@ -33,7 +32,7 @@ build() {
 #	 patch -p0 < ../pop_be_restart.cpp.patch
 	 patch -p0 < ../smolt_jump.patch
 #	 patch -p0 < ../2.6.28_dvb_api_version.diff
-       	patch -p1 < ../mythtv-fixes-glvdpau19990.patch
+       	patch -p1 < ../mythtv-fixes-glvdpau20018.patch
 
    . /etc/profile.d/qt3.sh
 
-- 
cgit v0.12


From 74bc1ff0d10516cf4eb0d9f2d182225e4f684768 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 27 Feb 2009 01:03:57 -0800
Subject: Fixed kernel version.

---
 abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD              | 2 +-
 abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD b/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD
index d5437e2..06f17bf 100644
--- a/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD
+++ b/abs/extra-testing/v4l-dvb-hdpvr/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=v4l-dvb-hdpvr
 _kernver=2.6.28-LinHES
 pkgver=1
-pkgrel=4
+pkgrel=5
 pkgdesc="V4L-DVB drivers for HD-PVR from mercurial"
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
index c87bb82..7ae7ed0 100644
--- a/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
+++ b/abs/extra-testing/v4l-dvb-hdpvr/v4l-dvb-hdpvr.install
@@ -1,20 +1,20 @@
 # arg 1:  the new package version
 post_install() {
-  KERNEL_VERSION='2.6.26-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1                
 }
 
 # arg 1:  the new package version
 # arg 2:  the old package version
 post_upgrade() {
-  KERNEL_VERSION='2.6.26-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
 
 }
 
 # arg 1:  the old package version
 post_remove() {
-  KERNEL_VERSION='2.6.26-ARCH'
+  KERNEL_VERSION='2.6.28-LinHES'
   depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
 }
 
-- 
cgit v0.12