From a56552217f33d3ce4d72d65ca19056d45858a4ee Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 10:29:53 +0900
Subject: LinHES-config mythinstall foldingathome: initial inclusion of
 Folding@home

---
 abs/core-testing/LinHES-config/PKGBUILD            |   2 +-
 abs/core-testing/LinHES-config/mv_software.py      |   6 +-
 abs/core-testing/mythinstall/PKGBUILD              |   3 +-
 abs/core-testing/mythinstall/installsettings.cpp   |  72 +++++++++++++-
 abs/core-testing/mythinstall/installsettings.h     |   3 +
 abs/core-testing/mythinstall/xorgsettings.h        |   3 +-
 abs/extra-testing/community/foldingathome/PKGBUILD |  16 ++-
 .../foldingathome/archpatch_foldingathome.diff     | 110 ---------------------
 .../community/foldingathome/foldingathome.install  |  56 +++++++----
 9 files changed, 119 insertions(+), 152 deletions(-)
 delete mode 100644 abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
 mode change 100755 => 100644 abs/extra-testing/community/foldingathome/foldingathome.install

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index cbe41ab..de4e94b 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=89
+pkgrel=90
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index 7421e08..0a96bb3 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -19,7 +19,7 @@ def setup_software(systemconfig, data_config):
 
       default_installed=("mythcontrols", "mythgallery", "mythmovies",
                           "mythmusic", "mythsmolt", "mythvideo")
-      other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+      other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mythvodka")
     else:
       default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
                           "mythgame", "mythflix", "mythweather",
@@ -27,7 +27,7 @@ def setup_software(systemconfig, data_config):
 
       default_installed=("mythcontrols", "mythgallery", "mythmovies",
                           "mythmusic", "mythsmolt", "mythvideo")
-      other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+      other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome")
 
     for pkg in default_disabled:
         pkgname=pkg+postfix
@@ -56,4 +56,4 @@ def setup_software(systemconfig, data_config):
                 mv_common.pacremove(pkg)
         except:
             logging.debug("   ERROR-- %s is not defined", pkg)
-    logging.info("__End Software\n ")
\ No newline at end of file
+    logging.info("__End Software\n ")
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index 75654f1..c614fac 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=1
-pkgrel=9
+pkgrel=10
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=i686
 depends=()
@@ -47,4 +47,3 @@ build() {
     ln -s MythVantage mythinstall
     cd -
 }
-
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 7315464..3942460 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1277,6 +1277,62 @@ static HostCheckBox *Hostfuppes()
     return gc;
 };
 
+static HostCheckBox *Hostfoldingathome()
+{
+    HostCheckBox *gc = new HostCheckBox("Hostfoldingathome");
+    gc->setLabel(QObject::tr("Folding@home"));
+    gc->setValue(false);
+    gc->setHelpText(QObject::tr("A distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."));
+    return gc;
+};
+
+static HostComboBox *Hostfoldingusername()
+{
+    // If there is an old R5.5 style folding directory /myth/folding@home, attempt 
+    // to retrieve the old username.
+    
+    FILE *username_pipe;
+    username_pipe = 
+      popen (
+        "grep username= /myth/folding@home/client.cfg 2> /dev/null | "
+        "sed 's/username=//g'", "r");
+
+    if (username_pipe)
+    {
+      char username[200];
+      if (fgets (username, sizeof (username), username_pipe))
+      {
+    	  char *new_line;
+	  username[sizeof(username)-1]=0;
+	  if ((new_line = strchr (username, '\n')))
+	    new_line[0] = 0;
+
+	  cout << "found old username " << username << endl;
+
+    	  gContext->SetSetting("Hostfoldingusername", username);
+    	  gContext->SaveSetting("Hostfoldingusername", username);
+      }
+      pclose (username_pipe);
+    }
+
+    HostComboBox *gc = new HostComboBox("Hostfoldingusername",true);
+    gc->setLabel(QObject::tr("Folding Username"));
+    gc->setValue("");
+
+    gc->setHelpText(QObject::tr("The username associated to the work-units you return."));
+    return gc;
+};
+
+static HostComboBox *Hostfoldingworksize()
+{
+    HostComboBox *gc = new HostComboBox("Hostfoldingworksize");
+    gc->setLabel(QObject::tr("Work Packet Size"));
+    gc->addSelection("Big", "big");
+    gc->addSelection("Normal", "normal");
+    gc->addSelection("Small", "small");
+    gc->setHelpText(QObject::tr("Acceptable size of work assignment and work result packets (bigger units may have large memory demands)."));
+    return gc;
+};
 
 static HostCheckBox *HostXscreensaver()
 {
@@ -3880,6 +3936,9 @@ void writesettings ()
         hostparm.ThisHostXine = gContext->GetSetting("HostXine");
         hostparm.ThisHostwebmin = gContext->GetSetting("Hostwebmin");
         hostparm.ThisHostfuppes = gContext->GetSetting("Hostfuppes");
+        hostparm.ThisHostfoldingathome = gContext->GetSetting("Hostfoldingathome");
+        hostparm.ThisHostfoldingusername = gContext->GetSetting("Hostfoldingusername");
+        hostparm.ThisHostfoldingworksize = gContext->GetSetting("Hostfoldingworksize");
         hostparm.ThisHostDDnslogin = gContext->GetSetting("HostDDnslogin");
         hostparm.ThisHostDDnspassword = gContext->GetSetting("HostDDnspassword");
         hostparm.ThisHostDDnshostname = gContext->GetSetting("HostDDnshostname");
@@ -4124,7 +4183,9 @@ void writesettings ()
         myfile << "xine=\"" + hostparm.ThisHostXine  + "\"\n";
         myfile << "webmin=\"" + hostparm.ThisHostwebmin  + "\"\n";
         myfile << "fuppes=\"" + hostparm.ThisHostfuppes  + "\"\n";
-
+        myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome  + "\"\n";
+        myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername  + "\"\n";
+        myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize  + "\"\n";
 
 
 
@@ -4378,6 +4439,10 @@ MythInstallSettings::MythInstallSettings()
                     ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
                     GridShowPlugin5->addChild(Hostfuppes());
 
+		    ConfigurationGroup *GridShowPlugin6 = new VerticalConfigurationGroup(true,true);
+                    GridShowPlugin6->addChild(Hostfoldingathome());
+                    GridShowPlugin6->addChild(Hostfoldingusername());
+                    GridShowPlugin6->addChild(Hostfoldingworksize());
 
                     ConfigurationGroup *Mythvideoplugin = new HorizontalConfigurationGroup();
                         Mythvideoplugin->addChild(Hostpluginmythvideo());
@@ -4395,6 +4460,7 @@ MythInstallSettings::MythInstallSettings()
                     addChild(GridShowPlugin3);
                     addChild(GridShowPlugin4);
                     addChild(GridShowPlugin5);
+                    addChild(GridShowPlugin6);
                 }
             }
             if ( displayuser )
@@ -4475,7 +4541,3 @@ MythInstallSettings::MythInstallSettings()
 
 };
 
-
-
-
-
diff --git a/abs/core-testing/mythinstall/installsettings.h b/abs/core-testing/mythinstall/installsettings.h
index 55203f0..c140f3d 100755
--- a/abs/core-testing/mythinstall/installsettings.h
+++ b/abs/core-testing/mythinstall/installsettings.h
@@ -455,6 +455,9 @@ struct HostParms
         QString ThisHostXine;
         QString ThisHostwebmin;
         QString ThisHostfuppes;
+        QString ThisHostfoldingathome;
+        QString ThisHostfoldingusername;
+        QString ThisHostfoldingworksize;
 
         QString ThisHostDDnslogin;
         QString ThisHostDDnspassword;
diff --git a/abs/core-testing/mythinstall/xorgsettings.h b/abs/core-testing/mythinstall/xorgsettings.h
index 4a4ed34..46c4952 100755
--- a/abs/core-testing/mythinstall/xorgsettings.h
+++ b/abs/core-testing/mythinstall/xorgsettings.h
@@ -152,7 +152,7 @@ static HostComboBox *HostXres()
 	    if (strcmp (previous_mode, separator) == 0)
 	      continue;
 
-	    strncpy (previous_mode, separator, 200);
+	    strncpy (previous_mode, separator, sizeof(previous_mode));
   	    gc->addSelection(separator, line_in);
 	    found_modes_in_xorg_log = TRUE;
 
@@ -161,6 +161,7 @@ static HostComboBox *HostXres()
 	        defaults_added[def]=1;
 	  }
 	}
+	pclose (modelines);
       }
     }
 
diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index 411702c..ffd256e 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=foldingathome
 pkgver=6.02
-pkgrel=1
+pkgrel=2
 pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
 arch=('i686')
 url="http://folding.stanford.edu/"
@@ -13,16 +13,14 @@ depends=('bash')
 backup=('etc/conf.d/foldingathome')
 install=foldingathome.install
 source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
-	archpatch_foldingathome.diff)
+	run)
 md5sums=('112b3d66909050f1bb990993a1464cb9'
-         '02f4ca64d552b442d484c51fa5f4228a')
+         '7e1b3f2a6768b4fbeb415922a1a9c2e6')
 
 build() {
   cd $startdir/src/
-  patch -p1 <archpatch_foldingathome.diff
-  install -D -c -m755 fah6 $startdir/pkg/opt/fah/fah6 || return 1
-  install -D -c -m755 $startdir/src/foldingathome.rc.d $startdir/pkg/etc/rc.d/foldingathome || return 1
-  install -D -c -m644 $startdir/src/foldingathome.conf.d $startdir/pkg/etc/conf.d/foldingathome || return 1
-  install -D -m644 foldingathome.license $startdir/pkg/usr/share/licenses/$pkgname/COPYING
-  
+
+  # At this stage, the mpiexec is not included because it requires x86_64.
+  install -D -c -m755 fah6 $startdir/pkg/usr/bin/fah6 || return 1
+  install -D -m755 run $startdir/pkg/etc/sv/fah/run
 }
diff --git a/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff b/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
deleted file mode 100644
index 73410f1..0000000
--- a/abs/extra-testing/community/foldingathome/archpatch_foldingathome.diff
+++ /dev/null
@@ -1,110 +0,0 @@
-diff -Naur blank/foldingathome.conf.d 6.02-1/foldingathome.conf.d
---- blank/foldingathome.conf.d	1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.conf.d	2008-08-21 16:59:05.000000000 -0700
-@@ -0,0 +1,12 @@
-+#
-+# Optional user settings for foldingathome daemon
-+#
-+# If you prefer not to run fah as root then you can identifer a current or
-+# specially created user here.
-+
-+FAH_USER=""
-+
-+# If you wish to associate this user with a specific group you can enter the
-+# group name here.  If left blank the default is "users".
-+
-+FAH_GRP=""
-diff -Naur blank/foldingathome.license 6.02-1/foldingathome.license
---- blank/foldingathome.license	1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.license	2008-08-21 16:59:27.000000000 -0700
-@@ -0,0 +1,26 @@
-+Folding@Home distributed computing client
-+Copyright 2001-2007. Stanford University. All Rights Reserved. 
-+ 
-+License Agreement:
-+
-+Please carefully read the following terms and conditions before using this software. Use of this software 
-+indicates acceptance of this license agreement and disclaimer of all warranties. 
-+
-+Disclaimer of Warranty:
-+
-+IN NO EVENT SHALL STANFORD UNIVERSITY BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, 
-+OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS 
-+DOCUMENTATION, EVEN IF STANFORD UNIVERSITY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 
-+STANFORD UNIVERSITY SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOTLIMITED TO, THE IMPLIED 
-+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE AND ACCOMPANYING 
-+DOCUMENTATION PROVIDED HEREUNDER IS PROVIDED "AS IS". Folding@home HAS NO OBLIGATION TO PROVIDE 
-+MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS. 
-+
-+Restrictions:
-+
-+You may use this software on a computer system only if you own the system or have the permission of the owner. 
-+You may not alter the software or associated data files. 
-+You may only use unmodified versions of Folding@home obtained through authorized distributors to connect 
-+to the Folding@Home servers. Use of other software to connect to the Folding@home servers is strictly prohibited. 
-+Distribution of this software is prohibited. It may only be obtained by downloading from Stanford's web site 
-+(http://folding.stanford.edu and pages linked therein) or the web site of one of our commercial partners (Sony, NVIDIA, and ATI).
-diff -Naur blank/foldingathome.rc.d 6.02-1/foldingathome.rc.d
---- blank/foldingathome.rc.d	1969-12-31 16:00:00.000000000 -0800
-+++ 6.02-1/foldingathome.rc.d	2008-08-21 17:00:48.000000000 -0700
-@@ -0,0 +1,60 @@
-+#!/bin/bash
-+#/etc/rc.d/foldingathome
-+#
-+# Starts the Folding@Home client in the background
-+
-+. /etc/rc.conf
-+. /etc/rc.d/functions
-+. /etc/conf.d/foldingathome
-+
-+PID=`pidof -o %PPID /opt/fah/fah6`
-+case "$1" in
-+	start)
-+	stat_busy "Starting Folding@Home"
-+	if [ -z "$PID" ]; then
-+		if [ ! -z "$FAH_USER" ] ; then
-+			if [ ! -d "/opt/fah/$FAH_USER" ] ; then
-+				mkdir /opt/fah/$FAH_USER
-+				chown $FAH_USER /opt/fah/$FAH_USER
-+				if [ ! -z "$FAH_GRP" ] ; then
-+					chgrp $FAH_GRP /opt/fah/$FAH_USER
-+				else
-+					chgrp users /opt/fah/$FAH_USER
-+				fi
-+			fi
-+			cd /opt/fah/$FAH_USER
-+			su $FAH_USER -c "nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/$FAH_USER/myfah.log" &
-+		else
-+			cd /opt/fah
-+			nice --adjustment 19 /opt/fah/fah6 -verbosity 9 > /opt/fah/myfah.log &
-+		fi
-+	fi
-+	if [ ! -z "$PID" -o $? -gt 0 ]; then
-+		stat_fail
-+	else
-+		add_daemon foldingathome
-+		stat_done
-+	fi
-+	;;
-+	
-+	stop)
-+	stat_busy "Stopping Folding@Home"
-+	[ ! -z "$PID" ]&& kill $PID &> /dev/null
-+	if [ $? -gt 0 ]; then
-+		stat_fail
-+	else
-+		rm_daemon foldingathome
-+		stat_done
-+	fi
-+	;;
-+	
-+	restart)
-+	$0 stop
-+	sleep 1
-+	$0 start
-+	;;
-+	
-+	*)
-+	echo $"Usage: $0 {start|stop|restart}"
-+esac
-+
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
old mode 100755
new mode 100644
index 8eedb6c..3ecc7c9
--- a/abs/extra-testing/community/foldingathome/foldingathome.install
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -1,30 +1,44 @@
-# arg 1:  the new package version
 post_install() {
-  cat << 'EOM'
-  --> Please cd to /opt/fah/ and execute ./fah6 -smp -configonly 
-  --> to configure your settings. Then add "foldingathome" to the list
-  --> of daemons in /etc/rc.conf. If you would like to join the Arch 
-  --> Linux team, use team number 45032. To check current progress,
-  --> point your browser to file://opt/fah/MyFolding.html
+  # Check for an R5.5 fah installation.
+  r5_fah_dir=/myth/folding@home
+  r6_fah_dir=/myth/folding_$(hostname)
+  if [ -d "$r5_fah_dir" ] ; then
+    if [ -d "$r6_fah_dir" ] ; then
+      cat << 'EOM'
+  --> You have an R5.5 and an R6 folding directory at the same time!
+  --> you should manually delete the R5.5 directory:
+  -->    $r5_fah_dir
+EOM
+    else
+      mv $r5_fah_dir $r6_fah_dir
+    fi
+  else
+    if [ ! -d "$r6_fah_dir" ] ; then
+      mkdir $r6_fah_dir
+      cat > $r6_fah_dir/client.cfg << 'EOM'
+[settings]
+username=LinHES
+team=50975
+passkey=
+asknet=no
+bigpackets=normal
+machineid=1
 
-  --> It is strongly recommended that you run foldingathome as a user other
-  --> than root. You can identify a user in /etc/conf.d/foldingathome.
-  --> A directory called /opt/fah/$FAH_USER will be created."
+[http]
+active=no
+host=localhost
+port=8080
 EOM
-}
+    fi
+  fi
 
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  post_install $1
+  /sbin/add_service.sh fah
+  sleep 5
+  /sbin/sv -v start fah
 }
 
-# arg 1:  the old package version
 pre_remove() {
-  /bin/true
+  /sbin/sv stop fah
+  /sbin/remove_service.sh fah
 }
 
-op=$1
-shift
-
-$op $* 
-- 
cgit v0.12


From 2b833ea0ac484aa1ff2263624be366ad4c3b6b61 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 10:37:14 +0900
Subject: foldingathome: git add run script

---
 abs/extra-testing/community/foldingathome/PKGBUILD |  4 ++--
 abs/extra-testing/community/foldingathome/run      | 26 ++++++++++++++++++++++
 2 files changed, 28 insertions(+), 2 deletions(-)
 create mode 100644 abs/extra-testing/community/foldingathome/run

diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index ffd256e..7f6cc20 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=foldingathome
 pkgver=6.02
-pkgrel=2
+pkgrel=3
 pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
 arch=('i686')
 url="http://folding.stanford.edu/"
@@ -15,7 +15,7 @@ install=foldingathome.install
 source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
 	run)
 md5sums=('112b3d66909050f1bb990993a1464cb9'
-         '7e1b3f2a6768b4fbeb415922a1a9c2e6')
+         '87a3a1cea8fbd420068461ed529d9f05')
 
 build() {
   cd $startdir/src/
diff --git a/abs/extra-testing/community/foldingathome/run b/abs/extra-testing/community/foldingathome/run
new file mode 100644
index 0000000..f8d536e
--- /dev/null
+++ b/abs/extra-testing/community/foldingathome/run
@@ -0,0 +1,26 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting folding@home"
+
+FOLDING_DIR=/myth/folding_$(hostname)
+
+if [ -d $FOLDING_DIR ] ; then
+  cd $FOLDING_DIR
+  # Ensure that the client configuration file has the same details as /etc/systemconfig
+
+  source /etc/systemconfig
+
+  if [ -n "$foldingusername" ] ; then
+    sed -i 's/username=.*$/username='$foldingusername'/g' $FOLDING_DIR/client.cfg
+  fi
+
+  if [ -n "$foldingworksize" ] ; then
+    sed -i 's/bigpackets=.*$/bigpackets='$foldingworksize'/g' $FOLDING_DIR/client.cfg
+  fi
+
+  # No need to direct output to a log file becase a log file
+  # will automatically be placed in $FOLDING_DIR
+  exec /usr/bin/fah6 -verbosity 9 &> /dev/null < /dev/null
+fi
-- 
cgit v0.12


From 9dd5c92a9521a5fb3a5000b88a7d8c4b97339caf Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 11:17:07 +0900
Subject: shepherd: update to latest from
 http://www.whuffy.com/shepherd/shepherd

---
 abs/extra-testing/shepherd/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/extra-testing/shepherd/PKGBUILD b/abs/extra-testing/shepherd/PKGBUILD
index 28b2005..f7b3048 100644
--- a/abs/extra-testing/shepherd/PKGBUILD
+++ b/abs/extra-testing/shepherd/PKGBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Greg Frost <gregfrost1@bigpond.com>
 pkgname=shepherd
 pkgver=1
-pkgrel=1
+pkgrel=2
 pkgdesc="Australian EPG Grabber."
 arch=i686
 depends=(perl-pathtools perl-digest-sha1 perl-algorithm-diff perl-javascript perl-list-compare)
-- 
cgit v0.12


From 9e577c49ff4c553c198bdefa594f211e2b2bbc1d Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 11:44:16 +0900
Subject: foldingathome: change location to /myth/foldingathome/

---
 abs/extra-testing/community/foldingathome/PKGBUILD            |  4 ++--
 .../community/foldingathome/foldingathome.install             | 11 ++++++-----
 abs/extra-testing/community/foldingathome/run                 |  2 +-
 3 files changed, 9 insertions(+), 8 deletions(-)

diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index 7f6cc20..ed35112 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=foldingathome
 pkgver=6.02
-pkgrel=3
+pkgrel=4
 pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
 arch=('i686')
 url="http://folding.stanford.edu/"
@@ -15,7 +15,7 @@ install=foldingathome.install
 source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
 	run)
 md5sums=('112b3d66909050f1bb990993a1464cb9'
-         '87a3a1cea8fbd420068461ed529d9f05')
+         '61eb4617e7363d586a05dde980ad1c14')
 
 build() {
   cd $startdir/src/
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
index 3ecc7c9..8bcfaf3 100644
--- a/abs/extra-testing/community/foldingathome/foldingathome.install
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -1,20 +1,23 @@
 post_install() {
   # Check for an R5.5 fah installation.
   r5_fah_dir=/myth/folding@home
-  r6_fah_dir=/myth/folding_$(hostname)
+  r6_fah_dir=/myth/foldingathome/$(hostname)
   if [ -d "$r5_fah_dir" ] ; then
     if [ -d "$r6_fah_dir" ] ; then
       cat << 'EOM'
   --> You have an R5.5 and an R6 folding directory at the same time!
   --> you should manually delete the R5.5 directory:
   -->    $r5_fah_dir
+  --> The directroy used on R6 will be:
+  -->    $r6_fah_dir
 EOM
     else
+      mkdir -p /myth/foldingathome
       mv $r5_fah_dir $r6_fah_dir
     fi
   else
     if [ ! -d "$r6_fah_dir" ] ; then
-      mkdir $r6_fah_dir
+      mkdir -p $r6_fah_dir
       cat > $r6_fah_dir/client.cfg << 'EOM'
 [settings]
 username=LinHES
@@ -33,12 +36,10 @@ EOM
   fi
 
   /sbin/add_service.sh fah
-  sleep 5
-  /sbin/sv -v start fah
 }
 
 pre_remove() {
-  /sbin/sv stop fah
+  sv stop fah
   /sbin/remove_service.sh fah
 }
 
diff --git a/abs/extra-testing/community/foldingathome/run b/abs/extra-testing/community/foldingathome/run
index f8d536e..ede51f2 100644
--- a/abs/extra-testing/community/foldingathome/run
+++ b/abs/extra-testing/community/foldingathome/run
@@ -4,7 +4,7 @@ export TERM=linux
 . /etc/rc.d/functions
 stat_runit "Starting folding@home"
 
-FOLDING_DIR=/myth/folding_$(hostname)
+FOLDING_DIR=/myth/foldingathome/$(hostname)
 
 if [ -d $FOLDING_DIR ] ; then
   cd $FOLDING_DIR
-- 
cgit v0.12


From 3d4a484734ecc7b5e8f4e701fc8ee52115fdc370 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 12:07:17 +0900
Subject: foldingathome:bump. gd:bump for libjpeg

---
 abs/extra-testing/community/foldingathome/PKGBUILD | 2 +-
 abs/extra-testing/gd/PKGBUILD                      | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index ed35112..e6b6788 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=foldingathome
 pkgver=6.02
-pkgrel=4
+pkgrel=5
 pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
 arch=('i686')
 url="http://folding.stanford.edu/"
diff --git a/abs/extra-testing/gd/PKGBUILD b/abs/extra-testing/gd/PKGBUILD
index 11e2929..3df77a1 100644
--- a/abs/extra-testing/gd/PKGBUILD
+++ b/abs/extra-testing/gd/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=gd
 pkgver=2.0.35
-pkgrel=1
+pkgrel=2
 pkgdesc="Library for the dynamic creation of images by programmers"
 arch=('i686' 'x86_64')
 url="http://www.libgd.org/"
-- 
cgit v0.12


From 29ad4affc41af7ed94cd2ed55373f5459bd7182c Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 29 Aug 2009 23:04:41 -0700
Subject: Folding@Home:Updates for webpage.

---
 abs/extra-testing/community/foldingathome/PKGBUILD              | 2 +-
 abs/extra-testing/community/foldingathome/foldingathome.install | 4 +++-
 2 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/abs/extra-testing/community/foldingathome/PKGBUILD b/abs/extra-testing/community/foldingathome/PKGBUILD
index e6b6788..bb93407 100644
--- a/abs/extra-testing/community/foldingathome/PKGBUILD
+++ b/abs/extra-testing/community/foldingathome/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=foldingathome
 pkgver=6.02
-pkgrel=5
+pkgrel=6
 pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
 arch=('i686')
 url="http://folding.stanford.edu/"
diff --git a/abs/extra-testing/community/foldingathome/foldingathome.install b/abs/extra-testing/community/foldingathome/foldingathome.install
index 8bcfaf3..20e48d1 100644
--- a/abs/extra-testing/community/foldingathome/foldingathome.install
+++ b/abs/extra-testing/community/foldingathome/foldingathome.install
@@ -34,7 +34,9 @@ port=8080
 EOM
     fi
   fi
-
+  rm -fr $r6_fah_dir/index.html
+  ln -s $r6_fah_dir/MyFolding.html $r6_fah_dir/index.html
+  ln -s $r6_fah_dir /data/srv/httpd/htdocs/foldingathome
   /sbin/add_service.sh fah
 }
 
-- 
cgit v0.12


From 57f9faeb2bc2a0d0022d9bbcc8077327f4365b1f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 29 Aug 2009 23:07:11 -0700
Subject: local-website:updated link for f@h.

---
 abs/core-testing/local-website/PKGBUILD          | 2 +-
 abs/core-testing/local-website/htdocs/index.html | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index a0f666c..da53253 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=local-website
 pkgver=2
-pkgrel=13
+pkgrel=14
 pkgdesc="Contents of http://localhost"
 arch=(i686 x86_64)
 license=('GPL')
diff --git a/abs/core-testing/local-website/htdocs/index.html b/abs/core-testing/local-website/htdocs/index.html
index 1c5c05b..964ca9c 100644
--- a/abs/core-testing/local-website/htdocs/index.html
+++ b/abs/core-testing/local-website/htdocs/index.html
@@ -68,7 +68,7 @@
 	  </p>
 
 	  
-      <p><a href="folding@home/"><b>My Folding Status</b></a>: <br>
+      <p><a href="foldingathome/"><b>My Folding Status</b></a>: <br>
 
 		&nbsp; &nbsp; Status of the folding@home work for the local user.
 	  </p>
-- 
cgit v0.12


From 878aa1ed4763f813ea0d306c408c5fb682158881 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 18:10:12 +0900
Subject: xine-lib: upgrade to 1.1.16.3 and rebuild to fix missing shared lib
 references

---
 abs/extra-testing/xine-lib/PKGBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/extra-testing/xine-lib/PKGBUILD b/abs/extra-testing/xine-lib/PKGBUILD
index 1cc9e2b..aa15b8f 100644
--- a/abs/extra-testing/xine-lib/PKGBUILD
+++ b/abs/extra-testing/xine-lib/PKGBUILD
@@ -3,8 +3,8 @@
 # Contributor: Judd Vinet <jvinet@zeroflux.org>
 
 pkgname=xine-lib
-pkgver=1.1.16.2
-pkgrel=3
+pkgver=1.1.16.3
+pkgrel=4
 pkgdesc="A free video player for Unix"
 arch=('i686' 'x86_64')
 url="http://xinehq.de/"
@@ -17,8 +17,8 @@ makedepends=('pkgconfig' 'libtool' 'imagemagick' 'smbclient' 'mesa' 'alsa-lib'
 options=('!libtool')
 source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
         xine-lib-1.1.1-configure-no-mcpu-march.patch)
-md5sums=('336dd1f6266e9f943430ca6009b7aa7e' '9776df4eb54d2f1f68d8268adbc3b5c2')
-sha1sums=('faa3d9207d911a535161a3cd5660aa9e6b904c28' '121a8358d7919b2e51067412373f52848290338a')
+md5sums=('4f508abf088cf427a731f85634c8260d'
+         '9776df4eb54d2f1f68d8268adbc3b5c2')
 optiona=(!emptydir)
 
 build() {
-- 
cgit v0.12


From 8a3e6cfbd5e604a4c497c870d642a14c306571ab Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 18:26:00 +0900
Subject: pyorbit: rebuild to fix libpython2.5.so.1.0 => not found

---
 abs/extra-testing/pyorbit/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/extra-testing/pyorbit/PKGBUILD b/abs/extra-testing/pyorbit/PKGBUILD
index ac9f7c0..60f8f34 100644
--- a/abs/extra-testing/pyorbit/PKGBUILD
+++ b/abs/extra-testing/pyorbit/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=pyorbit
 pkgver=2.24.0
-pkgrel=2
+pkgrel=3
 pkgdesc="Python bindings for ORBit2"
 arch=(i686 x86_64)
 license=('LGPL')
-- 
cgit v0.12


From 5332451e787382363d5797c19043f2d766f7e4c3 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 18:34:03 +0900
Subject: perl-text-kakasi: fix kakasi dependency

---
 abs/core-testing/perl_modules/perl-text-kakasi/PKGBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/perl_modules/perl-text-kakasi/PKGBUILD b/abs/core-testing/perl_modules/perl-text-kakasi/PKGBUILD
index 19499af..1954f8a 100644
--- a/abs/core-testing/perl_modules/perl-text-kakasi/PKGBUILD
+++ b/abs/core-testing/perl_modules/perl-text-kakasi/PKGBUILD
@@ -3,12 +3,12 @@
 
 pkgname=perl-text-kakasi
 pkgver=2.04
-pkgrel=3
+pkgrel=4
 pkgdesc="Perl frontend to kakasi"
 arch=('i686' 'x86_64')
 url="http://search.cpan.org/~DANKOGAI/Text-Kakasi"
 license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0''kakasi') 
+depends=('perl>=5.10.0' 'kakasi') 
 options=('!emptydirs')
 source=(http://www.cpan.org/authors/id/D/DA/DANKOGAI/Text-Kakasi-$pkgver.tar.gz) 
 md5sums=('5a9e381cb93edfd707124a63c60f96b1')
-- 
cgit v0.12


From a37e2434c8b5f4c49ef40bc6f0ee3ea03124ad94 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 21:31:09 +0900
Subject: xulrunner: add libs to ld.so.conf in install script

---
 abs/extra-testing/xulrunner/PKGBUILD          |  3 ++-
 abs/extra-testing/xulrunner/xulrunner.install | 11 +++++++++++
 2 files changed, 13 insertions(+), 1 deletion(-)
 create mode 100644 abs/extra-testing/xulrunner/xulrunner.install

diff --git a/abs/extra-testing/xulrunner/PKGBUILD b/abs/extra-testing/xulrunner/PKGBUILD
index 84d6734..da6d8cd 100644
--- a/abs/extra-testing/xulrunner/PKGBUILD
+++ b/abs/extra-testing/xulrunner/PKGBUILD
@@ -4,7 +4,7 @@
 pkgname=xulrunner
 pkgver=1.9.1.1
 _ffoxver=3.5.1
-pkgrel=2
+pkgrel=5
 pkgdesc="Mozilla Runtime Environment"
 arch=(i686 x86_64)
 license=('MPL' 'GPL' 'LGPL')
@@ -18,6 +18,7 @@ source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}
         mozconfig)
 md5sums=('18169e189785d680827d4fce94524449'
          '6509d12e6b17bfc51c09e1dc35259035')
+install=xulrunner.install
 
 build() {
   cd ${startdir}/src/mozilla-1.9.1
diff --git a/abs/extra-testing/xulrunner/xulrunner.install b/abs/extra-testing/xulrunner/xulrunner.install
new file mode 100644
index 0000000..0b4cf9c
--- /dev/null
+++ b/abs/extra-testing/xulrunner/xulrunner.install
@@ -0,0 +1,11 @@
+post_install() {
+  # Ensure that the ld.so.conf file contains the xulrunner libs.
+  cp -f /etc/ld.so.conf /tmp/ld.so.conf
+  grep -v xulrunner /tmp/ld.so.conf > /etc/ld.so.conf
+  echo /usr/lib/xulrunner-1.9.1.1 >> /etc/ld.so.conf
+  /sbin/ldconfig
+}
+
+post_upgrade() {
+  post_install $*
+}
-- 
cgit v0.12


From 964f98b8bbfe3e053065ccc19cb0dba511e68607 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 21:39:47 +0900
Subject: python-netifaces: chmod -x on info files

---
 abs/core-testing/python-netifaces/PKGBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/python-netifaces/PKGBUILD b/abs/core-testing/python-netifaces/PKGBUILD
index d7fa623..13a424e 100644
--- a/abs/core-testing/python-netifaces/PKGBUILD
+++ b/abs/core-testing/python-netifaces/PKGBUILD
@@ -1,7 +1,7 @@
 pkgname=python-netifaces
 __pkgname="netifaces"
 pkgver=0.5
-pkgrel=1
+pkgrel=2
 pkgdesc="Python modules for network interfaces"
 arch=(i686 x86_64)
 license=('LGPL' 'MPL')
@@ -12,5 +12,6 @@ url="http://alastairs-place.net/netifaces/"
 
 build() {
   cd "${srcdir}/${__pkgname}-${pkgver}"
+  chmod -x -R netifaces.egg-info
   yes "" | python setup.py install --root=$startdir/pkg --prefix=/usr
 }
-- 
cgit v0.12


From 3aef682afa6426e44abaceb56e510af8dcf7bd94 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 30 Aug 2009 21:53:12 +0900
Subject: rrdtool: add ruby dep to resolve RRD.so dependency

---
 abs/extra-testing/rrdtool/PKGBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/extra-testing/rrdtool/PKGBUILD b/abs/extra-testing/rrdtool/PKGBUILD
index b2c42e3..6050e5c 100644
--- a/abs/extra-testing/rrdtool/PKGBUILD
+++ b/abs/extra-testing/rrdtool/PKGBUILD
@@ -4,13 +4,13 @@
 
 pkgname=rrdtool
 pkgver=1.3.6
-pkgrel=1
+pkgrel=2
 pkgdesc="Data logging and graphing application"
 arch=('i686' 'x86_64')
 url="http://www.rrdtool.org"
 license=('GPL')
-depends=('libart-lgpl' 'libpng' 'freetype2' 'libxml2' 'pango')
-makedepends=('ruby' 'python' 'tcl')
+depends=('libart-lgpl' 'libpng' 'freetype2' 'libxml2' 'pango' 'ruby')
+makedepends=('python' 'tcl')
 optdepends=('tcl, python and/or ruby: to use corresponding binding')
 options=('!libtool' '!emptydirs')
 source=(http://oss.oetiker.ch/rrdtool/pub/rrdtool-${pkgver}.tar.gz)
-- 
cgit v0.12