From 2a4fa579c512741d1699ba305caa84f5495ed6c3 Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Thu, 19 Feb 2009 16:45:41 -0500
Subject: builds fine, but not tested

---
 abs/core-testing/mythtv/trunk/mythgame/PKGBUILD    | 63 +++++++++++++---------
 abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD  | 47 ++++++++++++++++
 .../mythtv/trunk/mythmovietime/PKGBUILD            | 36 -------------
 abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD   |  4 +-
 abs/core-testing/mythtv/trunk/mythnews/PKGBUILD    | 63 +++++++++++++---------
 abs/core-testing/mythtv/trunk/mythphone/PKGBUILD   | 42 ---------------
 abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD   | 61 ++++++++++++---------
 7 files changed, 160 insertions(+), 156 deletions(-)
 create mode 100644 abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
 delete mode 100644 abs/core-testing/mythtv/trunk/mythmovietime/PKGBUILD
 delete mode 100644 abs/core-testing/mythtv/trunk/mythphone/PKGBUILD

diff --git a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
index 8c4257f..bc18ba4 100644
--- a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
@@ -1,36 +1,47 @@
 pkgname=mythgame-svn
-pkgver=16153
-pkgrel=4
+pkgver=20019
+pkgrel=1
 pkgdesc="Emulation plugin for MythTV"
 url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn' 'zlib')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
 license="GPL"
-source=()
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'zlib')
+conflicts=('mythgame')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
 _svnmod=mythplugins
 
 
 build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-PLUGIN=mythgame
-grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-if [ $? != 0 ]
-then
-		echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-		msg	 "appending program lib"
-		fi
-	export QMAKESPEC='linux-g++'
-	make distclean
-   ./configure  --disable-all --enable-opengl --enable-mythgame 
-
-   make -j 2 || return 1
-
-   make INSTALL_ROOT=$startdir/pkg install
-}
 
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythgame || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}
diff --git a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
new file mode 100644
index 0000000..341cf55
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mythmovies-svn
+pkgver=20019
+pkgrel=1
+pkgdesc="Displays information about movies playing in the area."
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('mythmovies')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythmovies || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}
diff --git a/abs/core-testing/mythtv/trunk/mythmovietime/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmovietime/PKGBUILD
deleted file mode 100644
index f83cdbf..0000000
--- a/abs/core-testing/mythtv/trunk/mythmovietime/PKGBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-pkgname=mythmovietime-svn
-pkgver=16153
-pkgrel=6
-pkgdesc="Emulation plugin for MythTV"
-url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn' 'zlib')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
-license="GPL"
-source=()
-_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
-_svnmod=mythplugins
-
-
-build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-PLUGIN=mythmovietime
-grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-if [ $? != 0 ]
-then
-		echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-			msg "appending program lib"
-		fi
-	export QMAKESPEC='linux-g++'
-	make distclean
-   ./configure  --disable-all --enable-mythmovies 
-
-   make -j 2 || return 1
-
-   make INSTALL_ROOT=$startdir/pkg install
-}
-
diff --git a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
index 73fb925..d6d0634 100644
--- a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=mythmusic-svn
-pkgver=20018
+pkgver=20019
 pkgrel=1
 pkgdesc="Music playing plugin for MythTV"
 url="http://www.mythtv.org"
 license="GPL"
 arch=('i686' 'x86_64')
 
-depends=("mythtv-svn" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
+depends=('mythtv-svn' 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
          'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
          'libvisual-plugins' 'libvisual-projectm')
 conflicts=('mythmusic')
diff --git a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
index 4dafc20..24ee880 100644
--- a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
@@ -1,34 +1,47 @@
 pkgname=mythnews-svn
-pkgver=16153
-pkgrel=4
+pkgver=20019
+pkgrel=1
 pkgdesc="News checking plugin for MythTV"
 url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
 license="GPL"
-source=()
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('mythnews')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
 _svnmod=mythplugins
 
+
 build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-	PLUGIN=mythnews
-	grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-	if [ $? != 0 ]
-	then
-			echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-				msg "appending program lib"
-			fi
-	make distclean
-   ./configure --disable-all --enable-mythnews
-
-   make -j 2 || return 1
-
-   make INSTALL_ROOT=$startdir/pkg install
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythnews || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
 }
-md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')
diff --git a/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD b/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD
deleted file mode 100644
index f6bf3ec..0000000
--- a/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-pkgname=mythphone-svn
-pkgver=16153
-pkgrel=3
-pkgdesc="Plugin that allows phone calls to be made to MythTv"
-url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
-license="GPL"
-source=()
-_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
-_svnmod=mythplugins
-
-
-build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-	make distclean
-	PLUGIN=mythphone
-	grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-	if [ $? != 0 ]
-	then
-		echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-		msg  "appending program lib"
-	fi
-	
-	msg "Correcting configure    kde3 to kde"
-   	sed -i 's#kde3#kde#' configure || return 1
-   	./configure  --enable-opengl --disable-all --enable-mythphone || return 1
-	qmake mythplugins.pro || return 1
-	make qmake || return 1
-	
-	msg "Correcting Makefile    kde3 to kde"
- 	sed -i 's#kde3#kde#' ./mythphone/mythphone/Makefile || return 1
-   	
-	make -j 2 || return 1
-	make INSTALL_ROOT=$startdir/pkg install
-}
-
diff --git a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
index 4087034..2bddf9e 100644
--- a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
@@ -1,36 +1,47 @@
 pkgname=mythvideo-svn
-pkgver=16153
-pkgrel=2
+pkgver=20019
+pkgrel=1
 pkgdesc="Video playback and browsing plugin for MythTV"
 url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn'  'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
 license="GPL"
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
+arch=('i686' 'x86_64')
 
-source=()
+depends=('mythtv-svn' 'mplayer' 'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
+conflicts=('mythvideo')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
 _svnmod=mythplugins
 
 
 build() {
-	cd $startdir/src/
-	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- 	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
-	cd $startdir/src/mythplugins
-  	make distclean 
-	PLUGIN=mythvideo
-	grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-	if [ $? != 0 ]
-	then
-			echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
-				msg "appending program lib"
-			fi
-   ./configure  --disable-all --enable-mythvideo  --enable-transcode  
-
-   make -j 2 || return 1
-
-   make INSTALL_ROOT=$startdir/pkg install
+
+	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+#	svn co $_svntrunk --config-dir ./ $_svnmod
+
+	cd $startdir/src/$_svnmod
+
+	echo "--------------------------applying patches----------------------------------------------------"
+	for i in `echo ${patches[@]:0} `
+	do
+		echo applying $i
+		echo "-----------------------------"
+		patch -Np0  -i ${startdir}/src/$i  || return 1
+	done
+	echo "--------------------------done applying patches-----------------------------------------------"
+	
+	[ "$CARCH" = "i686"   ] && ARCH="i686"
+	[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+	# configure
+	./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+	--enable-mythvideo || return 1
+
+	# build and install
+	. /etc/profile
+	make || return 1
+	make INSTALL_ROOT=$startdir/pkg install || return 1
+
 }
-md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')
-- 
cgit v0.12