From 8f84737ed83ba564ac1fb07d84d72c62a7863794 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 16 Mar 2009 12:22:29 -0500
Subject: Prevent alsa drivers from grabbing index 0 for "abnormal drivers"
 closes FS#290

---
 abs/core-testing/LinHES-system/PKGBUILD  |  7 ++++---
 abs/core-testing/LinHES-system/alsa-base | 10 ++++++++++
 2 files changed, 14 insertions(+), 3 deletions(-)
 create mode 100644 abs/core-testing/LinHES-system/alsa-base

diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 6270026..14958c7 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,16 +1,16 @@
 pkgname=LinHES-system
 pkgver=1.0
-pkgrel=41
+pkgrel=42
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
 install=LinHES.install
 pkgdesc="scripts and things related to having a automated system"
 depends=(linhes-sounds xdotool)
-
+backup=(etc/modprobe.d/alsa-base)
 binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh"
 
-source=(LinHES-session LinHES-profile.sh $binfiles)
+source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
 
 build() {
         cd $startdir/src
@@ -35,6 +35,7 @@ do
 	echo $item
 
 done	
+install -m755 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base
 
 }
 
diff --git a/abs/core-testing/LinHES-system/alsa-base b/abs/core-testing/LinHES-system/alsa-base
new file mode 100644
index 0000000..bf99ac3
--- /dev/null
+++ b/abs/core-testing/LinHES-system/alsa-base
@@ -0,0 +1,10 @@
+# Prevent abnormal drivers from grabbing index 0
+options bt87x index=-2
+options cx88_alsa index=-2
+options saa7134-alsa index=-2
+options snd-atiixp-modem index=-2
+options snd-intel8x0m index=-2
+options snd-via82xx-modem index=-2
+options snd-usb-audio index=-2
+options snd-usb-usx2y index=-2
+options snd-usb-caiaq index=-2
-- 
cgit v0.12