From e47d97e366a8eae8d5d71ef692b930fcfd953e53 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 15:35:46 -0500
Subject: rrd_stats: add pkg to repo. the configfile needs to be tweaked for
 each install, but the basics are there.

---
 abs/extra-testing/rrd_stats/PKGBUILD          |   2 +-
 abs/extra-testing/rrd_stats/rrd_stats.install |  61 +++++++++++++++++++++-----
 abs/extra-testing/rrd_stats/rrd_stats.tgz     | Bin 6603 -> 6598 bytes
 3 files changed, 51 insertions(+), 12 deletions(-)

diff --git a/abs/extra-testing/rrd_stats/PKGBUILD b/abs/extra-testing/rrd_stats/PKGBUILD
index 8e027d5..a171aa6 100644
--- a/abs/extra-testing/rrd_stats/PKGBUILD
+++ b/abs/extra-testing/rrd_stats/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=rrd_stats
 pkgver=1
-pkgrel=9
+pkgrel=11
 pkgdesc="graph system stats"
 arch=('i686' 'x86_64')
 url=""
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.install b/abs/extra-testing/rrd_stats/rrd_stats.install
index be3d2e9..d6aa4ed 100644
--- a/abs/extra-testing/rrd_stats/rrd_stats.install
+++ b/abs/extra-testing/rrd_stats/rrd_stats.install
@@ -1,22 +1,61 @@
 post_install() {
-	line="*/5 * * * *       /usr/local/bin/rrd_hddtemp.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_disk.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_traffic.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_mem.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
-	line="*/5 * * * *       /usr/local/bin/rrd_cpu.pl > /dev/null"
-	(crontab -l; echo "$line") | crontab -
+	PFIX="/data/srv/httpd/htdocs/rrd"
+	if [ ! -e $PFIX/index.html.orig ]
+	then
+		mv $PFIX/index.html  $PFIX/index.html.orig
+		ln -s $PFIX/index-rrd.html $PFIX/index.html
+	fi
+
+	ct=`crontab -l`
+	echo $ct | grep -q rrd_hddtemp.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_hddtemp.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+
+	echo $ct | grep -q rrd_disk.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_disk.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi	
+
+	echo $ct | grep -q rrd_traffic.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_traffic.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+	
+	echo $ct | grep -q rrd_mem.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_mem.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+	
+	echo $ct | grep -q rrd_cpu.pl
+	if [ $? != 0 ]
+	then
+		line="*/5 * * * *       /usr/bin/rrd_cpu.pl > /dev/null"
+		(crontab -l; echo "$line") | crontab -
+	fi
+
 }
 
 post_upgrade() {
- 	/bin/true
+ 	post_install $1
 }
 
 
 pre_remove() {
 	crontab -l | grep -v rrd_ | crontab - 
+	PFIX="/data/srv/httpd/htdocs/rrd"
+	if [  -e $PFIX/index.html.orig ]
+	then
+		rm $PFIX/index.html
+		mv $PFIX/index.html.orig  $PFIX/index.html
+	fi
 
 }
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.tgz b/abs/extra-testing/rrd_stats/rrd_stats.tgz
index 66d2e06..2d66428 100644
Binary files a/abs/extra-testing/rrd_stats/rrd_stats.tgz and b/abs/extra-testing/rrd_stats/rrd_stats.tgz differ
-- 
cgit v0.12


From 4e45176422a6ccd0c7447feb53b622283ad64689 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 15:46:32 -0500
Subject: LinHES-config: hook up rrd_tool to the advanced menu new mythvantage
 with rrdtool changed to rrd_stats

---
 abs/core-testing/LinHES-config/PKGBUILD       |  2 +-
 abs/core-testing/LinHES-config/mv_advanced.py | 10 ++++++++++
 2 files changed, 11 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index c000c02..4488cbc 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=13
+pkgrel=14
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/mv_advanced.py b/abs/core-testing/LinHES-config/mv_advanced.py
index 01351df..d7c65f1 100755
--- a/abs/core-testing/LinHES-config/mv_advanced.py
+++ b/abs/core-testing/LinHES-config/mv_advanced.py
@@ -66,6 +66,14 @@ def setup_splash(Usebootsplash):
         cmd = ''' sed -i "s/^default.*1/default 0/g" /boot/grub/menu.lst'''
         mv_common.runcmd(cmd)
     return
+def setup_rrd(UseRRD):
+    if UseRRD == "1":
+        logging.info("    Enabling rrd_stats")
+        mv_common.pacinstall("rrd_stats")
+    else:
+        logging.info("    Disabling rrd_stats")
+        mv_common.pacremove("rrd_stats")
+
 
 def setup_hobbit(UseHobbit,SystemType,dbhost):
     if UseHobbit == "1":
@@ -355,6 +363,8 @@ def setup_advanced(systemconfig,data_config):
         setup_hobbit(systemconfig["UseHobbit"],
                     systemconfig["SystemType"],
                     systemconfig["dbhost"])
+    if data_config.SYSTEMTYPE == "LinHES":
+        setup_rrd(systemconfig["UseRRD"])
 
     setup_evrouter(systemconfig["UseEvrouter"],
                    systemconfig["EvrouterConfig"],
-- 
cgit v0.12


From 90a6b06a24ac518c4671bfade5bb9d488dd2ffb1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 15:47:56 -0500
Subject: LinHES_config: pkgbuild Missed from last commit

---
 abs/core-testing/LinHES-config/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 4488cbc..40413ed 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=14
+pkgrel=15
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
-- 
cgit v0.12


From 0cb35af8f8e67e2d59dc39f9923e157f9ae6e3a7 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 15:53:18 -0500
Subject: rrd_status: remove nfs mount from config file. closes FS#146

---
 abs/extra-testing/rrd_stats/PKGBUILD      |   2 +-
 abs/extra-testing/rrd_stats/rrd_stats.tgz | Bin 6598 -> 6625 bytes
 2 files changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/extra-testing/rrd_stats/PKGBUILD b/abs/extra-testing/rrd_stats/PKGBUILD
index a171aa6..a086380 100644
--- a/abs/extra-testing/rrd_stats/PKGBUILD
+++ b/abs/extra-testing/rrd_stats/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=rrd_stats
 pkgver=1
-pkgrel=11
+pkgrel=12
 pkgdesc="graph system stats"
 arch=('i686' 'x86_64')
 url=""
diff --git a/abs/extra-testing/rrd_stats/rrd_stats.tgz b/abs/extra-testing/rrd_stats/rrd_stats.tgz
index 2d66428..4e27a43 100644
Binary files a/abs/extra-testing/rrd_stats/rrd_stats.tgz and b/abs/extra-testing/rrd_stats/rrd_stats.tgz differ
-- 
cgit v0.12


From a694d2e850545e12ebbbfdedfd54978e0b085ae2 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 15 Jun 2009 16:23:26 -0500
Subject: mythweb: create link to /myth/video on install. closes FS#227

the division by zero error was already fixed upstream
---
 abs/core-testing/mythtv/stable/mythweb/PKGBUILD        |  2 +-
 abs/core-testing/mythtv/stable/mythweb/mythweb.install | 11 +++++++----
 2 files changed, 8 insertions(+), 5 deletions(-)

diff --git a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
index e601ae9..3dded7f 100644
--- a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythweb
 pkgver=0.21
-pkgrel=15
+pkgrel=18
 pkgdesc="Web interface for MythTV's backend"
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/stable/mythweb/mythweb.install b/abs/core-testing/mythtv/stable/mythweb/mythweb.install
index 470cbd1..a2aa1bd 100644
--- a/abs/core-testing/mythtv/stable/mythweb/mythweb.install
+++ b/abs/core-testing/mythtv/stable/mythweb/mythweb.install
@@ -1,10 +1,13 @@
 post_install() {
-	echo "You must create a symlink from /home/httpd/html/mythweb/video_dir"
-	echo "to your MythTV recordings directory. Don't forget to change the"
-	echo "permissions so that the webserver can read those files and create"
-	echo "thumbnails."  
+	if [ ! -e /data/srv/httpd/htdocs/mythweb/data/video ]
+	then
+		ln -s /myth/video /data/srv/httpd/htdocs/mythweb/data/video
+	fi
 }
 
+post_upgrade(){
+	post_install $1
+}
 op=$1
 shift
 $op $*
-- 
cgit v0.12


From defeb831ab4f4f16c6efe7bf85ea017324881b53 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Tue, 16 Jun 2009 00:15:32 -0700
Subject: Added myt2xvid3

---
 abs/core-testing/linhes-scripts/PKGBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index bd8279e..8875c69 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=14
+pkgrel=15
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -14,7 +14,7 @@ source=(ftp://ftp.knoppmyth.net/R6/sources/linhes-scripts.tar.bz2)
 build() {
   cd $startdir/src/
   mkdir -p $startdir/pkg/usr/LH/bin
-  cp 770* idle.sh imp* myth* shoo* pau*sh mplayer* vdpau* screen* mplayer* $startdir/pkg/usr/LH/bin
+  install -D -m755 myt2* 770* idle.sh imp* myth* shoo* pau*sh mplayer* vdpau* screen* mplayer* $startdir/pkg/usr/LH/bin
   mkdir -p $startdir/pkg/etc/sv/pause-mythcommflag/supervise
   cp run $startdir/pkg/etc/sv/pause-mythcommflag/
   mkdir -p $startdir/pkg/etc/logrotate.d/
-- 
cgit v0.12