From ab6c1f25510856e2b932ef337f37be4ccd53839f Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 17:06:05 -0700
Subject: mpfr:Bumped/Updated for LinHES 7.

---
 abs/core-testing/mpfr/PKGBUILD     | 27 +++++++++++++++------------
 abs/core-testing/mpfr/mpfr.install |  2 ++
 2 files changed, 17 insertions(+), 12 deletions(-)

diff --git a/abs/core-testing/mpfr/PKGBUILD b/abs/core-testing/mpfr/PKGBUILD
index ac2ab77..e53757b 100644
--- a/abs/core-testing/mpfr/PKGBUILD
+++ b/abs/core-testing/mpfr/PKGBUILD
@@ -1,26 +1,29 @@
-# $Id: PKGBUILD 12992 2008-09-25 17:47:29Z jgc $
+# $Id: PKGBUILD 82426 2010-06-11 05:51:29Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Contributor: damir <damir@archlinux.org>
 
 pkgname=mpfr
-pkgver=2.3.2
-pkgrel=2
-pkgdesc="multiple-precision floating-point library"
-arch=(i686 x86_64)
-license=('GPL' 'LGPL')
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Multiple-precision floating-point library"
+arch=('i686' 'x86_64')
+license=('LGPL')
 url="http://www.mpfr.org/"
-depends=('gmp>=4.2.3' 'texinfo')
+depends=('gmp>=5.0')
 options=('!libtool')
 install=mpfr.install
-#source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.gz)
+source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.xz)
+md5sums=('8ab3bef2864b8c6e6a291f5603141bbd')
 
-source=(http://modular.math.washington.edu/home/novocin/tars/mpfr-2.3.2.tar.gz)
 build() {
   cd "${srcdir}/${pkgname}-${pkgver}"
   ./configure --prefix=/usr --enable-thread-safe --enable-shared || return 1
   make || return 1
+  make check || return 1
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
   make DESTDIR="${pkgdir}" install || return 1
-  cd "${pkgdir}/usr/share/info" || return 1
-  rm -f dir
-  gzip * || return 1
 }
diff --git a/abs/core-testing/mpfr/mpfr.install b/abs/core-testing/mpfr/mpfr.install
index a95dec6..46ef244 100644
--- a/abs/core-testing/mpfr/mpfr.install
+++ b/abs/core-testing/mpfr/mpfr.install
@@ -2,6 +2,7 @@ info_dir=/usr/share/info
 info_files=(mpfr.info)
 
 post_install() {
+  [ -x usr/bin/install-info ] || return 0
   for f in ${info_files[@]}; do
     install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
   done
@@ -12,6 +13,7 @@ post_upgrade() {
 }
 
 pre_remove() {
+  [ -x usr/bin/install-info ] || return 0
   for f in ${info_files[@]}; do
     install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
   done
-- 
cgit v0.12