From 858f0c53e9673a41bd5b3f7014b28b2f0e28cdef Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Wed, 12 Aug 2009 09:18:05 -0400
Subject: mv_install.py now restores asound.state and mplayer.conf

---
 abs/core-testing/LinHES-config/PKGBUILD      |  2 +-
 abs/core-testing/LinHES-config/mv_install.py | 15 +++++++++++++++
 2 files changed, 16 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 3dd79eb..c29165f 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=73
+pkgrel=74
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index 0b34650..bace1a5 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -1190,20 +1190,35 @@ def upgrade(hostoptions):
     time.sleep(3)
     copy_it("upgrade")
     cmd = "rm -rf %s/etc.old" %data_config.MOUNTPOINT
+    cmd = "rm -rf %s/varlibalsa.old" %data_config.MOUNTPOINT
     runcmd(cmd)
 
     cp_and_log("/tmp/etc/", data_config.MOUNTPOINT+"/etc.old/")
+    cp_and_log("/tmp/var/lib/alsa/", data_config.MOUNTPOINT+"/varlibalsa.old/")
     cp_and_log("/tmp/oss", data_config.MOUNTPOINT+"/var/lib/oss.old")
+
     srcfile = "%s/etc.old/ssh/" %(data_config.MOUNTPOINT)
     destfile = "%s/etc/ssh/" %(data_config.MOUNTPOINT)
     cp_and_log2(srcfile, destfile, '*.pub')
     cp_and_log2(srcfile, destfile, '*.key')
     cp_and_log2(srcfile, destfile, '*key')
+
     mdfile = mdadm_find("/tmp")
     cp_and_log("/tmp"+mdfile, data_config.MOUNTPOINT+"/etc")
+
+    # R5.5 -> R6
+    srcfile = "%s/varlibalsa.old/asound.state" %(data_config.MOUNTPOINT)
+    destfile = "%s/etc/asound.state" %(data_config.MOUNTPOINT)
+    cp_and_log(srcfile, destfile)
+    # R6 -> R6
     srcfile = "%s/etc.old/asound.state" %(data_config.MOUNTPOINT)
     destfile = "%s/etc/asound.state" %(data_config.MOUNTPOINT)
     cp_and_log(srcfile, destfile)
+
+    srcfile = "%s/etc.old/mplayer/mplayer.conf" %(data_config.MOUNTPOINT)
+    destfile = "%s/etc/mplayer/mplayer.conf" %(data_config.MOUNTPOINT)
+    cp_and_log(srcfile, destfile)
+
     if not os.path.exists("/tmp/etc/KnoppMyth-version"):
         logging.debug("    standard upgrade,  restoring auth files")
         cp_and_log(data_config.MOUNTPOINT+"/etc.old/passwd", data_config.MOUNTPOINT+"/etc/passwd")
-- 
cgit v0.12


From 69fbdfd67867d6ed1fce0bb8a5aac79c3489e13b Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Wed, 12 Aug 2009 09:25:05 -0400
Subject: bumped revision to build package with combined changes

---
 abs/core-testing/LinHES-config/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index c6d0754..e8b26c3 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=77
+pkgrel=78
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
-- 
cgit v0.12


From c42d21d10ab8fe1f025f56cae33bccdec343e1b0 Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Wed, 12 Aug 2009 13:28:22 -0400
Subject: mythtv-svn: update to svn 21228

---
 abs/core-testing/mythtv/trunk/morethemes/PKGBUILD     | 2 +-
 abs/core-testing/mythtv/trunk/mp_all.sh               | 2 +-
 abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD    | 2 +-
 abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD    | 2 +-
 abs/core-testing/mythtv/trunk/mythflix/PKGBUILD       | 2 +-
 abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD    | 2 +-
 abs/core-testing/mythtv/trunk/mythgame/PKGBUILD       | 2 +-
 abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD     | 2 +-
 abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD      | 2 +-
 abs/core-testing/mythtv/trunk/mythnews/PKGBUILD       | 2 +-
 abs/core-testing/mythtv/trunk/myththemes/PKGBUILD     | 2 +-
 abs/core-testing/mythtv/trunk/mythtv/PKGBUILD         | 5 ++---
 abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD      | 2 +-
 abs/core-testing/mythtv/trunk/mythweather/PKGBUILD    | 2 +-
 abs/core-testing/mythtv/trunk/mythweb/PKGBUILD        | 2 +-
 abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD | 2 +-
 16 files changed, 17 insertions(+), 18 deletions(-)

diff --git a/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
index f3f8e7c..a440786 100644
--- a/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/morethemes/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=morethemes-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Additional themes for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mp_all.sh b/abs/core-testing/mythtv/trunk/mp_all.sh
index d3de781..d8666ed 100755
--- a/abs/core-testing/mythtv/trunk/mp_all.sh
+++ b/abs/core-testing/mythtv/trunk/mp_all.sh
@@ -1,5 +1,5 @@
 #!/bin/sh
-pkgver=21145
+pkgver=21228
 pkgrel=1
 
 # NOTE: Make sure to build and install mythtv first BEFORE building anything else
diff --git a/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
index 9edf1fa..16ca0a5 100644
--- a/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mytharchive/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mytharchive-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows."
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
index bc64b8d..57480ea 100644
--- a/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythbrowser-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Mini web browser for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD b/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
index 0215cf7..6295977 100644
--- a/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythflix/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythflix-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Netflix access plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
index e949ceb..b5ac00f 100644
--- a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythgallery-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Image gallery plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
index f7e0fe9..19417e3 100644
--- a/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgame/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythgame-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Emulation plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
index 415c4e0..952cf42 100644
--- a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythmovies-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Displays information about movies playing in the area."
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
index a9cef5a..3d5b91b 100644
--- a/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythmusic/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythmusic-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Music playing plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
index 688f3ee..ca36734 100644
--- a/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythnews/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythnews-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="News checking plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
index 409573c..ca716a3 100755
--- a/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/myththemes/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=myththemes-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Themes for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index b30e205..4aad5af 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythtv-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="A personal video recorder for Linux"
 url="http://www.mythtv.org"
@@ -56,11 +56,10 @@ build() {
 
 	# configure
 	./configure --prefix=/usr --arch=${ARCH} \
-	--enable-vdpau --disable-xvmc \
+	--enable-vdpau --enable-xvmc --enable-xvmc-pro \
 	--enable-opengl-vsync --enable-libfaad --enable-dvb --enable-firewire \
 	--compile-type=release --with-bindings=perl,python \
 	--enable-audio-alsa --disable-audio-jack --disable-audio-arts || return 1
-       #        --enable-xvmc --enable-xvmc-pro \
 
 	# build and install
 	. /etc/profile
diff --git a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
index d9a587b..f229240 100644
--- a/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythvideo/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythvideo-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Video playback and browsing plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
index 8a56277..c1de969 100644
--- a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythweather-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Weather checking plugin for MythTV"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
index bd97ea0..2e3269d 100644
--- a/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweb/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythweb-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Web interface for MythTV's backend"
 url="http://www.mythtv.org"
diff --git a/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
index 052fa65..eee2306 100644
--- a/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythzoneminder/PKGBUILD
@@ -1,5 +1,5 @@
 pkgname=mythzoneminder-svn
-pkgver=21145
+pkgver=21228
 pkgrel=1
 pkgdesc="Integrates ZoneMinder into MythTV"
 url="http://www.mythtv.org"
-- 
cgit v0.12


From 07d18deb0e32e6b635e61b709e5890ae044acfed Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Wed, 12 Aug 2009 14:52:33 -0400
Subject: LinHES-config: fixes from jams

---
 abs/core-testing/LinHES-config/PKGBUILD      | 2 +-
 abs/core-testing/LinHES-config/mv_install.py | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index e8b26c3..19e3174 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=78
+pkgrel=79
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index bace1a5..5330975 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -701,7 +701,7 @@ def fix_permissions():
     SE = os.environ["TEMPLATES"]+"/settings/syssettings"
     cmd = "  chmod -R 755  %s" %(data_config.MOUNTPOINT+SE)
     runcmd(cmd)
-    cmd = "  chmod 755  %s" %(data_config.MOUNTPOINT+"/etc/systemconfig")
+    cmd = "  chmod 775  %s" %(data_config.MOUNTPOINT+"/etc/systemconfig")
     runcmd(cmd)
     cmd = "  chmod 755  %s" %(data_config.MOUNTPOINT+"/root")
     runcmd(cmd)
@@ -1071,7 +1071,7 @@ def find_upgrade():
     srcfile = data_config.MOUNTPOINT+"/etc/systemconfig"
     logging.info("Searching for systemconfig file %s", srcfile)
     if os.path.exists(srcfile):
-        logging.info("Found systemconfig file %fs", srcfile)
+        logging.info("Found systemconfig file %s", srcfile)
         TEMPLATES = os.environ["TEMPLATES"]+"/settings/syssettings"
         cp_and_log2(data_config.MOUNTPOINT+TEMPLATES, data_config.TEMP_TEMPLATES, '')
         sane_settings("/tmp/templates/settings/syssettings/settings.txt")
-- 
cgit v0.12


From f81e32d1c85dbdd942407a2b5df079f623743425 Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Wed, 12 Aug 2009 15:15:04 -0400
Subject: zoneminder: bumped for rebuild

---
 abs/core-testing/zoneminder/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/zoneminder/PKGBUILD b/abs/core-testing/zoneminder/PKGBUILD
index 6bfb082..5071e81 100644
--- a/abs/core-testing/zoneminder/PKGBUILD
+++ b/abs/core-testing/zoneminder/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=zoneminder
 pkgver=1.23.3
-pkgrel=6
+pkgrel=7
 pkgdesc="Capture, analyse, record and monitor video security cameras."
 arch=('i686')
 url="http://www.zoneminder.com"
-- 
cgit v0.12


From b1e1ae522a8a6a86cda2c0baecbfc6bba000c968 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Wed, 12 Aug 2009 16:08:53 -0400
Subject: fixed typo that would have kept etc.old around post-upgrade

---
 abs/core-testing/LinHES-config/PKGBUILD      | 2 +-
 abs/core-testing/LinHES-config/mv_install.py | 1 +
 2 files changed, 2 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index e8b26c3..19e3174 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=78
+pkgrel=79
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index bace1a5..14e1c5c 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -1190,6 +1190,7 @@ def upgrade(hostoptions):
     time.sleep(3)
     copy_it("upgrade")
     cmd = "rm -rf %s/etc.old" %data_config.MOUNTPOINT
+    runcmd(cmd)
     cmd = "rm -rf %s/varlibalsa.old" %data_config.MOUNTPOINT
     runcmd(cmd)
 
-- 
cgit v0.12


From 11de4aebdd13e06d096a08548addefe43ae0bf14 Mon Sep 17 00:00:00 2001
From: Bob Igo <bob@stormlogic.com>
Date: Wed, 12 Aug 2009 16:14:45 -0400
Subject: bumped rev to build pkg with combined fixes

---
 abs/core-testing/LinHES-config/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 19e3174..423a5ea 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=79
+pkgrel=80
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted 
-- 
cgit v0.12