From 1485cf1105f30b4542c28b688c3478ce39b883c7 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 30 Oct 2012 16:41:42 -0500
Subject: LinHES-config:  For FE only systems set BackendIP to NULL. By setting
 it to null it will autoselect which private IP to accept connections on for
 remote control.

refs #858

closes #858
---
 abs/core/LinHES-config/PKGBUILD                 |  8 ++++----
 abs/core/LinHES-config/mv_hostype.py            | 10 ++++++++++
 abs/core/LinHES-config/mv_install.py            |  4 ++--
 abs/core/LinHES-config/myth_settings_wrapper.sh | 16 ++++++++++++----
 4 files changed, 28 insertions(+), 10 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 37ec708..4954da3 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=173
+pkgrel=174
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -125,7 +125,7 @@ build() {
     install -o root -g root  -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
     install -o root -g root  -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
 }
-md5sums=('59e18e35359bebcd9d639c5e5b5d290d'
+md5sums=('cf5c419e6a719ba9be3f266038727bba'
          'f33e1a6f7985091b8d47cbaf7433f90f'
          '17677b9e25b8fe3511ad3a139ed91eea'
          '2596460462cf6c889cf8f95485537b20'
@@ -135,7 +135,7 @@ md5sums=('59e18e35359bebcd9d639c5e5b5d290d'
          'f73d6d6f98839e900cb6685bf5dc4eae'
          '408688e3bcb2cefe512f9a89863137c8'
          '2a7f3b34e522acfd08283b86c8926aba'
-         'c8812fc1dd0451361fc248d39de90c60'
+         '157906733642835bd7a3ff4e32771c8e'
          '689b01f7636e09b2f9657c6ce6006ee7'
          'b02bc06fc6623bf6473175165578e1d5'
          'a6faa20d905e2fd92ce79acab044b759'
@@ -157,7 +157,7 @@ md5sums=('59e18e35359bebcd9d639c5e5b5d290d'
          'fe5e31b833cc6707209e9d656b6eb53c'
          'ecb52b9b7a9ac0c8988093c1dfdda635'
          '23d0e12b7ca1cc6ea6b993c1d7ff20b9'
-         '67b651a8cd0dcccb368fe7d2402f05f3'
+         '1aa69e89034def751177cbd96c64e4ef'
          'b4900090d841d3e390cb840cf16afd85'
          '6dd202ec664ede468e42edf600f7913d'
          'c9c9390ac12145169dfe9a76896db328'
diff --git a/abs/core/LinHES-config/mv_hostype.py b/abs/core/LinHES-config/mv_hostype.py
index 473cc94..6d8446b 100755
--- a/abs/core/LinHES-config/mv_hostype.py
+++ b/abs/core/LinHES-config/mv_hostype.py
@@ -91,6 +91,16 @@ def setup_mysql_connection(systemconfig):
         b=mv_common.runcmd_output(cmd)
         logging.debug(b)
 
+    if systemtype == "Frontend_only":
+        fehost = mythip
+        logging.debug("    Changing Frontend_only in settings BIP Null: %s", fehost)
+        cmd = '''%s/bin/myth_settings_wrapper.sh -c BECONFIG -s frontendonly ''' %(mv_root)
+        #cmd = '''%s/bin/restore_default_settings.sh -c BECONFIG -s slave  -a %s ''' %(mv_root, slavehost)
+        b=mv_common.runcmd_output(cmd)
+        logging.debug(b)
+
+
+
 
     if systemtype == "Standalone":
         #THIS IS NEVER CALLED ANYMORE, need to move the mysql.txt stuff
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index 338e5dc..61e4405 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -17,7 +17,7 @@ def usage():
     print "The conf file is read when no command line options are given"
     print " /etc/systemconfig  must also be present "
 
-    print "Create /tmp/install_conf, with contents similiar to this.  Sizes are in MB"
+    print "Create /etc/install_conf, with contents similiar to this.  Sizes are in MB"
     print "    rootdisk=sda"
     print "    rootfs=ext4"
     print "    rootsize=5000"
@@ -2115,7 +2115,7 @@ for line in config_file:
 #Read in install_conf
 global install_conf
 install_conf = {}
-file_name = "/etc/install_layout"
+file_name = "/etc/install_conf"
 try:
     config_file = open(file_name)
 except:
diff --git a/abs/core/LinHES-config/myth_settings_wrapper.sh b/abs/core/LinHES-config/myth_settings_wrapper.sh
index a1fbffc..b122a78 100644
--- a/abs/core/LinHES-config/myth_settings_wrapper.sh
+++ b/abs/core/LinHES-config/myth_settings_wrapper.sh
@@ -239,11 +239,19 @@ case $OPERATION in
 
             if [ $SYSTEMTYPE = "standalone" ]
             then
-            define_xml "127.0.0.1" $hostname settings BackendServerIP
-            load_xml $gen_xml
-            define_xml "127.0.0.1" '' settings MasterServerIP
-            load_xml $gen_xml
+                define_xml "127.0.0.1" $hostname settings BackendServerIP
+                load_xml $gen_xml
+                define_xml "127.0.0.1" '' settings MasterServerIP
+                load_xml $gen_xml
+            fi
+
+            if [ $SYSTEMTYPE = "frontendonly" ]
+            then
+                define_xml '' $hostname settings BackendServerIP
+                load_xml $gen_xml
             fi
+
+
             ;;
 
 
-- 
cgit v0.12