From 085290881efe9b1e47fe5a6333637064b57256c2 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Nov 2022 23:12:35 -0500
Subject: linhes-templates: add pacman.conf.template

---
 linhes/linhes-templates/PKGBUILD                   |   6 +-
 .../templates/pacman.conf.template                 | 106 +++++++++++++++++++++
 2 files changed, 109 insertions(+), 3 deletions(-)
 create mode 100644 linhes/linhes-templates/templates/pacman.conf.template

diff --git a/linhes/linhes-templates/PKGBUILD b/linhes/linhes-templates/PKGBUILD
index f0598c6..6e93ca8 100644
--- a/linhes/linhes-templates/PKGBUILD
+++ b/linhes/linhes-templates/PKGBUILD
@@ -1,12 +1,13 @@
 pkgname=linhes-templates
 pkgver=9.0.0
-pkgrel=4
-conflicts=( )
+pkgrel=5
+conflicts=()
 pkgdesc="Templates used for LinHES system configuration"
 depends=()
 makedepends=()
 arch=('x86_64')
 source=(templates.tar.gz)
+sha256sums=('6d959c2c25d860b7e74d493900fa0de412975ab5652317dd442388db6ee97f83')
 
 package() {
     MVDIR=$pkgdir/usr/share/linhes
@@ -15,4 +16,3 @@ package() {
     chmod -R 0755 $MVDIR
     find $MVDIR -type f -perm 0755 -exec chmod 0644 {} +
 }
-sha256sums=('04a35b290a39c0ae20bb519989f8436ea01a867b53957ff5432c80500eaf4bb8')
diff --git a/linhes/linhes-templates/templates/pacman.conf.template b/linhes/linhes-templates/templates/pacman.conf.template
new file mode 100644
index 0000000..90fd6ea
--- /dev/null
+++ b/linhes/linhes-templates/templates/pacman.conf.template
@@ -0,0 +1,106 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir     = /
+#DBPath      = /var/lib/pacman/
+#CacheDir    = /var/cache/pacman/pkg/
+#LogFile     = /var/log/pacman.log
+#GPGDir      = /etc/pacman.d/gnupg/
+#HookDir     = /etc/pacman.d/hooks/
+HoldPkg     = pacman glibc
+#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+Architecture = auto
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg   =
+#IgnoreGroup =
+
+#NoUpgrade   =
+#NoExtract   =
+
+# Misc options
+#UseSyslog
+#Color
+#NoProgressBar
+# We cannot check disk space from within a chroot environment
+#CheckSpace
+#VerbosePkgLists
+ParallelDownloads = 5
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel    = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+#   - can be defined here or included from another file
+#   - pacman will search repositories in the order defined here
+#   - local/custom mirrors can be added here or in separate files
+#   - repositories listed first will take precedence when packages
+#     have identical names, regardless of version number
+#   - URLs will have $repo replaced by the name of the current repo
+#   - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+#       [repo-name]
+#       Server = ServerName
+#       Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+#[testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+#[community-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+# If you want to run 32 bit applications on your x86_64 system,
+# enable the multilib repositories as required here.
+
+#[multilib-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+#[multilib]
+#Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository.  See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs
+
+#[linhes]
+[linhes-testing]
+SigLevel = Optional TrustAll
+Server = http://linhes.org/repo/$arch/$repo/
-- 
cgit v0.12


From 75e8eba53439d7b7365e4ec6b28720f55805dd3c Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Nov 2022 23:42:19 -0500
Subject: linhes-dev: lh_setup_dev.sh: add rclone.conf; modify ccm pacman.conf
 template

---
 linhes/linhes-dev/PKGBUILD        |  4 ++--
 linhes/linhes-dev/lh_setup_dev.sh | 15 ++++++++++++++-
 2 files changed, 16 insertions(+), 3 deletions(-)

diff --git a/linhes/linhes-dev/PKGBUILD b/linhes/linhes-dev/PKGBUILD
index df74320..2a2981f 100644
--- a/linhes/linhes-dev/PKGBUILD
+++ b/linhes/linhes-dev/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-dev
 pkgver=9.0.0
-pkgrel=7
+pkgrel=8
 pkgdesc="Scripts to develop LinHES"
 arch=('x86_64')
 license=('GPL2')
@@ -10,7 +10,7 @@ url="http://linhes.org/"
 source=('lh_sync.sh' 'mp.py' 'lh_setup_dev.sh' 'lh_update_db_repo.sh')
 sha256sums=('3a64b4125b56c6f95cc9dc85ce58ebd1c0612b22fb27c3e76d4d9a5570f2d61e'
             '16787763282f20b15eee2377712e85d5653a9229d2b73d224c0fd4532436614a'
-            '081ac1ccb40df0c8aa82cd3841a39aa87ead4ea32c9ac6a76c5a7d7f0d10a80a'
+            '64c9ec7a519405e5967f90fd9e3d27207ad67abb47042bf8f43bfc5db761773e'
             '86c9ebe77228f7e3cc07cb05f480e5584e0e3cad1b889b63a50821f7323bf449')
 
 package() {
diff --git a/linhes/linhes-dev/lh_setup_dev.sh b/linhes/linhes-dev/lh_setup_dev.sh
index 1d9f783..e38e73f 100755
--- a/linhes/linhes-dev/lh_setup_dev.sh
+++ b/linhes/linhes-dev/lh_setup_dev.sh
@@ -15,6 +15,7 @@ mkdir -p /data/dev/pkg_repo/src_packages/linhes-testing
 echo -e "\n\nSetup clean-chroot-manager (ccm) and edit ~/.config/clean-chroot-manager.conf"...
 sudo ccm l
 sed -i 's/CHROOTPATH64=.*/CHROOTPATH64=\"\/data\/dev\/LH_buildroot\"/' ~/.config/clean-chroot-manager.conf
+sed -i 's/#CUSTOM_PACMAN_CONF=.*/CUSTOM_PACMAN_CONF=\"\/usr\/share\/linhes\/templates\/pacman.conf.template"/' ~/.config/clean-chroot-manager.conf
 sudo ccm c
 
 echo -e "\n\nChanging setting in /etc/makepkg.conf..."
@@ -48,10 +49,22 @@ fi
 END
 fi
 
+echo -e "\n\nAdd rclone.conf..."
+if ! grep -q 'host = linhes.org' ~/.config/rclone/rclone.conf; then
+cat >> ~/.config/rclone/rclone.conf<<END
+[ssh]
+type = sftp
+host = linhes.org
+user = reposync
+key_file = ssh-agent
+pubkey_file = ~/.ssh/id_rsa.pub
+END
+fi
+
 # clone the git linhes_pkgbuild
 # Checkout the repo. You will need to have been given a dev account on
 # linhes.org. This involves creating a public ssh key and supplying it to
 # one of the linhes.org admins. The key is created using ssh-keygen. The
 # resulting public key will be stored in .ssh/id_rsa.pub.
 echo -e "\n\nCheckout the repo manually. You will need to be given a dev account on linhes.org. This involves creating a public ssh key and supplying it toone of the linhes.org admins. The key is created using ssh-keygen. The resulting public key will be stored in .ssh/id_rsa.pub."
-echo -e "EXAMPLE: \ncd /data/dev\ngit clone git@linhes.org:linhes_pkgbuild\n\n"
+echo -e "EXAMPLE: \ncd /data/dev\ngit clone git@linhes.org:linhes_pkgbuild\ngit checkout testing\n\n"
-- 
cgit v0.12


From 94241aed81de346360aec8ad8c24026a4eebd2ca Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 Nov 2022 23:49:29 -0500
Subject: plex-htpc: update to 1.29.1

---
 linhes/plex-htpc/PKGBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/linhes/plex-htpc/PKGBUILD b/linhes/plex-htpc/PKGBUILD
index 20e28bf..9811cca 100644
--- a/linhes/plex-htpc/PKGBUILD
+++ b/linhes/plex-htpc/PKGBUILD
@@ -1,10 +1,10 @@
 # Maintainer: Ludvig Hozman <ludvig.hozman@gmail.com>
 
 pkgname=plex-htpc
-pkgver=1.28.1
+pkgver=1.29.1
 pkgrel=1
 _snapid=81OP06hEXlwmMrpMAhe5hyLy5bQ9q6Kz
-_snaprev=21
+_snaprev=24
 pkgdesc="Plex HTPC application for linux"
 arch=('x86_64')
 url='http://plex.tv'
@@ -13,7 +13,7 @@ makedepends=('squashfs-tools')
 depends=('qt5-base' 'qt5-svg' 'qt5-webengine' 'qt5-quickcontrols' 'qt5-x11extras' 'mpv' 'ffmpeg4.4')
 optdepends=('qt5-wayland: Wayland support' 'libva: GPU accelerated decoding')
 source=("https://api.snapcraft.io/api/v1/snaps/download/${_snapid}_${_snaprev}.snap" "qt.conf")
-sha256sums=('14c8a317e62b63b3a8e20de76b802e4b1e8a6fdf1249297a3da45ad0df1cbe70'
+sha256sums=('74eb389cb3c9f2cdf76db527b280347ba53c148556d0572a78dd19682d381968'
             '40d1b22236d9d2312d16563493b8c6d69134c5aa54ff6d1531243133fb46f083')
 
 prepare() {
-- 
cgit v0.12


From bee989bb3cc4c03cff6f310b37b8b30c1a4dff6f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 1 Dec 2022 00:12:39 -0500
Subject: linhes-system: lh_system_start.sh: change x11vnc setup

---
 linhes/linhes-system/PKGBUILD           |  4 ++--
 linhes/linhes-system/lh_system_start.sh | 15 +++++++++------
 2 files changed, 11 insertions(+), 8 deletions(-)

diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index baa5796..50579fd 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-system
 pkgver=9.0.0
-pkgrel=4
+pkgrel=5
 arch=('x86_64')
 #install=$pkgname.install
 pkgdesc="Everything that makes LinHES a system"
@@ -25,7 +25,7 @@ sha256sums=('96f67b5428debb7dac909893c56a7637bf6545c068732822981d4080125c53d9'
             '11168c9cd3b117decaab6bc665c183b4aab917cf0a976bce4c1b5e4686a27bc9'
             'ae34515e144830f424d3bd3f6b1b446892d62beed20bca6f0fb19b0bbb779f27'
             '23358a7bff4968eccd469613b81b1415c2ae0ebe77f14f74426697333e4d88d7'
-            'cb37ebf3967180fd6cf3a28cf0f685c5d69c344ef309355cfb42f6ad0f2ccf10'
+            '024c4270fe929ca9046ab34ebb03ab37f9647bb51c7b40ab2da5a08a278be54f'
             '91bdec992bb2c933e15625c181f2195c402060b879168ebf35944cb064c904b9'
             'cedd34e448d3d45ab0f9fff40c115401f45bdea5b99215d0aff514a759ae2b7c'
             '76f023c0cde7fea269234f1b29c32b117b91769217d4b1b8a3922daceb25f9f8'
diff --git a/linhes/linhes-system/lh_system_start.sh b/linhes/linhes-system/lh_system_start.sh
index e3243a5..f6be2d7 100755
--- a/linhes/linhes-system/lh_system_start.sh
+++ b/linhes/linhes-system/lh_system_start.sh
@@ -24,9 +24,10 @@ function applyUIsettings(){
 }
 
 function x11vnc_setup(){
-    msg "Set x11vnc Password" "Open Konsole run x11vnc -storepasswd"
+    konsole -e /bin/bash -i -c "echo 'Create VNC password.' && x11vnc --storepasswd"
+    mkdir ~/.vnc
     touch ~/.vnc/x11vnc.log
-    /usr/bin/systemctl enable --now x11vnc.service
+    sudo /usr/bin/systemctl enable --now x11vnc.service
 }
 
 function bashrc_setup(){
@@ -39,8 +40,9 @@ function bashrc_setup(){
 }
 
 function nanorc_setup(){
-    mkdir ~/.config/nano
-    echo -e 'set tabsize 4\nset tabstospaces\ninclude "/usr/share/nano/*.nanrc"' >> ~/.config/nano/nanorc
+    sudo sed -i 's/# set tabsize.*/set tabsize 4/' /etc/nanorc
+    sudo sed -i 's/# set tabstospaces.*/set tabstospaces/' /etc/nanorc
+    sudo sed -i 's/# include "\/usr\/share\/nano\/*.nanorc/include "\/usr\/share\/nano\/*.nanorc"/' /etc/nanorc
 }
 
 function storage_scan(){
@@ -51,7 +53,7 @@ function storage_scan(){
 
 function install_lh_apps(){
     #install programs that are not needed on the iso
-    sudo pacman -Syyy firefox glances mythtv ncdu x11vnc
+    sudo pacman -Syyy -noconfirm firefox glances mythtv ncdu x11vnc
 }
 
 function first_configure(){
@@ -59,6 +61,7 @@ function first_configure(){
         #apply settings for all system types
         applyUIsettings
         msg "New install of LinHES. Starting setup."
+        install_lh_apps
         nanorc_setup
         bashrc_setup
         x11vnc_setup
@@ -69,6 +72,7 @@ function first_configure(){
             #nice -n 19 mythfilldatabase --quiet &
             msg "Guide data is being loaded." "Until this completes some shows will appear as unknown in the program guide."
         else
+            msg "Frontend Only"
             #Frontend_only cmds
         fi
         touch ~/.config/lh_configured
@@ -80,5 +84,4 @@ function first_configure(){
 #-------MAIN-------
 first_configure
 /usr/bin/enableIRWake.sh &
-xset -dpms s off
 storage_scan
-- 
cgit v0.12