From c6bf7b0c7f31f94be17cabd97f40daf213bdede7 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 18 Nov 2010 01:52:49 +0000
Subject: gobject-introspection: update

---
 abs/core/gobject-introspection/PKGBUILD | 22 +++++++++++++++-------
 1 file changed, 15 insertions(+), 7 deletions(-)

diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
index a13f429..ce2809c 100644
--- a/abs/core/gobject-introspection/PKGBUILD
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -1,23 +1,31 @@
-# $Id: PKGBUILD 81938 2010-06-07 11:01:46Z jgc $
+# $Id: PKGBUILD 97051 2010-10-26 08:54:52Z ibiru $
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 pkgname=gobject-introspection
-pkgver=0.6.14
-pkgrel=2
+pkgver=0.9.12
+pkgrel=1
 pkgdesc="Introspection system for GObject-based libraries"
 url="http://live.gnome.org/GObjectInstrospection"
 arch=('x86_64' 'i686')
 license=('LGPL' 'GPL')
-depends=('libffi>=3.0.8' 'glib2>=2.24.1' 'python2' 'cairo>=1.8.10')
+depends=('libffi>=3.0.9' 'glib2>=2.26.0' 'python2')
+makedepends=('cairo')
+conflicts=('gir-repository')
+replaces=('gir-repository')
 options=('!libtool')
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/0.6/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('c4713bcbcebb06861738a8f630ab05289666e631f42f7abbf2e836978db7eba6')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/0.9/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('9c0060d66d14a060057a1fc005be73675a1b8a00d4968ce8e78ff2d6b9f84e81')
 
 build() {
   cd "${srcdir}/${pkgname}-${pkgver}"
-  ./configure --prefix=/usr --disable-static || return 1
+  ./configure --prefix=/usr --disable-static
   make || return 1
 }
+
 package() {
   cd "${srcdir}/${pkgname}-${pkgver}"
   make DESTDIR="${pkgdir}" install || return 1
+
+  sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|" \
+    "${pkgdir}"/usr/lib/gobject-introspection/giscanner/*.py
 }
+
-- 
cgit v0.12