From d51e88d864876da3582e1a0bfa7e2890c383c126 Mon Sep 17 00:00:00 2001
From: Michael Hanson <mihanson@linhes.org>
Date: Tue, 24 Jul 2012 00:49:41 +0000
Subject: linhes-scripts: fix for myth2mkv

---
 abs/core/linhes-scripts/PKGBUILD | 4 ++--
 abs/core/linhes-scripts/myth2mkv | 7 ++++++-
 2 files changed, 8 insertions(+), 3 deletions(-)

diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 829694b..5458b28 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=7
-pkgrel=41
+pkgrel=42
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -104,4 +104,4 @@ md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
          'd8838461af9d446a1fd7e7883fdc75d1'
          'cc9cdabcdfc969c2829b58c0e513488c'
          '54a478660d0f8150fe10112a9ecf2740'
-         '980423e07c8c6ffd0ea1bf9a1959fdc2')
+         '8fa34662c686b210c9943324b7df2feb')
diff --git a/abs/core/linhes-scripts/myth2mkv b/abs/core/linhes-scripts/myth2mkv
index 5035748..f180b31 100644
--- a/abs/core/linhes-scripts/myth2mkv
+++ b/abs/core/linhes-scripts/myth2mkv
@@ -2,7 +2,7 @@
 #
 # Convert video to AVC-1 / h264
 #
-# version 0.25-001
+# version 0.25-002
 #
 # Prerequisites:
 #   - mythtv >= 0.25
@@ -156,6 +156,11 @@ if [[ ${FPS} = "29.970" ]] ; then
   FPS="29.97"
 fi
 
+# HandBrake does not like a framerate of 59.940, so let's drop the 0
+if [[ ${FPS} = "59.940" ]] ; then
+  FPS="59.94"
+fi
+
 # A rough guestimation that if the video width is 1920, 1440, 852, 704, 640 or
 # 528 pixels it is probably interlaced.
 if [[ ${DEINT} = Y ]] ; then
-- 
cgit v0.12