From f221377d5d53dd2a811fe9940c1d06ef5300e81b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 30 May 2018 17:52:55 +0000
Subject: perl-exporter-tiny: initial

---
 abs/core/perl_modules/perl-exporter-tiny/PKGBUILD | 48 +++++++++++++++++++++++
 1 file changed, 48 insertions(+)
 create mode 100644 abs/core/perl_modules/perl-exporter-tiny/PKGBUILD

diff --git a/abs/core/perl_modules/perl-exporter-tiny/PKGBUILD b/abs/core/perl_modules/perl-exporter-tiny/PKGBUILD
new file mode 100644
index 0000000..a758e48
--- /dev/null
+++ b/abs/core/perl_modules/perl-exporter-tiny/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=perl-exporter-tiny
+pkgver=1.000000
+pkgrel=2
+pkgdesc="an exporter with the features of Sub::Exporter but only core dependencies"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+url='http://search.cpan.org/dist/Exporter-Tiny'
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOBYINK/Exporter-Tiny-$pkgver.tar.gz")
+sha512sums=('02e72b3d1ec09fb5b7da5638893a12098d3300cfc36ff417c8d5cd8a4ef54891d675310612130e118e0e6a88d615cc18cdc888ab7333f2fc1007632c82d4c349')
+_distdir="Exporter-Tiny-$pkgver"
+
+build() {
+  ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
+      PERL_AUTOINSTALL=--skipdeps                            \
+      PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'"     \
+      PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+      MODULEBUILDRC=/dev/null
+
+    cd "$srcdir/$_distdir"
+    /usr/bin/perl Makefile.PL
+    make
+  )
+}
+
+check() {
+  cd "$srcdir/$_distdir"
+  ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+    make test
+  )
+}
+
+package() {
+  cd "$srcdir/$_distdir"
+  make install
+
+  find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
-- 
cgit v0.12