From fc92229e57eb2c03e6de5a22efe33b5212c7bc9b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 27 Sep 2020 21:40:42 +0000
Subject: python: update to 3.8.5

---
 abs/core/python/PKGBUILD | 21 +++++++--------------
 1 file changed, 7 insertions(+), 14 deletions(-)

diff --git a/abs/core/python/PKGBUILD b/abs/core/python/PKGBUILD
index ffa1189..acb5af1 100644
--- a/abs/core/python/PKGBUILD
+++ b/abs/core/python/PKGBUILD
@@ -8,17 +8,17 @@ shopt -s extglob
 
 pkgbase=python
 pkgname=(python python-tests)
-pkgver=3.8.3
-pkgrel=1
+pkgver=3.8.5
+pkgrel=2
 _pybasever=${pkgver%.*}
 pkgdesc="Next generation of the python high-level scripting language"
 arch=('x86_64')
 license=('custom')
 url="https://www.python.org/"
-depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib' 'libnsl')
-makedepends=('tk' 'sqlite' 'valgrind' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb')
+depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'zlib')
+makedepends=('tk' 'sqlite' 'valgrind' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb' 'ttf-font')
 source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc})
-sha512sums=('3103bd8d944f3905eee3a2b52fd1f5c7dee380f9c5a99ad35a401fcba5a9117c3860ecec5cb47a92712c6549442fd2fa553a15c5657241dd09f5d00b9ed4f0f4'
+sha512sums=('460cee65d7df7150694590575502d7f22e548ebfc99c8f8b363eef8bf30ee72e58d8ffacb1d607824f877f880eb9fd6775a508388029583e1e1df3380f3f9587'
             'SKIP')
 validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D'  # Ned Deily (Python release signing key) <nad@python.org>
               'E3FF2839C048B25C084DEBE9B26995E310250568') # Ɓukasz Langa (GPG langa.pl) <lukasz@langa.pl>
@@ -26,9 +26,6 @@ validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D'  # Ned Deily (Python re
 prepare() {
   cd Python-${pkgver}
 
-  # https://bugs.python.org/issue34587
-  sed -i -e "s|testCongestion|disabled_&|" Lib/test/test_socket.py
-
   # FS#23997
   sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
 
@@ -73,10 +70,7 @@ build() {
 }
 
 check() {
-  # test_gdb is expected to fail with LTO
-  # test_idle, test_tk, test_ttk_guionly segfaults since 3.6.5
-  # test_socket hangs since 3.8.2
-  # test_decimal fails since 3.8.2
+  # test_tk: https://bugs.python.org/issue41306
 
   cd Python-${pkgver}
 
@@ -86,8 +80,7 @@ check() {
 
   LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
   LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" \
-    "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_gdb -x test_idle -x test_tk -x test_ttk_guionly \
-                                                                  -x test_socket -x test_decimal
+    "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_tk
 }
 
 package_python() {
-- 
cgit v0.12