From 18a16759c1ed3a84519ecb05e3601290bd91c0f1 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 6 Apr 2014 23:00:22 +0000
Subject: LinHES-system: LinHES-session: stop plymouthd. refs #891

---
 abs/core/LinHES-system/LinHES-session | 17 ++++++++++++++---
 abs/core/LinHES-system/PKGBUILD       |  6 +++---
 2 files changed, 17 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index 14606fb..870428d 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -55,13 +55,13 @@ function keylaunch(){
         fi
 
         echo "Checking if keylaunch is running"
-        if [ "$(pidof keylaunch)" ] 
+        if [ "$(pidof keylaunch)" ]
         then
             echo "keylaunch is already running"
         else
             echo "Starting keylaunch"
             /usr/bin/keylaunch &
-        fi 
+        fi
     fi
 
 }
@@ -317,7 +317,6 @@ function start_myth() {
             fi
         done
         sleep 3 #give time for MBE to be fully operational
-        
     fi
 
     #continue on with starting mythtv
@@ -396,6 +395,17 @@ function set_background()
 }
 
 
+function stop_plymouth()
+{
+    #pause plymouthd and continue in /etc/sv/frontend/finish
+    pidfile=/run/plymouth.pid
+    if [ -e "$pidfile" ]; then
+        plypid=`cat "$pidfile"`
+        if [ -n "$plypid" ]; then
+            sudo kill -s STOP "$plypid"
+        fi
+    fi
+}
 
 
 if [ x"$WM" = "fluxbox" ]
@@ -418,6 +428,7 @@ start_screensaver
 notify_scan &
 auto_start &
 update_apple_trailers
+stop_plymouth &
 first_configure
 show_help_tip
 start_myth
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index f0253f0..9cf066a 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.1
-pkgrel=20
+pkgrel=21
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -9,7 +9,7 @@ depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch'
         'python_aosd' 'udisks' 'LinHES-config>=2.3-59' 'sudo'
         'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu'
         'ethtool' 'gnu-netcat' 'normalize' 'ttf-overlock'
-        'handbrake-cli' 'mkvtoolnix' 'mplayer')
+        'handbrake-cli' 'mkvtoolnix' 'mplayer' 'runit-scripts>=8.1-12')
 backup=('etc/modprobe.d/alsa-base.conf')
 binfiles="LinHES-start optimize_mythdb.py myth_mtc.py
  load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh
@@ -75,7 +75,7 @@ package() {
 
 }
 
-md5sums=('7ab2a2c643d2b286811d8303d08982ad'
+md5sums=('2b69f7f632203f7196714b8855f962b1'
          'de32a1c50101265dd7f6ca5037f7a26a'
          '301884fb60521627fffd1160b2cf5181'
          '76b2637cac0452b3acdbeeb4e8a5474b'
-- 
cgit v0.12