From 81d44f51cb5f57d25b9b15ee9ca3d29f10acc2e3 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 10 Sep 2010 01:49:02 +0000
Subject: gcc: update to 4.5.1

---
 abs/core-testing/cloog-ppl/PKGBUILD           |  9 ++--
 abs/core-testing/coreutils/su                 |  9 ----
 abs/core-testing/coreutils/su.pam             |  9 ++++
 abs/core-testing/gcc/PKGBUILD                 | 57 ++++++++++++------------
 abs/core-testing/gcc/buildfix_new_bison.patch | 22 ---------
 abs/core-testing/gcc/gcc-java-driver.patch    | 11 -----
 abs/core-testing/gcc/r160561.patch            | 64 ---------------------------
 7 files changed, 43 insertions(+), 138 deletions(-)
 delete mode 100644 abs/core-testing/coreutils/su
 create mode 100644 abs/core-testing/coreutils/su.pam
 delete mode 100644 abs/core-testing/gcc/buildfix_new_bison.patch
 delete mode 100644 abs/core-testing/gcc/gcc-java-driver.patch
 delete mode 100644 abs/core-testing/gcc/r160561.patch

diff --git a/abs/core-testing/cloog-ppl/PKGBUILD b/abs/core-testing/cloog-ppl/PKGBUILD
index 16f0369..56af019 100644
--- a/abs/core-testing/cloog-ppl/PKGBUILD
+++ b/abs/core-testing/cloog-ppl/PKGBUILD
@@ -1,15 +1,15 @@
-# $Id: PKGBUILD 78357 2010-04-22 02:43:20Z allan $
+# $Id: PKGBUILD 87235 2010-08-11 12:10:19Z allan $
 # Maintainer: Allan McRae <allan@archlinux.org>
 # Contributor: ezzetabi <ezzetabi at gawab dot com>
 
 pkgname=cloog-ppl
 pkgver=0.15.9
-pkgrel=1
+pkgrel=2
 pkgdesc="Library that generates loops for scanning polyhedra"
 arch=('i686' 'x86_64')
 url="http://www.cloog.org/"
 license=('GPL')
-depends=('ppl')
+depends=('ppl>=0.11')
 options=('!libtool')
 source=(ftp://gcc.gnu.org/pub/gcc/infrastructure/${pkgname}-${pkgver}.tar.gz)
 md5sums=('806e001d1b1a6b130069ff6274900af5')
@@ -17,6 +17,9 @@ md5sums=('806e001d1b1a6b130069ff6274900af5')
 build() {
   cd $srcdir/$pkgname-$pkgver
 
+  # "Add" ppl-0.11 compatibility
+  sed -i "/ppl_minor_version=/s#10#11#" configure
+
   ./configure --prefix=/usr --infodir=/usr/share/info \
     --with-bits=gmp --with-ppl=/usr 
   make
diff --git a/abs/core-testing/coreutils/su b/abs/core-testing/coreutils/su
deleted file mode 100644
index cf15f40..0000000
--- a/abs/core-testing/coreutils/su
+++ /dev/null
@@ -1,9 +0,0 @@
-#%PAM-1.0
-auth		sufficient	pam_rootok.so
-# Uncomment the following line to implicitly trust users in the "wheel" group.
-#auth		sufficient	pam_wheel.so trust use_uid
-# Uncomment the following line to require a user to be in the "wheel" group.
-#auth		required	pam_wheel.so use_uid
-auth		required	pam_unix.so
-account		required	pam_unix.so
-session		required	pam_unix.so
diff --git a/abs/core-testing/coreutils/su.pam b/abs/core-testing/coreutils/su.pam
new file mode 100644
index 0000000..cf15f40
--- /dev/null
+++ b/abs/core-testing/coreutils/su.pam
@@ -0,0 +1,9 @@
+#%PAM-1.0
+auth		sufficient	pam_rootok.so
+# Uncomment the following line to implicitly trust users in the "wheel" group.
+#auth		sufficient	pam_wheel.so trust use_uid
+# Uncomment the following line to require a user to be in the "wheel" group.
+#auth		required	pam_wheel.so use_uid
+auth		required	pam_unix.so
+account		required	pam_unix.so
+session		required	pam_unix.so
diff --git a/abs/core-testing/gcc/PKGBUILD b/abs/core-testing/gcc/PKGBUILD
index 40fd4b6..1cec41a 100644
--- a/abs/core-testing/gcc/PKGBUILD
+++ b/abs/core-testing/gcc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 82472 2010-06-11 13:12:15Z allan $
+# $Id: PKGBUILD 87242 2010-08-11 12:46:24Z allan $
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Maintainer: Allan McRae <allan@archlinux.org>
 
@@ -6,31 +6,30 @@
 # NOTE: libtool requires rebuilt with each new gcc version
 
 pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-ada')
-pkgver=4.5.0
-pkgrel=6
-_snapshot=4.5-20100610
-_libstdcppmanver=20100312	# Note: check source directory name when updating this
+pkgver=4.5.1
+pkgrel=2
+#_snapshot=4.5-20100610
+_libstdcppmanver=20100719	# Note: check source directory name when updating this
 pkgdesc="The GNU Compiler Collection"
 arch=('i686' 'x86_64')
 license=('GPL' 'LGPL' 'custom')
 url="http://gcc.gnu.org"
-makedepends=('binutils>=2.20.1' 'libmpc>=0.8.2-2' 'cloog-ppl>=0.15.8' 'libelf' 'gcc-ada')
+makedepends=('binutils>=2.20.1' 'libmpc>=0.8.2-2' 'cloog-ppl>=0.15.9-2' 'elfutils' 'gcc-ada')
 options=('!libtool' '!emptydirs')
-source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,ada}-${pkgver}.tar.bz2
-	ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-{core,g++,fortran,objc,ada}-${_snapshot}.tar.bz2
-	ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-man.${_libstdcppmanver}.tar.bz2
+source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,ada}-${pkgver}.tar.bz2
+	#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-{core,g++,fortran,objc,ada}-${_snapshot}.tar.bz2
+	ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-api.${_libstdcppmanver}.man.tar.bz2
 	gcc_pure64.patch
-	gcc-hash-style-both.patch
-	r160561.patch)
-md5sums=('d0c6573f18e61d0a6c6fe742066346cd'
-         '4c5369d27b8cb4c4e447553f064d0f16'
-         '2c191ab600e600c774a65674c542e210'
-         'a569128d6daf741b242e39f5c24debe4'
-         'a7527896c33759ccc40bb82173f8f27f'
-         'f9a21b9dfc174f49a09ddaacfd3ac78f'
+	gcc-hash-style-both.patch)
+md5sums=('dc8959e31b01a65ce10d269614815054'
+         'b294953ff0bb2f20c7acb2bf005d832a'
+         '7567c2f8df8a8bf61b48fe414b88de65'
+         '3c11b7037896e967eddf8178af2ddd98'
+         'c92111e2e22fc60d1e0adb1b5c7fa4f9'
+         '226ae0c6364cfe2c1f7ac88d06088d5a'
          '4030ee1c08dd1e843c0225b772360e76'
-         '6fd395bacbd7b6e47c7b74854b478363'
-         '79cb26e66eb2502171ef69438fa8666d')
+         '6fd395bacbd7b6e47c7b74854b478363')
+
 
 if [ -n "${_snapshot}" ]; then
   _basedir="${srcdir}/gcc-${_snapshot}"
@@ -46,6 +45,9 @@ build() {
   
   cd ${_basedir}
 
+  # "Add" ppl-0.11 compatibility
+  sed -i "/ppl_minor_version=/s#10#11#" configure
+
   # Do not install libiberty
   sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
 
@@ -53,12 +55,9 @@ build() {
   sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
 
   if [ "${CARCH}" = "x86_64" ]; then
-    patch -Np1 -i ../gcc_pure64.patch || return 1
+    patch -Np1 -i ../gcc_pure64.patch
   fi
-  patch -Np0 -i ${srcdir}/gcc-hash-style-both.patch || return 1
-
-  # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44258
-  patch -Np1 -i ${srcdir}/r160561.patch || return 1
+  patch -Np0 -i ${srcdir}/gcc-hash-style-both.patch
 
   echo ${pkgver} > gcc/BASE-VER
 
@@ -71,14 +70,14 @@ build() {
       --with-system-zlib --with-ppl --with-cloog \
       --libdir=/usr/lib --libexecdir=/usr/lib \
       --mandir=/usr/share/man --infodir=/usr/share/info
-  make || return 1
+  make
 }
 
 package_gcc-libs()
 {
   pkgdesc="Runtime libraries shipped by GCC for C and C++ languages"
   groups=('base')
-  depends=('glibc>=2.12-4')
+  depends=('glibc>=2.11.1-2')
   install=gcc-libs.install
 
   cd ${_basedir}/build
@@ -105,14 +104,14 @@ package_gcc-libs()
 
 package_gcc()
 {
-  depends=('binutils>=2.20.1' 'libmpc>=0.8.1-2' 'cloog-ppl>=0.15.8' 'libelf')
+  depends=('binutils>=2.20.1' 'libmpc>=0.8.1-2' 'cloog-ppl>=0.15.9-2' 'elfutils')
   groups=('base-devel')
   install=gcc.install
 
   cd ${_basedir}/build
   
   # much, much easier to install the lot and clean-up the mess
-  make -j1 DESTDIR=${pkgdir} install || return 1
+  make -j1 DESTDIR=${pkgdir} install
   rm $pkgdir/usr/bin/{*gfortran,gnat*}
   rm $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{ada{include,lib},finclude,include/objc}/*
   rm $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{cc1obj{,plus},f951,gnat1,libgfortranbegin.a}
@@ -158,7 +157,7 @@ EOF
 
   # install the libstdc++ man pages
   install -dm755 ${pkgdir}/usr/share/man/man3
-  install -m644 ${srcdir}/libstdc++-man.${_libstdcppmanver}/man3/* \
+  install -m644 ${srcdir}/libstdc++-api-${_libstdcppmanver}.man/man3/* \
     ${pkgdir}/usr/share/man/man3/
   # deal with conflicts...
   rm -f ${pkgdir}/usr/share/man/man3/{ctime,queue,random,regex,string}.3
diff --git a/abs/core-testing/gcc/buildfix_new_bison.patch b/abs/core-testing/gcc/buildfix_new_bison.patch
deleted file mode 100644
index 01b8880..0000000
--- a/abs/core-testing/gcc/buildfix_new_bison.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- gcc/treelang/parse.y	2007-07-18 08:19:29.000000000 +0000
-+++ gcc/treelang/parse.y.new	2008-11-20 06:40:00.013275486 +0000
-@@ -369,7 +369,6 @@
-   current_function = NULL;
- }
- ;
--
- variable_defs_opt:
- /* Nil.  */ {
-   $$ = 0;
-@@ -685,9 +684,9 @@
- 
- expressions_with_commas_opt:
- /* Nil.  */ {
--$$ = 0
-+$$ = 0;
- }
--|expressions_with_commas { $$ = $1 }
-+|expressions_with_commas { $$ = $1; }
- ;
- 
- expressions_with_commas:
diff --git a/abs/core-testing/gcc/gcc-java-driver.patch b/abs/core-testing/gcc/gcc-java-driver.patch
deleted file mode 100644
index 528b528..0000000
--- a/abs/core-testing/gcc/gcc-java-driver.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/Makefile.in.orig	2008-03-08 09:52:09.000000000 +0000
-+++ gcc/Makefile.in	2008-03-08 09:54:09.000000000 +0000
-@@ -421,8 +421,8 @@
- xm_defines=@xm_defines@
- lang_checks=check-gcc
- lang_opt_files=@lang_opt_files@ $(srcdir)/c.opt $(srcdir)/common.opt
--lang_specs_files=@lang_specs_files@
-+lang_specs_files=@lang_specs_files@ $(srcdir)/java/lang-specs.h
- lang_tree_files=@lang_tree_files@
- target_cpu_default=@target_cpu_default@
- GCC_THREAD_FILE=@thread_file@
diff --git a/abs/core-testing/gcc/r160561.patch b/abs/core-testing/gcc/r160561.patch
deleted file mode 100644
index f3c386b..0000000
--- a/abs/core-testing/gcc/r160561.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- trunk/gcc/tree-sra.c	2010/06/10 16:44:04	160560
-+++ trunk/gcc/tree-sra.c	2010/06/10 16:49:09	160561
-@@ -1689,9 +1689,10 @@
- 
- /* Build a subtree of accesses rooted in *ACCESS, and move the pointer in the
-    linked list along the way.  Stop when *ACCESS is NULL or the access pointed
--   to it is not "within" the root.  */
-+   to it is not "within" the root.  Return false iff some accesses partially
-+   overlap.  */
- 
--static void
-+static bool
- build_access_subtree (struct access **access)
- {
-   struct access *root = *access, *last_child = NULL;
-@@ -1706,24 +1707,32 @@
- 	last_child->next_sibling = *access;
-       last_child = *access;
- 
--      build_access_subtree (access);
-+      if (!build_access_subtree (access))
-+	return false;
-     }
-+
-+  if (*access && (*access)->offset < limit)
-+    return false;
-+
-+  return true;
- }
- 
- /* Build a tree of access representatives, ACCESS is the pointer to the first
--   one, others are linked in a list by the next_grp field.  Decide about scalar
--   replacements on the way, return true iff any are to be created.  */
-+   one, others are linked in a list by the next_grp field.  Return false iff
-+   some accesses partially overlap.  */
- 
--static void
-+static bool
- build_access_trees (struct access *access)
- {
-   while (access)
-     {
-       struct access *root = access;
- 
--      build_access_subtree (&access);
-+      if (!build_access_subtree (&access))
-+	return false;
-       root->next_grp = access;
-     }
-+  return true;
- }
- 
- /* Return true if expr contains some ARRAY_REFs into a variable bounded
-@@ -2062,9 +2071,7 @@
-       struct access *access;
- 
-       access = sort_and_splice_var_accesses (var);
--      if (access)
--	build_access_trees (access);
--      else
-+      if (!access || !build_access_trees (access))
- 	disqualify_candidate (var,
- 			      "No or inhibitingly overlapping accesses.");
-     }
-- 
cgit v0.12