From 07fe0535dd2d88d2bdd543168fee1768b6c2a926 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verison.net>
Date: Tue, 23 Mar 2010 00:53:06 +0000
Subject: help2man: initial inclusion. Needed as a build dep for mythtv-contrib
 Ref: dct-channel

---
 abs/extra-testing/help2man/PKGBUILD                | 28 ++++++++++++++++++++++
 .../help2man/help2man-1.37.1-respect-LDFLAGS.patch | 11 +++++++++
 2 files changed, 39 insertions(+)
 create mode 100644 abs/extra-testing/help2man/PKGBUILD
 create mode 100644 abs/extra-testing/help2man/help2man-1.37.1-respect-LDFLAGS.patch

diff --git a/abs/extra-testing/help2man/PKGBUILD b/abs/extra-testing/help2man/PKGBUILD
new file mode 100644
index 0000000..ef9642e
--- /dev/null
+++ b/abs/extra-testing/help2man/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 67994 2010-02-10 11:34:11Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Paul Mattal <paul@mattal.com>
+
+pkgname=help2man
+pkgver=1.37.1
+pkgrel=1
+pkgdesc="Conversion tool to create man files"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/help2man/"
+license=('GPL')
+depends=('perl-locale-gettext')
+source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+        help2man-1.37.1-respect-LDFLAGS.patch)
+md5sums=('371b5cc74fe9c2ea3ee1ca23c19b19a8'
+         '6f80dfd75b46c6bfbc2eeb5516771096')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+
+  patch -Np1 -i ${srcdir}/help2man-1.37.1-respect-LDFLAGS.patch || return 1
+  ./configure --prefix=/usr \
+              --mandir=/usr/share/man \
+	      --infodir=/usr/share/info \
+	      --libdir=/lib
+  make || return 1
+  make DESTDIR="${pkgdir}" install || return 1
+}
diff --git a/abs/extra-testing/help2man/help2man-1.37.1-respect-LDFLAGS.patch b/abs/extra-testing/help2man/help2man-1.37.1-respect-LDFLAGS.patch
new file mode 100644
index 0000000..a314c27
--- /dev/null
+++ b/abs/extra-testing/help2man/help2man-1.37.1-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in	2009-11-14 07:21:34.000000000 +0100
++++ b/Makefile.in	2010-02-10 12:23:35.000000000 +0100
+@@ -103,7 +103,7 @@
+ 
+ preload: $(preload).so
+ $(preload).so: $(srcdir)/$(preload).c
+-	$(CC) $(CFLAGS) -o $@ -fPIC -shared $? $(LIBS)
++	$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ -fPIC -shared $? $(LIBS)
+ 
+ man: $(target).1
+ $(target).1: $(srcdir)/$(target).PL $(srcdir)/$(target).h2m
-- 
cgit v0.12