From b4b39219a4202ec5cd46a3dcf1082d9b8e966013 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 24 Feb 2011 02:39:48 +0000
Subject: runit-scripts: Add a local shutdown script (3.local) for custom
 shutdown commands

---
 abs/core/runit-scripts/PKGBUILD             |  8 +++-----
 abs/core/runit-scripts/runitscripts/3       | 10 ++++++++++
 abs/core/runit-scripts/runitscripts/3.local |  3 +++
 3 files changed, 16 insertions(+), 5 deletions(-)
 create mode 100755 abs/core/runit-scripts/runitscripts/3.local

diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 83b3800..d2e6be6 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=2.1.1
-pkgrel=18
+pkgrel=19
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
@@ -8,7 +8,7 @@ depends=('glibc' 'util-linux' 'initscripts' 'runit' )
 makedepends=('rsync')
 conflicts=()
 replaces=()
-backup=(etc/runit/1.local)
+backup=('etc/runit/1.local' 'etc/runit/3.local')
 install=runit.install
 source=(fbsplash-runit.sh)
 arch=('i686')
@@ -23,11 +23,9 @@ build() {
   install -d $startdir/pkg/sbin
   install -d $startdir/pkg/etc/rc.d/functions.d
 
-  install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
+  install -m0700 1 2 3 1.local 3.local ctrlaltdel $startdir/pkg/etc/runit
   install -m755 $startdir/src/fbsplash-runit.sh $startdir/pkg/etc/rc.d/functions.d/fbsplash-runit.sh
   install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
   rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
 }
-
-md5sums=('701fc39d1578b56e7702b1393d8a2b2e')
 md5sums=('fdc7aee7ce323f1e55060e2da54a9534')
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 50b3e92..d4b0a6a 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -9,4 +9,14 @@ then
 	kill -9 $pid 2>/dev/null
 fi
 export PREVLEVEL=3
+
+#user added stuff for level 3 of runit
+if [ -e /etc/runit/3.local ]
+then
+    #exec the file
+    stat_busy  /etc/runit/3.local
+    /etc/runit/3.local
+    stat_done
+fi
+
 /etc/rc.shutdown
diff --git a/abs/core/runit-scripts/runitscripts/3.local b/abs/core/runit-scripts/runitscripts/3.local
new file mode 100755
index 0000000..4aa8220
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/3.local
@@ -0,0 +1,3 @@
+#!/bin/bash
+#local user shutdown script, run at the end of runit 3
+
-- 
cgit v0.12