From b5b6b297d572ed222d16407aa127e4ca9b5bdd5b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 10 Apr 2014 17:10:02 +0000
Subject: ldb: initial inclusion. dep of samba. refs #961

---
 abs/extra/ldb/PKGBUILD | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
 create mode 100644 abs/extra/ldb/PKGBUILD

diff --git a/abs/extra/ldb/PKGBUILD b/abs/extra/ldb/PKGBUILD
new file mode 100644
index 0000000..9717290
--- /dev/null
+++ b/abs/extra/ldb/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: Marco A Rojas <marquicus at gmail dot com>
+
+pkgname=ldb
+pkgver=1.1.16
+pkgrel=1
+pkgdesc="A schema-less, ldap like, API and database"
+arch=('i686' 'x86_64')
+url="http://ldb.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+license=('GPL3')
+depends=('talloc' 'tevent' 'tdb' 'popt')
+makedepends=('python2')
+optdepends=('python2: for python bindings')
+
+build() {
+	cd ${srcdir}/${pkgname}-${pkgver}
+
+	# change to use python2
+	sed -i -e "s|/usr/bin/env python$|/usr/bin/env python2|" buildtools/bin/waf
+	export PYTHON=/usr/bin/python2
+
+	./configure --prefix=/usr \
+		--disable-rpath \
+		--disable-rpath-install \
+		--bundled-libraries=NONE \
+		--builtin-libraries=replace \
+                --with-modulesdir=/usr/lib/ldb/modules \
+                --with-privatelibdir=/usr/lib/ldb
+	make
+}
+
+package() {
+	cd ${srcdir}/${pkgname}-${pkgver}
+
+	make DESTDIR=${pkgdir}/ install
+}
+md5sums=('60865c0b5704469ee2e59703087c8ec8')
-- 
cgit v0.12