From 0a37d3f3f9c8e979d8f531f61420ccb7d2981e41 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 5 Dec 2017 20:35:12 +0000
Subject: xymon: add acl to allow nobody to read
 /home/mythtv/.mythtv/config.xml

---
 abs/core/xymon/PKGBUILD             | 2 +-
 abs/core/xymon/xymon-client.install | 3 ++-
 abs/core/xymon/xymon-server.install | 4 +++-
 3 files changed, 6 insertions(+), 3 deletions(-)

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index 12649cb..759241b 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.28
-pkgrel=4
+pkgrel=5
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license=('GPL')
 arch=('i686' 'x86_64')
diff --git a/abs/core/xymon/xymon-client.install b/abs/core/xymon/xymon-client.install
index 80210f1..312be91 100644
--- a/abs/core/xymon/xymon-client.install
+++ b/abs/core/xymon/xymon-client.install
@@ -2,7 +2,8 @@ post_install() {
 	. /etc/systemconfig
 	sed -i -e "s/127.0.0.1/$dbhost/" /home/xymon/client/etc/xymonclient.cfg
 	chown -R nobody /home/xymon
-
+    #added so py bindings work with /home/mythtv/.mythtv/config.xml
+    setfacl -m "u:nobody:--x" /home/mythtv/
 }
 
 post_upgrade() {
diff --git a/abs/core/xymon/xymon-server.install b/abs/core/xymon/xymon-server.install
index 0eec8f1..7c08bd3 100644
--- a/abs/core/xymon/xymon-server.install
+++ b/abs/core/xymon/xymon-server.install
@@ -20,7 +20,9 @@ post_install() {
     #fix permissions
     chown -R nobody:nobody /home/xymon
     chown -R nobody:nobody /data/srv/httpd/htdocs/xymon
-    
+    #added so py bindings work with /home/mythtv/.mythtv/config.xml
+    setfacl -m "u:nobody:--x" /home/mythtv/
+
     chown -R nobody:http /data/srv/httpd/htdocs/xymon/snap
     chown -R nobody:http /data/srv/httpd/htdocs/xymon/rep
     chmod -R 775   /data/srv/httpd/htdocs/xymon/rep
-- 
cgit v0.12