From 37a05f90e899430a2357f5deeb173e11e018d389 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Jan 2016 20:25:50 +0000
Subject: LinHES-system: LinHES-session: adjust for new tilda version

---
 abs/core/LinHES-system/LinHES-session | 30 ++++++++++++++----------------
 abs/core/LinHES-system/PKGBUILD       |  6 +++---
 2 files changed, 17 insertions(+), 19 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index ad8fb3c..c2b9b03 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -88,36 +88,34 @@ function load_nvidia_settings(){
 function run_tilda(){
     if [ -f /usr/bin/tilda ]
     then
-        if [ ! -e  ~/.tilda/config_0 ]
+        if [ ! -e  ~/.config/tilda/config_0 ]
         then
-            mkdir -p ~/.tilda/
+            mkdir -p ~/.config/tilda/
         fi
 
         width=`/usr/bin/xwininfo -root|grep Width | awk '{ print $2}'`
         height=`/usr/bin/xwininfo -root|grep Height | awk '{ print $2}'`
         center=$[width/2]
-        sixtypercent=`echo "scale=0; ( $width*.6) / 1" |bc`
-        quarter_height=`echo "scale=0; ($height*.35) /1" |bc`
+        tilda_width=`echo "scale=0; ( $width*.9) / 1" |bc`
+        tilda_height=`echo "scale=0; ($height*.4) /1" |bc`
 
-
-	if [ $sixtypercent -lt 700 ]
-	then
-             sixtypercent=700
+       if [ $tilda_width -lt 700 ]
+       then
+             tilda_width=700
         fi
 
-	if [ $quarter_height -lt 350 ]
-	then
-             quarter_height=350
+       if [ $tilda_height -lt 350 ]
+       then
+             tilda_height=350
         fi
-        startloc=`echo "scale=0 ; (${center}-(${sixtypercent})/2) / 1" |bc`
 
+        startloc=`echo "scale=0 ; (${center}-(${tilda_width})/2) / 1" |bc`
 
-        sed -e "s/^max_width.*$/max_width = $sixtypercent/" \
-            -e "s/^max_height.*$/max_height = $quarter_height/" \
-            -e "s/^x_pos.*$/x_pos = $startloc/g" /etc/tilda_config > ~/.tilda/config_0
+        sed -e "s/^max_width.*$/max_width = $tilda_width/" \
+            -e "s/^max_height.*$/max_height = $tilda_height/" \
+            -e "s/^x_pos.*$/x_pos = $startloc/g" /etc/tilda_config > ~/.config/tilda/config_0
 
         /usr/bin/tilda -h &
-
     fi
 }
 
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 5501add..9c7d50b 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
-pkgver=8.3
-pkgrel=24
+pkgver=8.4
+pkgrel=1
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -79,7 +79,7 @@ package() {
 
 }
 
-md5sums=('76842f8cff548d2c1289e0992a8b84dd'
+md5sums=('c03d5e54f00e404c561c7dc69fff9168'
          'ad5e144999b6f37931dea799c2761c7e'
          'de32a1c50101265dd7f6ca5037f7a26a'
          '2d7b8414ddce5f401331342ac1529c22'
-- 
cgit v0.12